ptrex

COM Object Browser

16 posts in this topic

#1 ·  Posted (edited)

COM Object Browser

This is something that could be a start of a COM object browser.

Open a COM-DLL or a TLB

Object_BrowserGui.au3

New version for 3.2.10.0 and higher

Object_BrowserGui_New.au3

Needs still improvement but it's a start.

Regards,

ptrex

Edited by ptrex

Share this post


Link to post
Share on other sites



COM Object Browser

This is something that could be a start of a COM object browser.

Open a COM-DLL or a TLB

Object_BrowserGui.au3

Needs still improvement but it's a start.

Regards,

ptrex

Hi god of Autoit,

i like the tool very much maybe you can integrate something like an com object list like the one you have in koda or visual studio.

a bug report: if you open a dll that does not has a com server the app crashes, maybe some more error handling, except this, i like it very much, nice work, like always.


$a=StringSplit("547275737420796F757220546563686E6F6C75737421","")For $b=1 To UBound($a)+(-1*-1*-1)step(2^4/8);&$b+=1*2/40*µ&Asc(4)Assign("c",Eval("c")&Chr(Dec($a[$b]&$a[$b+1])))''Chr("a")&"HI"Next;time_U&r34d,ths,U-may=get$the&c.l.u.e;b3st-regards,JRSmile;MsgBox(0x000000,"",Eval("c"));PiEs:d0nt+*b3.s4d.4ft3r.1st-try:-)

Share this post


Link to post
Share on other sites

@JRSmile / Manadar

Thanks for the feedback.

I am trying toward the layout of the MS VBA Object browser in MS Office.

It is still "unders consstruction", so there might be some errors here and this.

I will look into this, and keep you all posted.

Regards,

ptrex

Share this post


Link to post
Share on other sites

Using Autoit 3.2.10

the tool is not working


[quote]Baby you're all that I want, When you're lyin' here in my armsI'm findin' it hard to believe, We're in heavenAnd love is all that I need , And I found it there in your heartIt isn't too hard to see, We're in heaven .Bryan Adams[/quote].............................................................................[u]AUTOIT[/u]

Share this post


Link to post
Share on other sites

Using Autoit 3.2.10

the tool is not working

Same here

Share this post


Link to post
Share on other sites

@all

To get it going in the latest version of AU3 you will need to translate these to the new syntax.

_GUICtrlListViewSetColumnWidth()

_GUICtrlTreeViewDeleteAllItems()

_GUICtrlTreeViewSort()

_GUICtrlTreeViewGetParentID()

_GUICtrlListViewDeleteAllItems()

_GUICtrlListViewGetItemText()

regards

ptrex

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

I tryed to rewrite code with new gui functions but i got error

com browser.au3(18,27) : ERROR: $NM_FIRST previously declared as a 'Const'

Global Const $NM_FIRST = 0

~~~~~~~~~~~~~~~~~~~~~~~~~~^

com browser.au3(19,41) : ERROR: $NM_CLICK previously declared as a 'Const'

Global Const $NM_CLICK = ($NM_FIRST - 2)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^

com browser.au3(20,42) : ERROR: $NM_DBLCLK previously declared as a 'Const'

Global Const $NM_DBLCLK = ($NM_FIRST - 3)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^

com browser.au3(21,42) : ERROR: $NM_RCLICK previously declared as a 'Const'

Global Const $NM_RCLICK = ($NM_FIRST - 5)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^

com browser.au3(22,45) : ERROR: $TVM_HITTEST previously declared as a 'Const'

Global Const $TVM_HITTEST = ($TV_FIRST + 17)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^

com browser.au3 - 5 error(s), 0 warning(s)

Edited by MetalSpongebob

Noob but ethical

Share this post


Link to post
Share on other sites

Error on Script >>

I'm Use Auto it Version 3, 2, 10, 0 Please ...

Share this post


Link to post
Share on other sites

#11 ·  Posted (edited)

@all

Added a new version for 3.2.10.0 and higher.

regards,

ptrex

Need to change line 132 to:

_GUICtrlTreeView_DeleteAll($TreeView)
Edited by GaryFrost

SciTE for AutoItDirections for Submitting Standard UDFs

 

Don't argue with an idiot; people watching may not be able to tell the difference.

 

Share this post


Link to post
Share on other sites

I tried to run this script (compiled with 3.2.10) on new Windows7 64bit with 32bit DLL/OCX files and there are errors

COM Error - err.windescription: Variable must be of type 'Object'.

It seems that

$tliTypeLibInfo =ObjCreate("TLI.TypeLibInfo")

or

For $tliTypeInfo In $tliTypeLibInfo.TypeInfos

are not valid

Is there any hint for correction or link to other tool for browsing COM DLLs?

Share this post


Link to post
Share on other sites

I'm not sure if you mean autoit, but I've uses olewiew before.

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=7007

Thanks.

I need to know what ProgIDs are inside "C:\Program Files (x86)\Common Files\microsoft shared\OFFICE14\MSO.DLL"

OLEView is very good but unfortunatelly for MS Office it doesn't show all desired information.

I found another AU3 similar project

Share this post


Link to post
Share on other sites

Hi Zedna,

I see that you already got an alternative working.

In order to get the Object Browser running on an x64 machine you need to do some fiddling.

First you need to get hold of the x86 TLBINF32.DLL

And register it on the X64 machine. Which goes as follows.

So regsvr32.exe it in the correct directory:

x64-EXEs are stored in: \Windows\system32

x86-EXEs are stored in: \Windows\syswow64

Then add the #AutoIt3Wrapper_UseX64=N parameter and you're done.

Rgds,

ptrex

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now