Sign in to follow this  
Followers 0
caramen

Dont know why ^^ ... very shord help

12 posts in this topic

Hi this is caramen i am writing a news script atm and need a help about a cheap thing...

i got this:

$SettingsFile = @SCRIPTDIR & '\Settings.ini'

$Didi = IniRead ($SettingsFile, 'D2 Path', 'Diablo II', "ERROR")

Func Lunch()
    Run ('Loader.exe','$Didi')
    Sleep($DeleyA)
    WinActivate ( "Diablo II" )
    Sleep (500)
    WinMove("Diablo II","",0,0)
EndFunc

it is'nt the only part of my script but every thing work perfectly exepct this line

Run ('Loader.exe','$Didi')

i got bad repertory errore on the screen

[D2 Path]
Diablo II=C:\Program Files\Diablo II\

any help :) ? i have try a lot of thing but hmmmmmmmmmm NEED HELP muttley

thx before

Share this post


Link to post
Share on other sites



Is Loader located in the same directory as the script?

The variable should not be surrounded by quotes!

Run ('Loader.exe',$Didi)

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Is Loader located in the same directory as the script?

The variable should not be surrounded by quotes!

Run ('Loader.exe',$Didi)
exactly what i have tried :)

and for answer to your question no the loader is in C:\Program Files\Diablo II\

like the ini file say it :(

this is the first func of my script

and i just whant to start a game before continu everything i can make all user do it themself but it's more apreciate if the script do it for them muttley

thx for helping :P

Share this post


Link to post
Share on other sites

When that is the case it should look like:

Run ($Didi & 'Loader.exe')

Function Reference

Run

--------------------------------------------------------------------------------

Runs an external program.

Run ( "filename" , "workingdir" )

muttley !!!

i am trying now :/ and come back to say you

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

Function Reference

Run

--------------------------------------------------------------------------------

Runs an external program.

Run ( "filename" , "workingdir" )

muttley !!!

i am trying now :/ and come back to say you

As has been stated many time in this forum: WorkDir in NOT related to the path where the Executable is located!

The first parameter needs to include the Fully qualified path when the EXE isn't in one of the directories specified in the PATH environment variable.

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

Work thx problem solved Last thing plz

i got some special propriety hmmmmmmmmmmmmmm how to tell it :

i use the loader by using a shord cute on my desk

i right click on the shordcut icon

propriety

and for the taget path of the shord cut on my desk i need to specify that :

"C:\Program Files\Diablo II\Loader.exe" -w -title "Diablo II" how can i do this muttley ??

Edited by caramen

Share this post


Link to post
Share on other sites

Work thx problem solved Last thing plz

i got some special propriety hmmmmmmmmmmmmmm how to tell it :

i use the loader by using a shord cute on my desk

i right click on the shordcut icon

propriety

and for the taget path of the shord cut on my desk i need to specify that :

"C:\Program Files\Diablo II\Loader.exe" -w -title "Diablo II" how can i do this :) ??

What about you start trying it first yourselve and only when you get stuck you come back and ask it on this forum?

.. and please don't PM me for these type of support questions.... I am not going to respond to that unless you are willing to pay muttley


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

What about you start trying it first yourselve and only when you get stuck you come back and ask it on this forum?

.. and please don't PM me for these type of support questions.... I am not going to respond to that unless you are willing to pay muttley

erm support forum... thx very much for help sorry wast your time :/ bb

Share this post


Link to post
Share on other sites

erm support forum... thx very much for help sorry wast your time :/ bb

I have been nice to you but do not appreciate these type of comments and its tone.

I am done with you for the moment.


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#11 ·  Posted (edited)

I have been nice to you but do not appreciate these type of comments and its tone.

100% true

i know u just helped me and i thanks you very much for that. i realy dont like what i will say with my ugly english but...

i dont anderstand/agree this comment you asking for payback if i whant you help me, that 's realy realy sad dont forget where you are man... you got better knowledge but that's not alow you to speack like that. You're not a master... anyway

there is a little difference between

> AutoIt Forums > AutoIt v3 > General Help and Support

and

> AutoIt Forums > AutoIt v3 > Request Script Support

i dont requested your help exept in my MP after your third answer

it s just pathetic i am sorry

THX again for help.

Edited by caramen

Share this post


Link to post
Share on other sites

#12 ·  Posted (edited)

I have no good feel how to read this last post but my general issue here is that we expect you to put in some effort before asking questions here.

That means you check/read the helpfile, search the forum to see if others already asked this question and only then post your question.

As you are asking about starting diablo II, it is impossible you tried searching because I have seen this question at least a dozen times.

Now I assume you native language is french but I am pretty sure your post wasn't intended to nice towards me, but a tipical reaction I see when (young) folks don't get what they want quickly.

As said, I am done for a while with you but just wanted to explain where I am coming from.

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0