Sign in to follow this  
Followers 0
SpecTRe

Help for macro working background

13 posts in this topic

#1 ·  Posted (edited)

Hello,

I have written a macro first time reading and searching for a few hours and now i am stuck ;);) Macro compiles and runs without any error but it does not work. Simply, it does nothing.

Need help :)

;~ **************************************************
;~ W.o.T Makro
;~  28/09/2010
;~
;~ SpecTRe
;~
;~ **************************************************
HotKeySet("{Pause}", "Durdur")
HotKeySet("{ESC}", "Çıkış")

Global $Paused, $WinTitle ='W.o.T. Client'
TogglePause()

While 1
    If WinExists($WinTitle) Then
            ControlClick($WinTitle,"840","160","Left",1)
                Sleep(500)
            ControlClick($WinTitle,"840","45","Left",1)
                Sleep(500)

            ControlSend($WinTitle, "", "", "ESC", 1)
                Sleep(200)
            ControlSend($WinTitle, "", "", "ESC", 1)
                Sleep(200)


    Else
        MsgBox(0, "W.o.T. açık değil", "W.o.T. Penceresi bulunamadı!"&@CRLF&"Macrodan önce oyunu çalıştırıp login olunuz."&@CRLF&""&@CRLF&"Macro kapanacak.", "", "")
        Exit
    EndIf
WEnd

Func TogglePause()
    $Paused = NOT $Paused
    While $Paused
        sleep(100)
        ToolTip('W.o.T Macro Durduruldu! (Pause = Aktifleştir - Esc = Çıkış)',10,10)
    WEnd
    ToolTip("")
EndFunc

Func Terminate()
    Exit 0
EndFunc
Edited by SpecTRe

Share this post


Link to post
Share on other sites



World of Tanks ?

Is this some kind of antena you have that nobody knows anything about ?

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

3 posts and no help so far, wow.

Yes it is for World of Tanks and no it is not an actual bot. It just enters a battle and exits.

Need serious help.

Edited by SpecTRe

Share this post


Link to post
Share on other sites

BUMP

Seriously, noone nice enough to spare few minutes?

Share this post


Link to post
Share on other sites

Seriously, noone nice enough to spare few minutes?

Worst community i have ever seen.

Share this post


Link to post
Share on other sites

Bye...

Truth hurts?

Share this post


Link to post
Share on other sites

SpecTRe, this is a fine community, I have had absolutely tons of help from many people here.

Dont get upset, it isnt anything personal, Its been decided that helping people make bots, is not the way the developers of Autoit want this forum to go.

You can debate what is a bot until you are blue in the face, and its all been said before.

Jos pointed out that most people dont hang around in a community they think is the worst ever, they move along.

Just leave game bots/macros alone and stick to other tasks, you will get all the help you need.

Just a little tip though, try to debug your scripts a little before posting and have some info about the specific problem, something other than 'it dosent work'.

Good luck.


AutoIt Absolute Beginners    Require a serial    Pause Script    Video Tutorials by Morthawt   ipify 

Monkey's are, like, natures humans.

Share this post


Link to post
Share on other sites

top answer on google "W.o.T. Client".

That, and it's based on a template that keeps coming back in relation game bots.

@Spectre: The forum rules regarding game automation, as well as bumping are clear. No exceptions no matter how nice of a person you are!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0