Sign in to follow this  
Followers 0
johnmcloud

F1 (Help) - Bug

13 posts in this topic

#1 ·  Posted (edited)

Hi guys,

I have just update to the new version of autoit, 3.3.8.0

On my virtual system ( Windows XP SP3 ) i have noticed that I can not open the Help ( F1 ) when I click on a function. If i open the guide from start menù working fine.

I have try to:

1) Save the file .au3

2) Install Full Scite ( EDIT: Full Scite work )

3) Use the portable version by guinness

4) Use the zipped version of autoit-v3-sfx

With the previus version ( 3.3.6.0 ) i don't have this problem. It's really annoying.

EDIT: Tested again to make sure:

1) Install v.3.3.6.0 --> Save .au3 with a function --> Guide work

1) Install v.3.3.6.1 --> open the same .au3 --> Guide work

2) Install v.3.3.8.0 --> open the same .au3 --> Guide NOT work

It's a virtual machine, so no previus installation on it. Every installation on a clean machine.

It's a problem of the new version.

Thanks for support

Edited by johnmcloud

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Run the below script in the setup that doesn't work and cut&paste the generated output back into this thread to see what is happening:

Opt("WinSearchChildren", 1)
#AutoIt3Wrapper_UseX64=n
Global $WM_COPYDATA = 74
Global $SciTECmd
; Get SciTE DirectorHandle
$Scite_hwnd = WinGetHandle("DirectorExtension")
; Get My GUI Handle
Global $My_Hwnd = GUICreate("AutoIt3-SciTE interface")
;Register COPYDATA message.
GUIRegisterMsg($WM_COPYDATA, "MY_WM_COPYDATA")
;
ConsoleWrite("+ Check Helpfile properties settings:" & @CRLF)
SendSciTE_Command($My_Hwnd, $Scite_hwnd, "askproperty:SciteDefaultHome")
$SciTEHome = StringReplace(StringMid($SciTECmd, StringInStr($SciTECmd, "stringinfo:") + 11), "\\", "\")
SendSciTE_Command($My_Hwnd, $Scite_hwnd, "askproperty:command.help.$(au3)")
SendSciTE_Command($My_Hwnd, $Scite_hwnd, "askproperty:command.help.subsystem.$(au3)")
ConsoleWrite("+ autoit3.chm Exists check:" & FileExists($SciTEHome & "\..\autoit3.chm") & @CRLF)
ConsoleWrite("+ Autoit3Help.exe Exists check:" & FileExists($SciTEHome & "\..\Autoit3Help.exe") & @CRLF)
ConsoleWrite("+ Run ""Autoit3Help.exe StringInstr"" Test." & @CRLF)
Run('"' & $SciTEHome & '\..\Autoit3Help.exe" "StringInstr"')
;
; Send command to SciTE
Func SendSciTE_Command($My_Hwnd, $Scite_hwnd, $sCmd)
Local $My_Dec_Hwnd = Dec(StringRight($My_Hwnd, 8))
$sCmd = ":" & $My_Dec_Hwnd & ":" & $sCmd
ConsoleWrite('-->' & $sCmd & @LF)
Local $CmdStruct = DllStructCreate('Char[' & StringLen($sCmd) + 1 & ']')
DllStructSetData($CmdStruct, 1, $sCmd)
Local $COPYDATA = DllStructCreate('Ptr;DWord;Ptr')
DllStructSetData($COPYDATA, 1, 1)
DllStructSetData($COPYDATA, 2, StringLen($sCmd) + 1)
DllStructSetData($COPYDATA, 3, DllStructGetPtr($CmdStruct))
DllCall('User32.dll', 'None', 'SendMessage', 'HWnd', $Scite_hwnd, _
   'Int', $WM_COPYDATA, 'HWnd', $My_Hwnd, _
   'Ptr', DllStructGetPtr($COPYDATA))
EndFunc   ;==>SendSciTE_Command
; Received Data from SciTE
Func MY_WM_COPYDATA($hWnd, $msg, $wParam, $lParam)
Local $COPYDATA = DllStructCreate('Ptr;DWord;Ptr', $lParam)
$SciTECmdLen = DllStructGetData($COPYDATA, 2)
Local $CmdStruct = DllStructCreate('Char[' & $SciTECmdLen + 1 & ']', DllStructGetData($COPYDATA, 3))
$SciTECmd = StringLeft(DllStructGetData($CmdStruct, 1), $SciTECmdLen)
ConsoleWrite('<--' & $SciTECmd & @LF)
EndFunc   ;==>MY_WM_COPYDATA
Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

Thanks Jos.

I have copy-paste your script in Scite and click "Compile"

With Basic Scite give me this error:

>C:program filesautoit3autoit3.exe "C:Documents and SettingsWindows XpDesktopTest.au3"
'C:program' is not recognized as an internal or external command,
operable program or batch file.
>Exit code: 1 Time: 0.203

With Full Scite:

>"C:ProgrammiAutoIt3SciTEAutoIt3WrapperAutoIt3Wrapper.exe" /ShowGui /in "C:Documents and SettingsWindows XpDesktopTest.au3"
+>11:27:05 Starting AutoIt3Wrapper v.2.1.0.8    Environment(Language:0410  Keyboard:00000410  OS:WIN_XP/Service Pack 3  CPU:X64 OS:X86)
-> No changes made..
>Exit code: 0   Time: 1.617

I have start the script and now the help work, but the help work only if SciteFull is installed, for the basic version don't work, as you can see. I don't understand why say "No changes made..", before don't work.

Thanks again for support

EDIT: So the result is:

3.3.8.0 (autoit-v3-setup) --> Help NOT work

3.3.8.0 (SciTE4AutoIt3) --> Help work ( don't need any fix, my mistake )

3.3.6.1 (autoit-v3.3.6.1-setup) --> Help work

3.3.6.1 (SciTE4AutoIt3) --> Help work

3.3.6.0 (autoit-v3.3.6.0-setup) --> Help work

3.3.6.0 (SciTE4AutoIt3) --> Help work

The problem is only with basic version of SciTe ( autoit-v3-setup) in v3.3.8.0. The basic version of v3.3.6.0/v3.3.6.1 (autoit-v3.3.6.0-setup - autoit-v3.3.6.1-setup) the help working by clicking on a function, only with the basic SciTe of v3.3.8.0 not work.

Edited by johnmcloud

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

>"C:ProgrammiAutoIt3SciTEAutoIt3WrapperAutoIt3Wrapper.exe" /run /prod /ErrorStdOut /in "C:Documents and SettingsWindows XpDesktopTestFi.au3" /UserParams  
+>12:01:14 Starting AutoIt3Wrapper v.2.1.0.8    Environment(Language:0410  Keyboard:00000410  OS:WIN_XP/Service Pack 3  CPU:X64 OS:X86)
>Running AU3Check (1.54.22.0)  from:C:ProgrammiAutoIt3
+>12:01:14 AU3Check ended.rc:0
>Running:(3.3.8.0):C:ProgrammiAutoIt3autoit3.exe "C:Documents and SettingsWindows XpDesktopTestFi.au3"  
+ Check Helpfile properties settings:
-->:393586:askproperty:SciteDefaultHome
<--:393586:macro:stringinfo:C:ProgrammiAutoIt3SciTE
-->:393586:askproperty:command.help.$(au3)
<--:393586:macro:stringinfo:$(SciteDefaultHome)..Autoit3Help.exe "$(CurrentWord)"
-->:393586:askproperty:command.help.subsystem.$(au3)
<--:393586:macro:stringinfo:2
+ autoit3.chm Exists check:1
+ Autoit3Help.exe Exists check:1
+ Run "Autoit3Help.exe StringInstr" Test.
+>12:01:15 AutoIT3.exe ended.rc:0
>Exit code: 0   Time: 1.978

It's open the guide with StringInStr. The problem is with basic Scite, the guide with full version working fine

Edited by johnmcloud

Share this post


Link to post
Share on other sites

It's open the guide with StringInStr. The problem is with basic Scite, with full version working fine

Forget about Basic SciTE to work at this moment. I have done several modification for the upcoming release, but the current version will not work in none English or X64 environment as it hardcodes the Path to "c:program filesAutoit3".

Since you have an Italian installation, it won't work.


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

If i change the install dir to "C:Program FilesAutoit3" the guide working also on basic version, so it's only a path problem

So i need to wait a new version or install into this dir for the moment, or install the full Scite

Edited by johnmcloud

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

If i change the install dir to "C:Program FilesAutoit3" the guide working also on basic version, so it's only a path problem

So i need to wait a new version or install into this dir for the moment, or install the full Scite

Correct, or you can use this version of SciTE-Lite which will be in the next AutoIt3 installer. Just run the AutoIt3 installer and replace SciTE with this version. Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Thanks for you help.

Just for curiosity, when will be released the next version?

Share this post


Link to post
Share on other sites

Thanks for you help.

Just for curiosity, when will be released the next version?

I will be releasing a new SciTE4AutoIt3 installer soon with the new SciTE v 3.xx after testing is successful, but have no idea when the next production version of AutoIt3 will be release.

So, did the Beta version of SciTE lite work for you when you have just AutoIt3 installed?

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

So, did the Beta version of SciTE lite work for you when you have just AutoIt3 installed?

Jos

No, give me error.

"Impossible to find MSVCR100D.dll etc..."

Share this post


Link to post
Share on other sites

No, give me error.

"Impossible to find MSVCR100D.dll etc..."

Guess I copied the wrong (debug) version... could you give it a try again with the current version?

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#13 ·  Posted (edited)

Guess I copied the wrong (debug) version... could you give it a try again with the current version?

Yes, work, i have instllaed the wrong version yesterday ( the setup has the same name for both version :) )

The Help work fine now

Thanks Jos for support, hope the new version coming soon.

Edited by johnmcloud

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Similar Content

    • WiorDi37
      By WiorDi37
      Hello, Everyone!
      I want when clicking the exit button the window will close. If content changes upon exit the program will automatically choose not save.
      Look forward to the help, thanks.
      #include <ButtonConstants.au3> #include <GUIConstantsEx.au3> #include <WindowsConstants.au3> #include <AutoItConstants.au3> $GUI = GUICreate("Form1", 220, 119, 192, 124, $WS_SYSMENU) GUISetFont(10, 400, 0, "Tahoma") GUICtrlCreateGroup("Chuẩn bị trình chiếu", 16, 16, 185, 65) $ok_Button = GUICtrlCreateButton("Ok", 32, 48, 75, 25) $exit_Button = GUICtrlCreateButton("Exit", 112, 48, 75, 25) GUICtrlCreateGroup("", -99, -99, 1, 1) GUISetState(@SW_SHOW) While 1 $nMsg = GUIGetMsg() Switch $nMsg Case $ok_Button ShellExecute(@MyDocumentsDir&'\Dich-thuat\Short-Document.pdf', "", "", Default, @SW_MAXIMIZE) WinWaitActive("Data and Computer Communications (Eighth Edition) - Google Chrome") ShellExecute(@MyDocumentsDir&'\Dich-thuat\Document.rtf', "", "", Default, @SW_MAXIMIZE) WinWaitActive("Document.rtf [Compatibility Mode] - Word") ShellExecute(@MyDocumentsDir&'\Dich-thuat\Presentation1.pptx', "", "", Default, @SW_MAXIMIZE) WinWaitActive("Presentation1.pptx - PowerPoint") MouseClick("left", 1381, 886, 1) Sleep(2000) MsgBox(64, "Thông báo", "Đã chuẩn bị xong") Case $exit_Button WinClose("Presentation1.pptx - PowerPoint") ;I need help handling this place Case $GUI_EVENT_CLOSE Exit EndSwitch WEnd  

    • badcoder123
      By badcoder123
      Hey everyone,
      I've been messing around with some new things and adlibs look extremely useful/interesting, however, I can't seem to get it to work.. Here's what I have
      HotKeySet("{F1}", "_Exit") $qCount = 1 Global $_Timer AdlibRegister($_Timer, 1000) AdlibUnRegister($_Timer) While 1 SoundPlay(@WindowsDir & "\media\tada.wav", 1) $qCount += 1 ToolTip('"Tada" has been played ' & $qCount & " times",200,200) WEnd Func _Timer() Local Static $iCount += 1 ConsoleWrite($iCount) If $iCount = 20 Then ConsoleWrite("iCount is at " & $iCount) EndFunc Func _Exit() Exit EndFunc Basically I want it to call the _Timer function but it doesn't seem to work :/ any ideas?
    • DagSa
      By DagSa
      Try to find a solution for help files to my autoit executable.
      Its installed from simple XP-POS cash computers to desktop with windows 7, 8, 10.
      The compiled AutoIt program itself work everywhere, but the help file??
      I need a help file called from from the program and I don't really know what working best in all OS platforms.
      1. A wordfile is helpful enough, but word is not installed everywhere.
      2. RTF is very big files with pictures.
      3. I could save it as pdf, but not all have it either.
      4. Tried  .MHT file, but downside is browser could cover hole screen if browser closed this way. I have not found any way to resize it to specific size when open up.
      5. Use of IE.au3 lib. Well it could open mht files ,but always got question about use it as default browser or not. Think this also make IE browser lose control so I could not resize.
      6. Look at making a  .CHM file, but I don't think its the future do use that format. (.hlp is no no and old)

      Any tips of do it in autoit or make a call to open up in some nice format working everywhere.
       
    • au3leecher
      By au3leecher
      Hellow everybody,
      I tryed to manipulate a game called "Assault Cube" which is a easy beginning in coding. I run the code but the wished value doesn't change, i don't understand why.
      The Pointers are fine, I checked that the pointers don't change every time while restart the game.
      My Code:
      <snip>
      _____________________________________________________________________________________________________________________________________________________________________________________________
      Checklist:
      The Offsets are 18C & 4
      In Cheat Engine: ("ac_client.exe"+0010F418) <- Pointer
      4 Bytes = 'dword'
       
    • geekyworld
      By geekyworld
      Hi. I want to read the help file on my Kindle ebook reader (to protect my eyes). Is it available in Kindle or epub format? I tried converting it myself but the results were not very good.
      --Thanks!