Jump to content

Recommended Posts

Okay so basically I have another problem with my script again, Not exactly the script it's self but more finding how to add a certain pixel color into it. I've made a few attempts and got it close but not close enough. I'm trying to make the mouse hover over the Pause Button on my Media Player. I'll add the Pixel color into the attachments. If someone could show me how to find the Pixel color in the form of the line "PixelSearch( 0, 0, $i, 768, 0xFF0000, 10 )" then I'd be the most greatful noobie that ever existed

misc4.au3

post-73895-0-34342300-1340485464_thumb.j

Share this post


Link to post
Share on other sites

Tools -> AutoIT info window.

Click and drag the target to where the pause button is and let go. In the info window, click on the mouse tab and it will have the color of where you let go of the target.

Share this post


Link to post
Share on other sites

I gave that a Shot. Now it's attracted to one of my desktop Icons but not the pause button. I tried multiple times but it just doesn't seem to wan't to move to the button.

Share this post


Link to post
Share on other sites

PixelSearch() returns after it finds the first instance of a colour in the search area.

There are a number of ways to try, I'll list two of them.

1. Change the direction of your search (see help file)

2. Find the position of the GUI (WinGetPos) and search only that area.


AutoIt Absolute Beginners    Require a serial    Pause Script    Video Tutorials by Morthawt   ipify 

Monkey's are, like, natures humans.

Share this post


Link to post
Share on other sites

Is there a way I could get it to search the entire screen for the Pixel instead of just having it in one place with the (Wingetpos)? Because I often move my windows around so it won't always be in "fullscreen mode"

Share this post


Link to post
Share on other sites

yes but I realise I may not have expanded as much as I should of. Basically I know the script works. Because It follows a form of red on my desktop. But it doesn't have the same connection for when I run the Player, (even in full screen) it's almost as if it's a different red from the one on my desktop. The exact red of my pause button is displayed in the attachment part of the post. But for some reason when I do the Window AutoIT tool thing it gives me "0x14CF0000" as the color but that doesn't seem to be correct as it isn't attracted to that shade. The whole line I have is " $coord = PixelSearch( 0, 0, $i, 650, 0x14CF0000, 10 )"

Share this post


Link to post
Share on other sites

I see, I'm just guessing here, but it sounds like media player might employ the same method

which some full screen games do, which hinder the detection of pixels.

I don't know anything about that sorry. And I could be wrong.


AutoIt Absolute Beginners    Require a serial    Pause Script    Video Tutorials by Morthawt   ipify 

Monkey's are, like, natures humans.

Share this post


Link to post
Share on other sites

mokay, well is there away to maybe convert it to RGB? that'd be a simpler form I guess. Alot easier to get exact colors or even test colors. or maybe just have an imbetween so like imbetween red and purple?

Share this post


Link to post
Share on other sites

The problem here is that you are not understanding how the pixel search works. If you r searching for a red pixel and there is an icon on your desktop, it will return only the only one time which is the first instance that is true. You have the exact color. Using rgb will not change anything. It will still return the same thing.

I also don't understand why your pause and play button is red but that's another subject. If you really want to pause and play, look into controlclick because that will not require the window to be showing.

Share this post


Link to post
Share on other sites

well i don't know how to describe the button it'self but it's like a cirlce with a rectangle inside. and it's red. so thats that. but anyway. If the pixel search wont work is there another possible way i could do a search?

Share this post


Link to post
Share on other sites

but i saw u used this: ( 0, 0, $i, 650, 0x14CF0000, 10 ) as your color but isnt the 10 at the end shade?

if so try 1 or 0 because at 10 it will detect yellow if its on ur screen or green instead of red 1 is ok if ur not sure what red it is 0 it only gets to the specified color.

as for the fullscreen problem maybe its solved this way.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By SOCCERMOMMY
      Hello all,
      First time posting; please excuse my noobness as I am self-taught over a short period with very little programming experience.  However, I am trying to create a simple program that retrieves college basketball scores from the web, puts them into an array and writes to excel.  Ultimately I want to create an additional variable that would be a date range so the program can cycle through many pages and retrieve years worth of information at a time.  For now, I am working on a single day.  Here is where I am stuck:  I want to use _StringBetween to isolate team names while considering whether they are "winners" or "losers".  Here is a snippet from the source code i am dealing with:
      <tr class="winner">   <td><a href="/teams/MIN/2020.html">Minnesota</a></td>   <td class="right">118</td>   <td class="right gamelink">   <a href="/boxscores/202001050CLE.html">Final</a>       </td>   </tr>   <tr class="loser">   <td><a href="/teams/CLE/2020.html">Cleveland</a></td>   <td class="right">103</td>   <td class="right">&nbsp;   </td>   </tr>   </tbody>   </table>
       
      My thought was to use _Stringbetween( '<tr class ="loser> <td>' & @CRLF & '<td><a href="/teams/', '</a></td>')  
      However, i believe I am using the @CRLF out of context.  Is there another way to identify page breaks within the stringbetween function?  Complete script is attached for reference.  Appreciate the help and patience as I try to piece it all together   
      Muchos gracias.
       
       
      basketball scores x2.au3
    • By v120
      Original posted by CoePSX
       
       
       
       
      Drawing_Script.au3
    • By BetaLeaf
      What is Rollbar?
      Rollbar provides real-time error alerting & debugging tools for developers. Learn more about it at https://rollbar.com/product/
      Demo: https://rollbar.com/demo/demo/
      Screenshot:
      Instructions: (RollbarTest.au3)
      ; Include RollbarSDK #include "RollbarSDK.au3" ;Turns on ConsoleWrite debugging override. ;Global $Rollbar_Debug=False ; Initialize RollbarSDK with the project's API key. ; Parameters ....: $__Rollbar_sToken - [Required] Go to https://rollbar.com/<User>/<ProjectName>/settings/access_tokens/ for your project. Use the token for post_server_item. _Rollbar_Init("eaa8464a4082eeabd9454465b8f0c0af") ; Write code that causes an error you want to catch, then call ; _Rollbar_Send ; Parameters ....: $__Rollbar_sErrorLevel - [Required] Must be one of the following values: Debug, Info, Warning, Error, Critical. ; $__Rollbar_sMessage - [Required] The message to be sent. This should contain any useful debugging info that will help you debug. ; $__Rollbar_sMessageSummary - [Optional] A string that will be used as the title of the Item occurrences will be grouped into. Max length 255 characters. If omitted, Rollbar will determine this on the backend. _Rollbar_Send("Debug", "This is an debug message. If you received this, you were successful!", "Debug Message") _Rollbar_Send("Info", "This is a test message. If you received this, you were successful!", "Info Message") _Rollbar_Send("Warning", "This is an warning message. If you received this, you were successful!", "Warning Message") _Rollbar_Send("Error", "This is an error message. If you received this, you were successful!", "Error Message") _Rollbar_Send("Critical", "This is an critical message. If you received this, you were successful!", "Critical Message") _Rollbar_Send("Info", "This is a test message. If you received this, you were successful!") ;No Message ; Rollbar_Send's helper functions ; Parameters ....: $__Rollbar_sMessage - [Required] The message to be sent. This should contain any useful debugging info that will help you debug. ; $__Rollbar_sMessageSummary - [Optional] A string that will be used as the title of the Item occurrences will be grouped into. Max length 255 characters. If omitted, Rollbar will determine this on the backend. _Rollbar_SendDebug("This is an debug message. If you received this, you were successful!", "Debug Message") _Rollbar_SendInfo("This is a test message. If you received this, you were successful!", "Info Message") _Rollbar_SendWarning("This is an warning message. If you received this, you were successful!", "Warning Message") _Rollbar_SendError("This is an error message. If you received this, you were successful!", "Error Message") _Rollbar_SendCritical("This is an critical message. If you received this, you were successful!", "Critical Message") ; Usable Example Local $sImportantFile = "C:\NOTAREALFILE_1234554321.txt" Switch FileExists($sImportantFile) Case True MsgBox(0, "Example Script", "An important file was found. Continuing...") Case Else _Rollbar_SendCritical('An important file was missing. Halting... File: "' & $sImportantFile & '"', 'Important file "' & $sImportantFile & '" is missing.') EndSwitch Notes: Please comment your feedback, advice, & suggestions below. While this is only a proof of concept, I will expand its feature set for everyone to use. 
      Right now, it is fully functional but not tested in production.
       
       
      Changelog:
      RollbarSDK.au3
      RollbarTest.au3
      v0.2
       
      v0.1.1
       
    • By Dwalfware
      Hi Folks
      Can not get my head around this one.
      This function gets the DNS object s
      If you have two DNS entries fine. but if you have only one! Trouble
      $objItem.DNSServerSearchOrder[0] = Primary DNS
      $objItem.DNSServerSearchOrder[1] = Secondry DNS not always there. I need a way to return 0 if not there or the IP if its there.
      Or is there a way to tell how many objects there are in the "[?]"
      I'm terrible at WMI errors, thanks for help in advance.
      Func _GETcurrentNICinfo2() $oErrors = ObjEvent("AutoIt.Error", "Error_Handle") Local $DnsSecondry Local $objWMIService = ObjGet( "winmgmts:\\" & @ComputerName & "\root\CIMV2" ) Local $query = $objWMIService.ExecQuery("SELECT DNSServerSearchOrder FROM Win32_NetworkAdapterConfiguration WHERE Index = " & _GetSelectedNIC(), "WQL", 0x30 ) If @error Then Return 0 If NOT IsObj($query) Then Return 0 Else For $objItem In $query Return $objItem.DNSServerSearchOrder[1] next Endif EndFunc  
    • By dejhost
      Happy New Year everyone!
      I would like to extract the color values of certain pixels in an image.  This is how I picture the workflow: 
      User opens an image of his choice. Image is shown on the screen. User draws a line into the image. This happens by marking the startpixel and the endpixel of the line The line is drawn, so the user can check visually if he is happy with the line.  The following pixel based properties belonging to the line are stored in Excel: X-Coordinate Y-Coordinate Color Value Additional operations: Extracting for max- and min. color values; Statistical operations.   Browsing through the helpfile of AutoIt I find plenty of functions for treating images (e.g. GDIPlus), but I am completely unsure if Autoit will get me there. Should I read the entire image into an array? Should I rather attempt to script an external image software (e.g. IrfanView, Gimp)?
      I would be very thankful if someone could give some recommendations and maybe list a couple of the most important commands to use.
      Thank you very much.
      Dejhost
       
       
×
×
  • Create New...