Jump to content

Recommended Posts

Need help logging into the web interface of my WhatsUP gold server for an overhead display in our IT dept.

Essentially I want the script to open IE, navigate to our servers web address, login to whats up, then kill IE and start the process over. ( only because the web interface times out after about 10 mins and logs you out )

Currently I have this:

$user='admin'
$pass='squirrel69'

#include <IE.au3>

Dim $oIE = _IECreate('about:blank', 0, 0)

With $oIE
    .Left = 0
    .Top = 0
    .Menubar = False
    .Resizable = False
    .StatusBar = False
    .TheaterMode = True
    .Toolbar = False
    .Visible = True
EndWith

_IENavigate($oIE, 'http://srv13app8/NmConsole/CoreNm/User/DlgUserLogin/DlgUserLogin.asp')

 

I AM STUCK please help !! :)

 

Share this post


Link to post
Share on other sites

Couple of things.

Firstly, you have 7 posts, that's more than enough to know that this is Developer Chat, not General Help and Support. Secondly, please wrap your code in AutoIt tags, you can do that by selecting your code in the editor and clicking on the A button.

Good day to you.

Share this post


Link to post
Share on other sites

Need help logging into the web interface of my WhatsUP gold server for an overhead display in our IT dept.

Essentially I want the script to open IE, navigate to our servers web address, login to whats up, then kill IE and start the process over. ( only because the web interface times out after about 10 mins and logs you out )

Currently I have this:

$user='admin'$pass='squirrel69'
#include <IE.au3>
Dim $oIE = _IECreate('about:blank', 0, 0)
With $oIE.Left = 0.Top = 0.Menubar = False.Resizable = 
False.StatusBar = False.TheaterMode = True.Toolbar = 
False.Visible = TrueEndWith
_IENavigate($oIE, 'http://srv13app8/NmConsole/CoreNm/User/DlgUserLogin/DlgUserLogin.asp')

I AM STUCK please help !! :)

 

Share this post


Link to post
Share on other sites

Need a paste in of the user and password inputs (html).

You can also then do a loop waiting for the login screen again, and re-login

edit: not sure if that's a public page, but you might want to remove those creds :)

Edited by jdelaney

IEbyXPATH-Grab IE DOM objects by XPATH IEscriptRecord-Makings of an IE script recorder ExcelFromXML-Create Excel docs without excel installed GetAllWindowControls-Output all control data on a given window.

Share this post


Link to post
Share on other sites

I am not sure how to do that

I was thinking I could do a

send($user)
send("{TAB}")
send($pass)
send ("{ENTER}")

But there has to be a better way

Share this post


Link to post
Share on other sites

I wouldn not recommend sends...they can be flawed (other apps pick up the sends) or not registered by the app...controlsend is better, but still no way to validate that you are in the proper webpage input.

Download a dom viewer (like IE Developer tools)

They have a pointer tool, you can drag into the inputs (user/password), and will show you the html for that input...paste that back here...or right click the page, and view source...and search for the user/password <input>s.

Edited by jdelaney

IEbyXPATH-Grab IE DOM objects by XPATH IEscriptRecord-Makings of an IE script recorder ExcelFromXML-Create Excel docs without excel installed GetAllWindowControls-Output all control data on a given window.

Share this post


Link to post
Share on other sites

Sorry

<input name="DlgUserLogin.sPassword" class="Aspf-EditPassword" id="DlgUserLogin.sPassword" accessKey="p" style="width: 190px;" onfocus="this.className+=' Aspf-Control-Focus';" onblur="this.className='Aspf-EditPassword'" type="password" maxLength="100"/>

 

<input name="DlgUserLogin.sUserName" class="Aspf-Edit Aspf-Control-Focus" id="DlgUserLogin.sUserName" accessKey="u" style="width: 190px;" onfocus="this.className+=' Aspf-Control-Focus';" onblur="this.className='Aspf-Edit'" type="text" maxLength="100"/>

Share this post


Link to post
Share on other sites

use the _IEgetobjbyid function...pass in the dom object, and "DlgUserLogin.sPassword" to get the password, DlgUserLogin.sUserName for the user...then you can use those returned objects in _IEFormElementSetValue to set the values

do the same to get the login button (by id), and do _ieaction "click" to login

If you can't get it to work, post the new code doing the above steps.

Edited by jdelaney

IEbyXPATH-Grab IE DOM objects by XPATH IEscriptRecord-Makings of an IE script recorder ExcelFromXML-Create Excel docs without excel installed GetAllWindowControls-Output all control data on a given window.

Share this post


Link to post
Share on other sites

this is what I did, with no luck. I am new to this sorry

#include <IE.au3>_IEGetObjById(ByRef <input 
name="DlgUserLogin.sPassword" class="Aspf-EditPassword" 
id="DlgUserLogin.sPassword" accessKey="p" style="width: 190px;" 
onfocus="this.className+=' Aspf-Control-Focus';" 
onblur="this.className='Aspf-EditPassword'" type="password" 
maxLength="100"/>  , DlgUserLogin.sPassword)

It did not work

Share this post


Link to post
Share on other sites

check the help file for what to add into the function (variables)

example:

$oIE = _IECreate("Yoururl")
_IELoadWait($oIE)
$oLoginPassword = _IEGetObjById($oIE,"DlgUserLogin.sPassword")
_IEFormElementSetValue ($oLoginPassword,"yourpassword")

IEbyXPATH-Grab IE DOM objects by XPATH IEscriptRecord-Makings of an IE script recorder ExcelFromXML-Create Excel docs without excel installed GetAllWindowControls-Output all control data on a given window.

Share this post


Link to post
Share on other sites

This is what I did

#include <IE.au3>
$oIE = _IECreate("http://srv13app8/NmConsole/CoreNm/User/DlgUserLogin/DlgUserLogin.asp")_IELoadWait($oIE)$oLoginPassword 
= _IEGetObjById($oIE,"DlgUserLogin.sPassword")_IEFormElementSetValue 
($oLoginPassword,"yourpassword")

This is the error in my output window

>"C:\Program Files (x86)\AutoIt3\SciTE\..\autoit3.exe" /ErrorStdOut 
"E:\SCRIPTS\monitors\whatsup2.au3"C:\Program Files 
(x86)\AutoIt3\Include\IE.au3 (560) : ==> The requested action with this 
object has failed.:WEndWEnd^ ERROR>Exit code: 1    
Time: 0.531

Please help

Share this post


Link to post
Share on other sites

Please do no paste in text, highlight, and then click the code button...it mangles your output...press the code button THEN paste into that window.

Looks like an issue with _IELoadWait...is this consistent?  please paste in the error output again.

Edited by jdelaney

IEbyXPATH-Grab IE DOM objects by XPATH IEscriptRecord-Makings of an IE script recorder ExcelFromXML-Create Excel docs without excel installed GetAllWindowControls-Output all control data on a given window.

Share this post


Link to post
Share on other sites

#include <IE.au3>



Call ("signIn")

Func signIn ()
Global $oIE = _IECreate ("http://srv13app8/nmconsole")

Local $username = _IEGetObjByName ($oIE,"DlgUserLogin.sUserName")
Local $password = _IEGetObjByName ($oIE,"DlgUserLogin.sPassword")

_IEFormElementSetValue ($username,"admin")
_IEFormElementSetValue ($password,"squirrel")

EndFunc

Error

>"C:\Program Files (x86)\AutoIt3\SciTE\..\autoit3.exe" /ErrorStdOut "E:\SCRIPTS\monitors\whatsup.au3"
C:\Program Files (x86)\AutoIt3\Include\IE.au3 (560) : ==> The requested action with this object has failed.:
WEnd
WEnd^ ERROR
>Exit code: 1    Time: 0.732

Share this post


Link to post
Share on other sites

Just for fun, try this one...send back the consolewrite data:

Func signIn()
    Global $oIE = _IECreate("http://srv13app8/nmconsole")
    If IsObj($oIE) Then
        ConsoleWrite("Created IE and navigated" & @CRLF)
    Else
        ConsoleWrite("UNable to create IE and navigate" & @CRLF)
        Return False
    EndIf

    If _IELoadWait($oIE) Then
        ConsoleWrite("Page loaded" & @CRLF)
    Else
        ConsoleWrite("UNable to load page" & @CRLF)
        Return False
    EndIf

    Local $username = _IEGetObjByName($oIE, "DlgUserLogin.sUserName")
    If IsObj($username) Then
        ConsoleWrite("Able to find login node" & @CRLF)
    Else
        ConsoleWrite("UNable to find login node" & @CRLF)
        Return False
    EndIf

    Local $password = _IEGetObjByName($oIE, "DlgUserLogin.sPassword")
    If IsObj($password) Then
        ConsoleWrite("Able to find password node" & @CRLF)
    Else
        ConsoleWrite("UNable to find password node" & @CRLF)
        Return False
    EndIf

    If _IEFormElementSetValue($username, "admin") Then
        ConsoleWrite("Able to set login node" & @CRLF)
    Else
        ConsoleWrite("UNable to set login node" & @CRLF)
        Return False
    EndIf

    If _IEFormElementSetValue($password, "squirrel") Then
        ConsoleWrite("Able to set password node" & @CRLF)
        Return True
    Else
        ConsoleWrite("UNable to set password node" & @CRLF)
        Return False
    EndIf

EndFunc   ;==>signIn
Edited by jdelaney

IEbyXPATH-Grab IE DOM objects by XPATH IEscriptRecord-Makings of an IE script recorder ExcelFromXML-Create Excel docs without excel installed GetAllWindowControls-Output all control data on a given window.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By SkysLastChance
      I am pretty sure the site that I am using was updated and now I am not seeing the same tags/elements that I used to. I tried using a UIAspy to see if I could grab them that way with no luck. 
      What do I need to do to be able to automate this again. Are the elements hidden somewhere?
      Instead of highlighting established account is highlights all of the web page almost. How can I get to the detail again? 
      I used to grab establish account by the name. Now I have nothing to even try to grab. 
      There are not elements in the event viewer either. 
       


       
      This is what happens when I try to inspect the element and click established account. 
      I get the same type of results in chrome
    • By yffulf
      Is there probably a way to click ie popup button and hide or invisible popup button in the same time?
      I try to use WinSetState @SW_hide ,
      the result is ie crashing or no response because button hide and the next click command won't work...
      $oForm=_IEFormGetObjByName($oIE,"form1") $obutton=_IEFormElementGetObjByName($oForm,"btn_OK") $hWnd = _IEPropertyGet($oIE, "hwnd") _IEAction($obutton,"focus") ControlSend($hWnd, "", "[CLASS:Internet Explorer_Server; INSTANCE:1]", "{Enter}") WinWait("", "確定存檔嗎?") WinSetState("","確定存檔嗎?",@SW_Hide) ControlClick("", "確定存檔嗎?", "[CLASS:Button; TEXT:確定; Instance:1;]")  
    • By _leo_
      Hey there!
      I am having a problem with clicking a button in IE. As you can see in the code, there would be a class name to click it, but since this button exists several times with exactly the same code, I can only use the "Noch nicht veröffentlicht" to separate it from the others. But this part is just pure text without any classification. 
      "<div class="checkmark" data-v-1e5b1f70=""><svg xmlns="http://www.w3.org/2000/svg" class="icon" viewBox="0 0 16 16" data-v-1e5b1f70=""><circle cx="8" cy="8" r="8" data-v-1e5b1f70="" /></svg></div>Noch nicht veröffentlicht"
      I was trying to click it with:
      #include <IE.au3> local $oNNVs = _IEFormGetCollection($oIE2) For $oNNV in $oNNVs If String($oNNV.innertext) = "Noch nicht veröffentlicht" Then _IEAction($oNNV, "click") EndIf Next and:
      $inputs = $oIE2.document.getElementsByTagName("div") For $input In $inputs If $input.innertext == "Noch nicht veröffentlicht" then $input.click() EndIf Next But nothing seems to work. Thanks for the help!
    • By TXTechie
      Hello Everyone,
      I'm looking for a way to use an already open Internet Explorer (IE) window (if one is up and running) and then navigate to a new URL in a new IE tab.
      I thought that _IECreate would easily meet my needs. However, when I use the following script:
      #include <IE.au3> Local $oIE = _IECreate("https://" & $Server & ":8444/", 1, 1, 0, 1) ...with one or more open IE windows, it still opens yet a new IE window.
      Are there any other ideas for how to reliably use an already open IE windows and then how to open a new tab in IE to navigate to a new URL?
      Regards,
      TX Techie
    • By WoodGrain
      Hi All,
      I've tried to create a script to browse to a web page in IE, but it only works for some sites, I've tried to simplify the script as much as possible, hoping you can point me in the right direction - thanks.
      This one going to Google does work:
      #include <IE.au3> $oIE = _IECreate("https://www.google.com.au/", 0, 1, 1) _IELoadWait($oIE) _IEQuit($oIE) But this one going to OneDrive opens the IE page, but fails immediately returning the errors, and the IE window is not closed:
      --> IE.au3 T3.0-2 Error from function _IELoadWait, $_IESTATUS_ClientDisconnected (-2147023174, Browser has been deleted prior to operation.)
      --> IE.au3 T3.0-2 Error from function _IELoadWait, $_IESTATUS_InvalidObjectType ()
      --> IE.au3 T3.0-2 Error from function _IEQuit, $_IESTATUS_InvalidObjectType
      #include <IE.au3> $oIE = _IECreate("https://abccorp-my.sharepoint.com/", 0, 1, 1) _IELoadWait($oIE) _IEQuit($oIE) Even if I put a sleep timer in for 10 seconds after the _IECreate it still doesn't work
      Thanks all!
×
×
  • Create New...