Sign in to follow this  
Followers 0
carloselectro

How to allow autoit ActiveX in IE

6 posts in this topic

I am trying to use the following script wihtout success.

IE is always poping the activeX popup. I have tried to allow everything in the security settings but nothing works.

Is the anything I can do to make it work? Autoit fills up the webpage correctly but erase everything once I click the Allow blocked content...

Es1Dts2.png

#include <IE.au3>
#include <File.au3>
#include <FileConstants.au3>
#include <String.au3>
#include <Array.au3>
#include <D:\PortableApps\Autoit Portable\App\Include_Custom\CSV\CSV.au3>

Local $aArray_Cisco[150] = ["43501", "44653", "44781", "44909", "45037", "44141", "44269", "44397", "44525", "37485", "37613", "37741", "37869", "36973", "37101", "37229", "37357", "38509", "38637", "38765", "38893", "37997", "38125", "38253", "38381", "39533", "39661", "39789", "39917", "39021", "39149", "39277", "39405", "40557", "40685", "40813", "40941", "40045", "40173", "40301", "40429", "33389", "33517", "33645", "33773", "32877", "33005", "33133", "33261", "34413", "34541", "34669", "34797", "33901", "34029", "34157", "34285", "35437", "35565", "35693", "35821", "34925", "35053", "35181", "35309", "36461", "36589", "36717", "36845", "35949", "36077", "36205", "36333", "29292", "29420", "43309", "43437", "44589", "44717", "44845", "44973", "44077", "44205", "44333", "44461", "37421", "37549", "37677", "37805", "36909", "37037", "37165", "37293", "38445", "38573", "38701", "38829", "37933", "38061", "38189", "38317", "39469", "39597", "39725", "39853", "38957", "39085", "39213", "39341", "40493", "40621", "40749", "40877", "39981", "40109", "40237", "40365", "33325", "33453", "33581", "33709", "32813", "32941", "33069", "33197", "34349", "34477", "34605", "34733", "33837", "33965", "34093", "34221", "35373", "35501", "35629", "35757", "34861", "34989", "35117", "35245", "36397", "36525", "36653", "36781", "35885", "36013", "36141", "36269", "29228"]
Global $sNom_Usager
Global $sPoste
Global $file = "D:\PortableApps\Script\Source\téléphone.csv"
Global $aArray


$oIE = _IECreate("C:\SPA514G Personal Directory.html")

$aArray = _ParseCSV($file, ",", '"', 0)

Local $nombre_de_ligne = _FileCountLines($file)

Local $i = 0

Do


    $sNom_Usager = $aArray[$i][0]
    $sPoste = $aArray[$i][3]
    $name = _IEGetObjByName($oIE, $aArray_Cisco[$i])

    _IEPropertySet($name, 'innerText', 'n=' & $sNom_Usager & ';p=' & $sPoste)

    $i = $i + 1


Until  $i = $nombre_de_ligne OR $i = 150

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

;$iZone = 0 ; My Computer
$iZone = 1 ; Local Intranet Zone
;$iZone = 2 ; Trusted sites Zone
;$iZone = 3 ; Internet Zone
;$izone = 4 ; Restricted Sites Zone

RegWrite("HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\" & $iZone, "1208", "REG_DWORD", 0)

Edited by jguinch

Share this post


Link to post
Share on other sites

The message still pops up. I wonder if it's because my webpage is saved locally on my computer...

Share this post


Link to post
Share on other sites

I have found that the  following procedure works:

1. Launch Internet Explorer
2. Navigate to Tools/Internet Options
3. Click on the Advanced tab
4. Scroll down to the Security section and Enable the option entitled “Allow active content to run in files on My Computer”.
5. Apply the change

Thank you for your help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0