Jump to content
Sign in to follow this  
RyukShini

Changing Proxy If proxy is dead

Recommended Posts

I have a script visiting a website of mine and I want it to change to a new proxy each run with an array(I think I got that covered and it should be working)
but if this proxy is dead it gives me an error in AutoIT(Not so strange), but I want it to skip the proxy if its dead and go on the the next.
I use $oHTTP.SetProxy(2, "proxy:port")
everything works except for if proxy is dead or none responding etc.

Share this post


Link to post
Share on other sites
Just now, JLogan3o13 said:

@RyukShini please explain why you would need to change the proxy with each visit to the website.

because I am pulling up quite a bit of information from my website and I have enabled different features blocking exactly this.
but if I do this from proxies it wont pop up with this error on my site.
and if I turn of the features on my site, I may be an easier victim to both DDOS attacks and similar.
So this is why I would like proxy support, to actually access my own site with more requests.
I know I could just whitelist my IP, but I'd rather use this and not need to whitelist every IP I get online on(I travel weekly if not more often sometimes and I am often on public IPs)

Thanks in advance @JLogan3o13

Share this post


Link to post
Share on other sites
3 hours ago, RyukShini said:

because I am pulling up quite a bit of information from my website and I have enabled different features blocking exactly this.

It's your side so: "why you blocking yourself?"  

The frontend of your cms must be able to give you every and so much informations you need. If it isn't so change your cms. If is your hoster which blocks change the hoster.

You can also query Information directly from (nearly) every db using tools like phpMyAdmin.

Edited by AutoBert

Share this post


Link to post
Share on other sites
8 hours ago, AutoBert said:

It's your side so: "why you blocking yourself?"  

The frontend of your cms must be able to give you every and so much informations you need. If it isn't so change your cms. If is your hoster which blocks change the hoster.

You can also query Information directly from (nearly) every db using tools like phpMyAdmin.

But I would prefer using my script.
Afterall I am learning AutoIT and this is a great way of learning, interacting with your own content, is it not?

I would really appreciate any help on this matter.

Share this post


Link to post
Share on other sites

@RyukShini after further reflection on this request I do not believe it is something you're going to get help with. You certainly may not have bad intentions with the script, but that does not mean that someone else coming along and reading this thread would not use it poorly. In general, using a constantly changing proxy to get around website security is not something we want to support.


"Profanity is the last vestige of the feeble mind. For the man who cannot express himself forcibly through intellect must do so through shock and awe" - Spencer W. Kimball

How to get your question answered on this forum!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kingjacob90
      Hi
      So I am trying to click the green button, this button is not always in the same place. So fare I am trying to click it by finding the color but there is also something else with the same color on the screen (circled in yellow) that is causing issues. Is there a way to use the Title and Class of the window (can't be just the window as there are more than one with the same name).
      How does AutoIt Info get this information?

    • By adjist
      Hello all! 
       
      Getting this error :
      (22) : ==> Variable used without being declared.: if $vNumber = 0 Then if ^ ERROR  
      But I'm sure I have defined the variable, as in the top of my script has 
      Global $vNumber = 0  
      How would I go about fixing this?
       
    • By MarkIT
      Hi AutoIT masters,
      Good day! Sorry to have bothered this forum but we really need help. We are working on an automation project that is running on VDI server. The BOTS are in .exe are running fine until AV detected them and deleted the files. The files were re-compiled and AV kept on deleting them. The copy of the .exe BOT deleted were sent to Symantec for whitelisting. After whitelisting, it is no longer deleted but no longer working as designed (showing Line script error). We checked the scripts and there were no issues since we run it using SciTE editor and it performed the desired task. Good thing we found on this thread the solution using .a3x and the BOTS worked fine and no longer deleted. Now, the problem is they are asking why the BOTS won't run in .EXE and what is the reason behind Symantec AV deleting them. We raised a case with Symantec but they cannot provide further information as they are always seeing the file as "False Positive". We even tested with Symantec turned off and those .EXE files are working fine, however, after re-enabling, it got deleted.
      Just seeking help on how to better convince them that it is really Symantec causing the issue and the .a3x file.
    • By AutoitMike
      Scite 3.4.4
      Win 10
      I click "Help" or press F1, there is no response
      If I use the file explorer and double click Autoit.chm or Autoit3.chm help opens.
      There is no dialog to check or uncheck "Always ask before opening this file" when clicking on these files.
       
      If you are curious as to why I dont have the latest version, I am creating a back up laptop that has a VERY extensive automation application that I have written over the past 15 years.
       
      An extremely potent, powerful, needed function has been deleted in the upgrade of Autoit in recent years that I can not do without. If my main laptop dies, which it almost did, I am in a very bad position. So I bought the exact same laptop and I am "cofiguring" it to work exactly the same as my main laptop. However, this one has been "Upgraded" to Win 10 which I hope is not the problem. 
      Thanks for any help
    • By dascondor
      So basically need to pull text from a .txt file or .sql and use that text to replace something within a different file.
       
      First File:
      jumps
       
      Or:
      Text1 = jumps
      Text2 = fence
      Second File:
      My Dog XXXXX over the YYYYY.
       
       
      After Script:
      My Dog jumps over the fence
       
      I have found a good start, I'm basic programmer at best, I have some experience but this gets out of my wheel house.
       
      Any help is appreciated.
       
       
×
×
  • Create New...