Sign in to follow this  
Followers 0
tommytx

FF autoit not going past the first URL.

4 posts in this topic

Has anything changed recently with how FF interacts with autoit.. I cannot get it to do anything past start the first url and just hangs at that piont.
here is the code i am using..
The only thing it does is open up the vahud.com and never moves on to the test.htm page.. and does this on all my FF autoit programs..
I am using XP but it has alwasy been fine in the past..

 

#Include <FF.au3>

_FFStart("http://vahud.com")

    Sleep(2000)
    _FFAction("presentationmode", True)
    Sleep(2000)
    _FFOpenURL("http://vahud.com/test.htm")
    Sleep(2000)
Exit

and here is the rusults i obtain.
 

__FFStartProcess: ""C:\Program Files\Mozilla Firefox\firefox.exe" -new-window "http://vahud.com"  "-repl 4242 "
_FFConnect: OS: WIN_XP WIN32_NT 2600 Service Pack 3
_FFConnect: AutoIt: 3.3.12.0
_FFConnect: FF.au3: 0.6.0.1b-10
_FFConnect: IP: 127.0.0.1
_FFConnect: Port:   4242
_FFConnect: Delay:  2ms
_FFConnect ==> Timeout: TCPConnect Error: 10061
_FFConnect ==> General Error: Timeout: Can not connect to FireFox/MozRepl on: 127.0.0.1:4242
__FFSend ==> Socket Error
_FFCmd ==> Error return value
_FFOpenURL: http://vahud.com/test.htm
__FFSend ==> Socket Error
_FFCmd ==> Error return value
_FFOpenURL ==> No match: http://vahud.com/test.htm
>Exit code: 0    Time: 72.04

 

Share this post


Link to post
Share on other sites



Looks like MozRepl is either not installed or not running...

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

Downoad the actual FF.Au3 and test again. The console output tells ff want to connect on Port 4242 but afair it must be 42, so test the linked version. @Stilgar has posted the link on autoit.de yesterday and told the V0.6.0.2b is out of the beta state and had reached stable state. After testing come back and report.

Edited by AutoBert

Share this post


Link to post
Share on other sites
1 hour ago, AutoBert said:

Downoad the actual FF.Au3 and test again. The console output tells ff want to connect on Port 4242 but afair it must be 42, so test the linked version. @Stilgar has posted the link on autoit.de yesterday and told the V0.6.0.2b is out of the beta state and had reached stable state. After testing come back and report.

Looks like it was the Moz not activating automatically.. as I forced it on manually and its seemed ok.. so thanks for the advice...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Similar Content

    • X_xkijux_x
      By X_xkijux_x
      Ok so im using this program. clarify for school. I would like to have a program that takes every word i type in microsoft word and searches on it in claryfi. is this possible. I would like to have the program not stopping me from typing more after that word. Like when i type a word it auto search it on clarify without making me stop typing and if i want to change i can do that and if im fine that word i can just keep typing and it will search after the next word. 
    • Miliardsto
      By Miliardsto
      Is this possible to make program works like in diagram? There is so much encryption methods and UDFs are they give security? If the $Address will be crypted with some encryption algorithm could be possible to get the value of $Address in easy way? Of course We know its easy too look into autoit code and get value of variable and so We dont want to anyone see $Address value - there are functions Could func1.au3, func2.au3.. be for example func1.php or other type of file? As we know .php files are unnable to see. For example func1 would be read by FileRead() and then Execute() Is this generally possible to do?
      Will it give secure?
      What do you think about? Maybe there is something wrong in this concept or missed.

    • JaredStroeb
      By JaredStroeb
      I need to open an application and send it keys in Session 0.  I have exe's working locally, I can see the application open in session 0 through interactive services, but my send commands do not go to the application.  The following article running-autoit-session-0, directs me to use ControlSend() however my application has no controls that can be identified by AutoIt v3 Window Info.  Get All Windows Controls also returned nothing for the application's handle.  
      What are my options?  
      Can this be done with AutoIt?
      Is there a different "relatively simple" library/tool to use? (I am familiar with C# if there is a viable library there )

       
    • nassausky
      By nassausky
      Hey all,
      Has anyone created any queries for youtube? I was thinking it might be something like this but can't quite figure it out:
      $oIE = _IECreateEmbedded() _IENavigate($oIE,"https://www.youtube.com") Local $oForms = _IETagNameGetCollection($oIE, "form") Local $sTxt = "" For $oForm In $oForms If $oForm.id = "masthead-search" Then $oInputs = _IETagNameGetCollection($oIE, "input") For $oInput In $oInputs If $oInput.id = "masthead-search-term" Then _IEFormElementSetValue($oInput, "cards") _IEFormSubmit($oForm) EndIf Next EndIf Next  
    • Skysnake
      By Skysnake
      Scite comes up occasional, almost incidentally, in some support topics.  I have not found a "Scite" topic in the forums, so this is where I will start.  I have recently been using Scite intensively, specifically with a large project and I have certain issues.  I know that Scite is not an AutoIt product, but it is so closely integrated to the core release that it makes sense to raise issues and request support here.  If this is not the right please refer me to the right forum.
      Thx
       
      Skysnake