Jump to content
mmoalem

Clipget() does not work

Recommended Posts

mmoalem

I seem to have an issue with clipget() - the following bit of code copy URL from chrome address bar - than using clipget() i try to grab the URL into a variable and input it into a spreadsheet. the script did not put anything into the sheet 

originally I though it was an issue with  OOo/LibO Calc UDF and posted it there :

 

than I tried writing $NewURL into a text file and than just a msgbox but it comes blank. (the URL is in the clipboard as i can paste it)

 

send ("!d") ;select URL in browser
send ("^c") ;copy selected URL
Local $NewURL = ClipGet()
MsgBox($MB_ICONINFORMATION + $MB_TOPMOST, $sTitle, $NewURL )

am I doing something wrong? is there an issue with a URL characters?

Share this post


Link to post
Share on other sites
david1337

Hmm I don't see anything wrong in that code.

This works fine here - The MsgBox gives me the URL.
Have you tried with different sites?

#include <MsgBoxConstants.au3>

send ("!d") ;select URL in browser
send ("^c") ;copy selected URL

Local $NewURL = ClipGet()
Local $sTitle = "Title"

MsgBox($MB_ICONINFORMATION + $MB_TOPMOST, $sTitle, $NewURL )

 

Share this post


Link to post
Share on other sites
mmoalem
3 hours ago, david1337 said:

Hmm I don't see anything wrong in that code.

This works fine here - The MsgBox gives me the URL.
Have you tried with different sites?

#include <MsgBoxConstants.au3>

send ("!d") ;select URL in browser
send ("^c") ;copy selected URL

Local $NewURL = ClipGet()
Local $sTitle = "Title"

MsgBox($MB_ICONINFORMATION + $MB_TOPMOST, $sTitle, $NewURL )

 

that is strange... doesnt work for me even with other URLs... Now I kind of went the manual route opening a text file, activating it, pasting from the clipboard - that works but wish i understood why clipget doesnt work

Share this post


Link to post
Share on other sites
232showtime

its working,

#include <MsgBoxConstants.au3>
WinActivate("[Class:MozillaWindowClass]")

send ("!d") ;select URL in browser

send ("^c") ;copy selected URL
Local $NewURL = ClipGet()
MsgBox($MB_ICONINFORMATION + $MB_TOPMOST, "Title", $NewURL )

just activate your browser and put some if statement


ill get to that... i still need to learn and understand a lot of codes graduated.gif

Correct answer, learn to walk before you take on that marathon.

Share this post


Link to post
Share on other sites
mmoalem

the issue is in clipget - the URL is copied into the clipboard no problem but $NewURL is not populated by clipget() - have no idea why... tried running it as admin on win10 as well but did not work

5 hours ago, 232showtime said:

its working,

#include <MsgBoxConstants.au3>
WinActivate("[Class:MozillaWindowClass]")

send ("!d") ;select URL in browser

send ("^c") ;copy selected URL
Local $NewURL = ClipGet()
MsgBox($MB_ICONINFORMATION + $MB_TOPMOST, "Title", $NewURL )

just activate your browser and put some if statement

 

Share this post


Link to post
Share on other sites
KickStarter15

It's working as well in me.

#include <FileConstants.au3>
#include <MsgBoxConstants.au3>
#include <WinAPIFiles.au3>

WinActivate("[Class:MozillaWindowClass]")

send ("!d") ;select URL in browser

send ("^c") ;copy selected URL
Local $NewURL = ClipGet()
$sFilePath = @ScriptDir & "\Test.txt"
$hFileOpen = FileOpen($sFilePath, $FO_APPEND)
   FileWriteLine($hFileOpen, $NewURL)
FileClose($hFileOpen)
MsgBox($MB_SYSTEMMODAL, "Title", "Contents of the ClipGet:" & @CRLF & FileRead($sFilePath))

 

17 minutes ago, mmoalem said:

$NewURL is not populated by clipget()

What do you mean by not populating your clipget()?


Programming is "To make it so simple that there are obviously no deficiencies" or "To make it so complicated that there are no obvious deficiencies" by C.A.R. Hoare.

Share this post


Link to post
Share on other sites
KickStarter15
22 hours ago, mmoalem said:

the following bit of code copy URL from chrome address bar - than using clipget() i try to grab the URL into a variable and input it into a spreadsheet. the script did not put anything into the sheet

Have you tried using Mozilla instead? Chrome seems not working in me.

I tried having it this way:

#include <FileConstants.au3>
#include <MsgBoxConstants.au3>
#include <WinAPIFiles.au3>

If WinExists("[CLASS:MozillaWindowClass]") Then
    WinActivate("[CLASS:MozillaWindowClass]")
ElseIf WinExists("[CLASS:IEFrame]") Then
    WinActivate("[CLASS:IEFrame]")
 ElseIf WinExists("[CLASS:Chrome_WidgetWin_0]") Then
    WinActivate("[CLASS:Chrome_WidgetWin_0]")
EndIf

send ("!d") ;select URL in browser

send ("^c") ;copy selected URL
Local $NewURL = ClipGet()
$sFilePath = @ScriptDir & "\Test.txt"
$hFileOpen = FileOpen($sFilePath, $FO_APPEND)
   FileWriteLine($hFileOpen, $NewURL)
FileClose($hFileOpen)
MsgBox($MB_SYSTEMMODAL, "Title", "Contents of the ClipGet:" & @CRLF & FileRead($sFilePath))

But you might want to check this here and try Xandy's line. Might help you with your chrome issue. But for FireFox and IE above code is working fine.^_^

Edited by KickStarter15

Programming is "To make it so simple that there are obviously no deficiencies" or "To make it so complicated that there are no obvious deficiencies" by C.A.R. Hoare.

Share this post


Link to post
Share on other sites
Bowmore

Sometimes when using send("^c) to copy data to the clipboard it can take a short time for the data to get into the clipboard. Adding a short sleep before trying to access the data in the clipboard usually  solves the problem.

#include <MsgBoxConstants.au3>
WinActivate("[Class:MozillaWindowClass]")

send ("!d") ;select URL in browser

send ("^c") ;copy selected URL
sleep(500) ;<===== Experiment with different values to get the optimum sleep time
Local $NewURL = ClipGet()
MsgBox($MB_ICONINFORMATION + $MB_TOPMOST, "Title", $NewURL )

 

 

 


"Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the universe trying to build bigger and better idiots. So far, the universe is winning."- Rick Cook

Share this post


Link to post
Share on other sites
jdelaney

Also, just because you activate a window doesn't necessarily mean that 100% of your sends are going to get to that window.  Why not just use IE, and then there are actual functions that will grab a DOM object text (the url) into a variable


IEbyXPATH-Grab IE DOM objects by XPATH IEscriptRecord-Makings of an IE script recorder ExcelFromXML-Create Excel docs without excel installed GetAllWindowControls-Output all control data on a given window.

Share this post


Link to post
Share on other sites
mmoalem
On 2017-5-18 at 9:23 PM, Bowmore said:

Sometimes when using send("^c) to copy data to the clipboard it can take a short time for the data to get into the clipboard. Adding a short sleep before trying to access the data in the clipboard usually  solves the problem.

#include <MsgBoxConstants.au3>
WinActivate("[Class:MozillaWindowClass]")

send ("!d") ;select URL in browser

send ("^c") ;copy selected URL
sleep(500) ;<===== Experiment with different values to get the optimum sleep time
Local $NewURL = ClipGet()
MsgBox($MB_ICONINFORMATION + $MB_TOPMOST, "Title", $NewURL )

 

 

 

That was the issue! thank you all for trying to help - appreciate the support

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • AndyS19
      By AndyS19
      I want to copy just the selected text in an input control and put it to the clipboard, but GuiCtrlRead() always reads all of the text in the control.
      In this test code, when I highlight a  portion of the left control's text and press ^C, I want to copy just that text to the clipboard; but when I highlight a  portion of the right control's text and press ^C, I want to copy all of its text to the clipboard.
      #include <Debug.au3> _DebugSetup(@ScriptName & "_debug.txt", False, 2, "") _DebugOut("=============== " & @MON & "/" & @MDAY & "/" & @YEAR & " " & @HOUR & ":" & @MIN & ":" & @SEC & " ====================") #include <GUIConstants.au3> #include <WinAPI.au3> #include <Array.au3> Opt("GUICloseOnESC", 1) ; ESC closes GUI? (0 = no, 1 = yes) Opt("GUIOnEventMode", 1) ; Set OnEvent mode Opt('MustDeclareVars', 1) OnAutoItExitRegister("Event_GUIClose") Opt("GUIEventOptions", 1) ;0=default, 1=just notification, 2=GuiCtrlRead tab index Opt("WinTitleMatchMode", -2) ;1=start, 2=subStr, 3=exact, 4=advanced, -1 to -4=Nocase Global $hWnd_MainWin, $iID_Left, $iID_Right _Main() Func _Main() $hWnd_MainWin = GUICreate("test7", 200, 300) $iID_Left = GUICtrlCreateInput("AAA BBB CCC (get Selected text)", 10, 30, 200, 25) GUICtrlSetOnEvent($iID_Left, "handle_left_btn") $iID_Right = GUICtrlCreateInput("DDD EEE FFF (get All text)", 10, 60, 200, 25) GUICtrlSetOnEvent($iID_Right, "handle_right_btn") Local $aAccelKeys[1][2] = [["^c", $hWnd_MainWin]] GUISetAccelerators($aAccelKeys) GUISetOnEvent($GUI_EVENT_CLOSE, 'Event_GUIClose') GUISetState() ; Make everything visible While 1 Sleep(127) WEnd EndFunc ;==>_Main Func handle_CTRL_C_key() ConsoleWrite("+++: handle_CTRL_C_key() entered" & @CRLF) Local $hCtrl, $ctrlID, $control_classname, $text $control_classname = ControlGetFocus($hWnd_MainWin) $hCtrl = ControlGetHandle($hWnd_MainWin, "", $control_classname) $ctrlID = _WinAPI_GetDlgCtrlID($hCtrl) If ($ctrlID = $iID_Left) Then $text = GUICtrlRead($ctrlID) ClipPut($text) ConsoleWrite("+++: Copied selected text:" & @CRLF & "==>" & $text & "<==" & @CRLF) ElseIf ($ctrlID = $iID_Right) Then $text = GUICtrlRead($ctrlID) ClipPut($text) ConsoleWrite("+++: Copied all text:" & @CRLF & "==>" & $text & "<==" & @CRLF) EndIf EndFunc ;==>handle_CTRL_C_key Func Event_GUIClose() Exit (99) EndFunc ;==>Event_GUIClose Func handle_left_btn() ConsoleWrite("+++: handle_left_btn() entered" & @CRLF) EndFunc ;==>handle_left_btn Func handle_right_btn() ConsoleWrite("+++: handle_right_btn() entered" & @CRLF) EndFunc ;==>handle_right_btn
       
    • fenhanxue
      By fenhanxue
      i want to copy a picture file to clipboard, so that i can paste the picture through ctrl+V
      this is my code ,but it dosen't work :
      #AutoIt3Wrapper_UseX64 = n #Include <Clipboard.au3> #include <GDIPlus.au3> _GDIPlus_Startup() $hClipboard_Bitmap = _GDIPlus_BitmapCreateFromFile('C:\1.jpg') _ClipBoard_Open(0) _ClipBoard_SetDataEx($hClipboard_Bitmap,$CF_BITMAP) _ClipBoard_Close() _GDIPlus_Shutdown() can you help me
    • rudi
      By rudi
      Hello.
      I fail trying to save content from WhatsApp other then plain text to a file that way, that non-char-content will be preserved in it's correct encoding. e.g. Emojis are spoiled.
      I've tried to do so using just filewrite() as well as forcing UTF
      #include <clipboard.au3> MsgBox(0,"Ready to read clipboard","Mark some WhatsApp content with non-char elements, e.g. Emojis, copy that to your clipboard (CTRL+c), then click OK here.") $ClipContent=_ClipBoard_GetData() ConsoleWrite('@@ Debug(' & @ScriptLineNumber & ') : $ClipContent = ' & $ClipContent & @CRLF & '>Error code: ' & @error & @CRLF & "Extended: " & @extended & @CRLF) ;### Debug Console $File="C:\temp\ClipSaveToFile.txt" $h=FileOpen($File,2+8+64) ; overwrite, create path, UTF16 FileWrite($h,$ClipContent) FileClose($h) $h=FileOpen($File,64) $NeuGelesen=FileRead($h) ConsoleWrite('@@ Debug(' & @ScriptLineNumber & ') : $NeuGelesen = ' & $NeuGelesen & @CRLF & '>Error code: ' & @error & @CRLF & StringLen ($NeuGelesen) & @CRLF ) ;### Debug Console FileClose($h) _ClipBoard_SetData($NeuGelesen) MsgBox(0,"Done","Re-read content of TEMP file was placed to the clipboard. Now paste this into WhatsApp. (Emojis will be spoiled)") I've also tried other encodings (16, 32, 64, 512)

      Or what is a different, functional approach to save WhatsApp Content to File in a way, to be able to to get it back to post it back to WhatsApp?

      Regards, Rudi.
    • AndreyS
      By AndreyS
      Hello to you, dear developers!
      Could you please tell me if there is an easy way to determine if the information was pasted from the clipboard?
      Without any variation of the insertion via Ctrl+V, or through the context menu.
      I revised the Help and many forum topics, but found nothing suitable.
      Can there be any WinAPI system events that determine this event?
    • Nareshm
      By Nareshm
      Its possible to past previously copied text to somewhere with autoit script ?
      If yes, How it ?
      example : Before I copied ABCD and then copied the PQRS, how to past the previously copied ABCD ?
×