Jump to content
Sign in to follow this  
AutoPM

Script Keeps Running Even After Closing.

Recommended Posts

I have Never Faced Such Issue before. With Autoit.

I'm Doing some Edits on Clipboard data. Using A While Loop for continue Checking Clipboard. 

I have compiled script as exe file & ran it.

Problem is that Even After Closing Script. Clipboard Edits Are continue happening.

Even Tried Restarting PC , But No Help. Checked Task Manager But There Is No Process Related to Compiled exe file.

NO IDEA HOW IS IT EVEN POSSIBLE :sweating:

I'm Using Autoit V3.3.14.5 

 

 

 

Share this post


Link to post
Share on other sites

@Subz Not Everything Can Be Shared Publicly. That's Why I Explained it.

9 minutes ago, Subz said:

do we have to organize a medium to look into a crystal ball?

If you can,Go Ahead 

Share this post


Link to post
Share on other sites
1 hour ago, AutoPM said:

If you can,Go Ahead

What a conceited answer from someone who's asking for help.
Hope Mods will help you out to get the right behaviour to stay here :) 


Click here to see my signature:

Spoiler

Thoughts:

  • I will always thank you for the time you spent for me.
    I'm here to ask, and from your response, I'd like to learn.
    By my knowledge, I can help someone else, and "that someone" could help in turn another, and so on.

/*--------------------------------------------------------------------------------------------------------------------------------------------------------------------------*/

ALWAYS GOOD TO READ:

 

Share this post


Link to post
Share on other sites
9 minutes ago, FrancescoDiMuro said:

What a conceited answer from someone who's asking for help.

If I Don't Want to Share My Script That's My Choice,

He Replied With  : "or do we have to organize a medium to look into a crystal ball?" instead of simply Writing to Share Script.

9 minutes ago, FrancescoDiMuro said:

Hope Mods will help you out to get the right behaviour to stay here :) 

if they're going to block me for replying harshly to Such a harsh Reply. No Problem It Takes 1 minute to Create a New Account

17 minutes ago, FrancescoDiMuro said:

conceited answer

I'm not active on this Forum. that doesn't mean that  i'm new to autoit.

Share this post


Link to post
Share on other sites

AutoPM,

If you do not show us some code which can reproduce the behaviour you describe then I am afraid we cannot help you. I have never heard of an AutoIt compiled exe which continues running after closure - and certainly not after a machine reboot. So either you have done something within the code which causes this behaviour (which is why we need to see a reproducer script) or there is something else going on with your machine - which I consider the most likely explanation.

So over to you - if you want help then show some code.

M23

P.S. And I would strongly counsel against opening other accounts - we do not permit that here.


Public_Domain.png.2d871819fcb9957cf44f4514551a2935.png Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind

Open spoiler to see my UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

@AutoPM I apologize if you thought I was responding harshly, it was sarcasm  The point I was trying to make was, how are we suppose to help you without seeing the code, we can only assume that it's an issue with your code as we've never seen this behavior before, as Melba23 has just pointed out.

Share this post


Link to post
Share on other sites

@Subz No Problem, I apologize too for my Replies. Actually I just wanted to know is this some kind of bug with autoit. If something like this came up before. Looks like Something wrong with my code. i will fix it :) 

 

 

Share this post


Link to post
Share on other sites

What macro did you used one after one? -.-


My video tutorials : HERE ( In construction )  || My Discord : https://discord.gg/S9AnwHw

How to Ask Help ||  UIAutomation From Junkew || WebDriver From Danp2 || And Water's UDFs in the Quote

Spoiler

 Water's UDFs:
Active Directory (NEW 2018-10-19 - Version 1.4.10.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (2018-10-31 - Version 1.3.4.1) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2017-07-21 - Version 0.4.0.1) - Download - General Help & Support - Example Scripts
PowerPoint (2017-06-06 - Version 0.0.5.0) - Download - General Help & Support
Excel - Example Scripts - Wiki
Word - Wiki
 
Tutorials:

ADO - Wiki

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...