Sign in to follow this  
Followers 0
crashdemons

[Solved] AutoItWrapperGUI Outfile extension

8 posts in this topic

#1 ·  Posted (edited)

EDIT: Thanks for moving the topic to the correct forum. :)

--------------------------------

In older versions of AutoIt, the AutoIt3Wrapper allowed me to specify an outfile with a file extension other than EXE.

For instance, I could specify "ScreenSaver.SCR"

Now, I can still do this during before building - but the annoyance is that the AutoIt3Wrapper GUI changes the extension back to EXE when saving. (or using the compile button, which still saves the wrapper settings)

(eg: "ScreenSaver.SCR" changes to "ScreenSaver.EXE")

Right now, I cannot compile to an SCR unless I just use the "Build" option after editing the wrapper settings manually.

I noticed this after updating to AutoIt3.3 from AutoIt3.2.12.1 and testing/compiling my "Targetting Screensaver" script.

Just a heads-up if this wasn't intentional.

Specs:

AutoIt3Wrapper GUI 1.10.1.14

AutoIt3.3.0.0

Installation package: autoit-v3-sfx.exe

Edited by crashdemons

My Projects - WindowDarken (Darken except the active window) Yahsmosis Chat Client (Discontinued) StarShooter Game (Red alert! All hands to battlestations!) YMSG Protocol Support (Discontinued) Circular Keyboard and OSK example. (aka Iris KB) Target Screensaver Drive Toolbar Thingy Rollup Pro (Minimize-to-Titlebar & More!) 2D Launcher physics example Ascii Screenshot AutoIt3 Quine Example ("Is a Quine" is a Quine.) USB Lock (Another system keydrive - with a toast.)

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

No responses to this issue?

I'm noticing a lot of little annoyances lately with this particular install.

eg: this

and:

1. OpenInclude doesn't seem to do anything anymore. ?

2. Autocomplete for functions and variables that are non-UDF and not built-in doesn't seem to appear anymore.

3. The popup function reference for built in and UDF functions only comes up on the opening parenthesis, not on subsequent commas that separate the parameters (as before).

SciTE4AutoIt3 Version 1.77

Contrasted with my previous: SciTE4AutoIt3 Version 1.71

I really don't remember seeing anything in the notes about these changes, if they were intended.

While I understand that maintaining some of these things probably isn't first-priority, they make working with AutoIt Sooooo much faster.

PS: I still have the folder for my older Au3.2.12.1 install - if I swap the folders, the old setup/SciTE/etc work fine.

Edited by crashdemons

My Projects - WindowDarken (Darken except the active window) Yahsmosis Chat Client (Discontinued) StarShooter Game (Red alert! All hands to battlestations!) YMSG Protocol Support (Discontinued) Circular Keyboard and OSK example. (aka Iris KB) Target Screensaver Drive Toolbar Thingy Rollup Pro (Minimize-to-Titlebar & More!) 2D Launcher physics example Ascii Screenshot AutoIt3 Quine Example ("Is a Quine" is a Quine.) USB Lock (Another system keydrive - with a toast.)

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

No responses to this issue?

I'm noticing a lot of little annoyances lately with this particular install.

eg: this

and:

1. OpenInclude doesn't seem to do anything anymore. ?

2. Autocomplete for functions and variables that are non-UDF and not built-in doesn't seem to appear anymore.

3. The popup function reference for built in and UDF functions only comes up on the opening parenthesis, not on subsequent commas that separate the parameters (as before).

SciTE4AutoIt3 Version 1.77

Contrasted with my previous: SciTE4AutoIt3 Version 1.71

I really don't remember seeing anything in the notes about these changes, if they were intended.

While I understand that maintaining some of these things probably isn't first-priority, they make working with AutoIt Sooooo much faster.

PS: I still have the folder for my older Au3.2.12.1 install - if I swap the folders, the old setup/SciTE/etc work fine.

Little annoyances huh ?

1. Are you using the standard SciTE4AutoIt3 installer for installing the Full version, which is working fine for me?

2. Are you sure you are using the Full version of SciTE as distributed with that installer? (check Help/About which should say "SciTE" on the first line.

3. Same comment as 2

So I am pretty convinced you are not running the SciTE version supplied with the Full SciTE4AutoIt3 installer.

It is correct that Autoit3wrapper_Gui forced the extension to the selected type.

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Sorry, I was using the SFX installer for AutoIt

Help>about:

SciTE4AutoIt3

Version 1.77

Dec 24 2008 09:01:19

- I must have overlooked that I needed a separate install for SciTE & all. (Didn't remember/read well enough)

- I will try the "Full SciTE4AutoIt3 install" (first link here I assume) and report back.

Thanks.

Edited by crashdemons

My Projects - WindowDarken (Darken except the active window) Yahsmosis Chat Client (Discontinued) StarShooter Game (Red alert! All hands to battlestations!) YMSG Protocol Support (Discontinued) Circular Keyboard and OSK example. (aka Iris KB) Target Screensaver Drive Toolbar Thingy Rollup Pro (Minimize-to-Titlebar & More!) 2D Launcher physics example Ascii Screenshot AutoIt3 Quine Example ("Is a Quine" is a Quine.) USB Lock (Another system keydrive - with a toast.)

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

I just spent about an hour (or what felt like an hour) downloading the installer over dialup; but it says it failed an integrity check

- so I assume it got corrupted somewhere in the course of the download. (which seems to be normal operation for dialup)

Posted Image

Re-downloading now.

Edited by crashdemons

My Projects - WindowDarken (Darken except the active window) Yahsmosis Chat Client (Discontinued) StarShooter Game (Red alert! All hands to battlestations!) YMSG Protocol Support (Discontinued) Circular Keyboard and OSK example. (aka Iris KB) Target Screensaver Drive Toolbar Thingy Rollup Pro (Minimize-to-Titlebar & More!) 2D Launcher physics example Ascii Screenshot AutoIt3 Quine Example ("Is a Quine" is a Quine.) USB Lock (Another system keydrive - with a toast.)

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

Downloaded and Installed from the Scite4AutoIt installer (SciTE Version 1.78)

- what do I need to do to get the entries for the tools menu back/working?

Working Options:

Obfuscator

Tidy

Build/Go

FunctionPopup

Missing Options:

OpenInclude

Koda*

Snippet holder*

Not working for me:

Compile - (CompileAu3.exe missing? I thought Compile was supposed to use AutoIt3Wrapper)

Au3 Spy (Au3_spy.exe missing? Shouldn't this be looking for Au3Info.exe?)

SyntaxCheck (Au3Check is included but in the AutoIt install Directory, not where SciTE is looking)

CheckCompile (CheckCompile.bat missing)

CheckRun (see above)

(* Files still in the SciTE folder)

I searched the forum for some of these but they all point to very old posts - what did I do wrong, I seem to have screwed everything up so far.

Have these options just been removed, or what?

C:\Program Files\AutoIt3\

AutoIt3 - 3.3.0.0

C:\Program Files\AutoIt3\SciTE\

SciTE.exe

Help > about:

SciTE
Version 1.78
    May 21 2009 20:37:14
by Neil Hodgson.
 Updated: Valik & Jos

Posted Image

Posted Image

Edit: tried deleting the SciTE folder and re-installing SciTE, but the same results were returned.

Edit 2: opened it up again to collect more information and noticed text shown in the console every time SciTE is ran:

Need to change au3.properties: BETA_AUTOIT = 0
Edited by crashdemons

My Projects - WindowDarken (Darken except the active window) Yahsmosis Chat Client (Discontinued) StarShooter Game (Red alert! All hands to battlestations!) YMSG Protocol Support (Discontinued) Circular Keyboard and OSK example. (aka Iris KB) Target Screensaver Drive Toolbar Thingy Rollup Pro (Minimize-to-Titlebar & More!) 2D Launcher physics example Ascii Screenshot AutoIt3 Quine Example ("Is a Quine" is a Quine.) USB Lock (Another system keydrive - with a toast.)

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

Do you have write rights to the SciTE program directory and its subdirectories?

One other thing to check is if this line inside au3.properties is set correctly:

# *** Specify here your AutoIt program directory  ***
autoit3dir=C:\Program Files\AutoIt3

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions        Beta files                                                          Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Ah, for some reason some of the files and folders including the SciTE folder were set to read-only... (not sure how that got set)

- Changed them back and reinstalled SciTE once more - all is working now perfectly now.

I didn't even think to check the file/folder attributes as I don't remember changing any of them.

Thanks for taking the time to help.


My Projects - WindowDarken (Darken except the active window) Yahsmosis Chat Client (Discontinued) StarShooter Game (Red alert! All hands to battlestations!) YMSG Protocol Support (Discontinued) Circular Keyboard and OSK example. (aka Iris KB) Target Screensaver Drive Toolbar Thingy Rollup Pro (Minimize-to-Titlebar & More!) 2D Launcher physics example Ascii Screenshot AutoIt3 Quine Example ("Is a Quine" is a Quine.) USB Lock (Another system keydrive - with a toast.)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0