Sign in to follow this  
Followers 0
Arclite86

Can somebody test this please

12 posts in this topic

#include <Chrome.au3>

$url = ("http://tweepi.com/auth/login")
$chrome_path = ("C:\Program Files (x86)\Google\Chrome\Application\chrome.exe")
$chrome = _ChromeStartup ($url, $chrome_path)

$username = ("testtest")
$getname =  ("signin_username")
local $usernamevak = _ChromeObjGetHTMLById ($getname)
_ChromeObjSetValueByName($usernamevak,$username)

this function doesn't work, i want to know if this has to do with my plugins or that the code just doesn't , if that is the case could somebody please give me the correct working code

Share this post


Link to post
Share on other sites



Different from >this?

yeah but nobody is responding to that last post, so i hoped that somebody would help me here,

so can anybody help??

Share this post


Link to post
Share on other sites

You never answered the questions I asked in that thread either, so people are probably reluctant to help when you won't even help us help you.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

You never answered the questions I asked in that thread either, so people are probably reluctant to help when you won't even help us help you.

Ok sorry,.. you r question was:''Did you install the AutoIT extension into Chrome and AutoIT Chrome Native Messaging Host? Have you tried it with this UDF?'

the answer is yes, i all did that but it still didnt work, 

now i think it is because of the code, could you please test and run it to so if the username input of the website is fillet with the text :"testtest"

Share this post


Link to post
Share on other sites

can anybody help me please?

Share this post


Link to post
Share on other sites

I just tried, it did not work, the values were not set.

could you please help me to put some text intro this input:

<input type="text" name="signin[username]" class="shadow_input biginput lightgray" title="you@example.com" id="signin_username">

Share this post


Link to post
Share on other sites

Sorry, I don't know how.

If I needed to do such a thing with chrome, I'd learn how to use the >IUIAutomation UDF

If and when you try it, post your code so someone who does use it can diagnose any problems you might have.


AutoIt Absolute Beginners    Require a serial    Pause Script    Video Tutorials by Morthawt   ipify 

Monkey's are, like, natures humans.

Share this post


Link to post
Share on other sites

#10 ·  Posted (edited)

I have learned how to use the UI Automation UDFs. It does not work with this particular URL. Not in Chrome. It works with IE.

I apologize. It works if you remember to enable accessibility: chrome://accessibility.

Edited by LarsJ

Share this post


Link to post
Share on other sites

I have tested this with the UI Automation framework. When I try to set an email value with the SetValue method, the cursor is placed in the edit field and the default text "you@example.com" is deleted. But the new value is not written to the field and I get a COM error: 0x80004001 (Not implemented).

I have tried with the MSAA API too. The put_accValue method results in the same error: 0x80004001 (Not implemented).

This error may well be the reason that your own code in the first post fails.

The reason for the errors are probably that the methods SetValue, put_accValue and set value of _ChromeObjSetValueByName are not implemented for the email and password fields because Tweepi don't like the login procedure to be automated.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0