Sign in to follow this  
Followers 0
tatane

empty element / 0 number in array

5 posts in this topic

#1 ·  Posted (edited)

Hi,

Could you tell me what's the result of this script on your version of Autoit :

Local $tableau[5] = ["",0,"","test",8]

For $i = 0 to 4
    If $tableau[$i] = "" Then
        ConsoleWrite($tableau[$i] & " : empty element" & @CRLF)
    EndIf
Next

Thanks.

Edited by tatane

Share this post


Link to post
Share on other sites



tatane,

Once again the problem of mixing datatypes in comparisons pops up - I am not going to explain it again, so please search for a previous thread where I have done so. ;)

Basically, if you want to compare the values in the array to a string ("") then use String to convert them to the same datatype:

If String($tableau[$i]) = "" Then
or use the == operator so that AutoIt does it for you. :)

M23


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

You're looking for this?

Local $tableau[5] = ["",0,"","test",8]
 
For $i = 0 to 4
    If $tableau[$i] == "" Then
        ConsoleWrite($tableau[$i] & " : empty element" & @CRLF)
    EndIf
Next

Share this post


Link to post
Share on other sites

The problem was that I was saving index elements of a listview and when the 0 index element was in the array, my test of empty element was wrong with 0.

I didn't know 0 number and empty element was considered as same value.

Thank you very much for the fast answer.

Share this post


Link to post
Share on other sites

I'm comparing with 0 and got this result:

Local $tableau[5] = ["",0,"","test",8]

For $i = 0 to 4
    If $tableau[$i] = 0 Then
        ConsoleWrite($tableau[$i] & " : empty element" & @CRLF)
    EndIf
Next

Console OutPut

 : empty element
0 : empty element
 : empty element
test : empty element
 
Saludos

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0