KaFu

Windows 10 Sound Control Panel - Info needed

20 posts in this topic

HiHo Board,


I've received some complains, that SSD does not work properly on Windows 10. As I've not installed it yet I'm looking for some help to see what has changed.

Does running this code still open the Sound control panel? First run should open Playback tab, second run the Recording tab.

$iPID = Run("rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,0", @ScriptDir, @SW_HIDE)
Sleep(2000)
ProcessClose($iPID)

$iPID = Run("rundll32.exe shell32.dll,Control_RunDLL mmsys.cpl,,1", @ScriptDir, @SW_HIDE)
Sleep(2000)
ProcessClose($iPID)

Additionally could someone please analyse the resulting window with AU3Info?
- What's the Window class? On Win7 it's "#32770".
- Is the listview still of the class "SysListView32"?
- Is the "Set Default" button still of the class "Button" with Instance = 2?
- Is the "Properties" button still of the class "Button" with Instance = 3?
- Is the "Ok" button still of the class "Button" with Instance = 4?

Any help is much appreciated :)...

Regards
KaFu

Share this post


Link to post
Share on other sites



Hi, Kafu. Yes the script opens the desired tabs for me on WIN10 Pro. The AU3Info still looks all the same:

  • window class is still #32770
  • Still SysListView32
  • Set Default is still Button 2
  • Properties is still Button 3
  • Ok is still Button 4

 

 


√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites

As JLogan3o13 says It still work.

Look This alternative.

;~ Sound
Global Const $MicrosoftSound="Microsoft.Sound"
Global Const $GUID_MicrosoftSound="{F2DDFC82-8F12-4CDD-B7DC-D4FE1425AA4D}"
;~ Supported OS: Windows 7, Windows 8, Windows 8.1

Global Const $sCLSID_OpenControlPanel = "{06622D85-6856-4460-8DE1-A81921B41C4B}"
Global Const $sIID_IOpenControlPanel =  "{D11AD862-66DE-4DF4-BF6C-1F5621996AF1}"
Global Const $sTagIOpenControlPanel= "Open hresult(wstr;wstr;ptr);GetPath hresult(wstr;wstr;uint);GetCurrentView hresult(int*)"


Local $oOpenControlPanel = ObjCreateInterface($sCLSID_OpenControlPanel, $sIID_IOpenControlPanel,  $sTagIOpenControlPanel)


;~  open Playback tab
$oOpenControlPanel.Open($MicrosoftSound,"",Null)
;~ open Recording tab
$oOpenControlPanel.Open($MicrosoftSound,"1",Null)
$oOpenControlPanel=0;Free

 

 

Saludos

1 person likes this

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Thanks for the info :). Most strange, maybe I've changed something in the meantime and just can't remember it.

 

Would someone with Windows 10 give the latest Beta a testrun?

https://funk.eu/wp-content/plugins/download-monitor/download.php?id=217

Edited by KaFu

Share this post


Link to post
Share on other sites

It seems to be working for me, it opens Playback, then when I click the Switch to button it opens the Recording tab. Anything specific you want me to check?


√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites

Would be great if you could test that the shortcuts work. "Create simple" Shortcut and "Create shortcut to toggle", the shortcuts are created in the programs location directory. Using the shortcuts the switch should be performed without a GUI. Same systematic goes for recording.

Share this post


Link to post
Share on other sites

I test Create simple and work correctly.  Create shortcut to toggle with recording devices does Not. I have three device but I always select the last.

 

Saludos

1 person likes this

Share this post


Link to post
Share on other sites

Damn, that needs to be fixed, back to the drawing-board :), I guess I have to get a third recording device from somewhere, thanks for testing!

Share this post


Link to post
Share on other sites

An alternative to select default device could be written using OjectCreateInterface starting with IMMDeviceEnumerator::EnumAudioEndpoints... Minimum supported OS: Windows Vista.

 

Saludos

1 person likes this

Share this post


Link to post
Share on other sites

Thanks for the hint with the MMDevice COM interface. I've gather all those bits and pieces already, but implementing would require a full rewrite... I save that for v2 as long as the panel automation works fine :)...

Share this post


Link to post
Share on other sites

Oh well, seems like there are constellations where I can not derive the current states from the buttons alone. I guess I'll release this version with the remark that I know that in some cases toggle won't work and start with v2 based on the MMDevice COM interface straight away, thanks for testing guys ;)!

Share this post


Link to post
Share on other sites

#13 ·  Posted (edited)

I had to learn the hard way, that either the button itself is never enabled on a secondary desktop, or that ControlCommand($hWnd_Sound, "", "Button2", "IsEnabled", "") just does not work on a secondary desktop. Anyhow, I fell back to using an .ini file in the program directory to record the toggle states.

"Should" now work fine on Win10, if someone with Windows 10 would give the latest Beta a testrun?

https://funk.eu/wp-content/plugins/download-monitor/download.php?id=217

Best Regards

Edited by KaFu

Share this post


Link to post
Share on other sites

@KaFu work correctly (Toggle option was tested just with recording devices, because I have just one Playback device)

 

Saludos

1 person likes this

Share this post


Link to post
Share on other sites

Hi KaFu,

I'm using your SSD for some years now and I was happy to find a Windows 10 version here in this forum. Now I got an update on my Windows 10 and your script is not working anymore.

Do you update the version on your hp, too? There is still your 1.3...

Thank you so much for your work :)

Share this post


Link to post
Share on other sites

#17 ·  Posted (edited)

Share this post


Link to post
Share on other sites

Hi Karsten,

thanks a lot, it works again as it should - tut, was es soll ;)

Enjoy the great weather today,

Grüße aus Niedersachsen :)

Share this post


Link to post
Share on other sites

#19 ·  Posted (edited)

Just updated the Beta again (quite some changes this time, among others I change to v2 :whistle:). So, for those few interested, give it a try and let me know of any bugs (esp. on Win10), otherwise I'll upload the final v2 including source soon ;)...

http://funk.eu/wp-content/plugins/download-monitor/download.php?id=217

SSD_v2_Beta.png

Edited by KaFu
1 person likes this

Share this post


Link to post
Share on other sites

On my Windows 10 it works fine :)

Thanks a lot

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now