Jump to content
sksjsj

Communication between evaluation unit and PC

Recommended Posts

 

Hello everybody,

 

I need some help in communicating between the PC and an evaluation unit. I have the following devices:

1.https: //www.ifm.com/us/en/product/DTE104

2. https://www.ifm.com/us/en/product/ANT513

I use autoit for a tracking software. The evaluation unit has a webpage where I can see the UID of the scanned tag, but I would need to improve the wait time, so that I can see directly the UID  in my autoit GUI too.

I tried with TCP / IP but I can't communicate with the ev.unit to send my data directly to the software. It is connected to PC via ethernet cable.

Anyone else working with that and can give me some ideas?

Thank you in advance! :) 

Share this post


Link to post
Share on other sites

 

That means the web page must always be active on all PCs where I have readers and that's not ok. I would prefer to be able to take UID directly "by cable" into my soft.

I will try with UDF. For this I need just WinPcap driver ?

 

Thank you both for the answer!

 

Share this post


Link to post
Share on other sites
4 minutes ago, sksjsj said:

That means the web page must always be active on all PCs where I have readers

Nope you can start the web page (in your script) in hiding mode and close it after you have read all the info necessary.  It would be lot more easy that way.

Share this post


Link to post
Share on other sites

Yes, this is a good idea and can be done. 

 

Btw, i tried to use socket to take the UID. 

I searched and i figured out that sending this:

TCPSend($iSocket, "RU_01")
TCPSend($iSocket, @CRLF)

to my evaluation unit with:

Local $sIPAddress = "192.168.0.79" 

Local $iPort = 33000

it works and connects, but I can't see/receive the UID anyway.

 

I put the code below.

Thanks!

tcp.txt

Share this post


Link to post
Share on other sites
3 hours ago, sksjsj said:

to my evaluation unit with:

Local $sIPAddress = "192.168.0.79" 

and in your code you have Local $sIPAddress = "192.168.0.79" ; This IP Address only works for testing on your own computer. and that is the IP of the unit, not your PC !!

Use Local $sIPAddress = "0.0.0.0" to use any IP in your PC. If the unit server is HTTP, is all good to use TCP/IP, now, if is HTTPS, then you can not get the data other than via a browser, as in IE or WinHTTP.

Share this post


Link to post
Share on other sites

 

Hello everyone,

I have solved the problem like in the picture. It looks like the message sent to the evaluation unit was not in the correct format.

Thank you for your help and support!

 

DONE.PNG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...