Jump to content
a6point6

Subscript used on non-accessible variable.

Recommended Posts

Im befabbled about what is wrong here:

This works:


    while $inn=9
        $c=PixelSearch(504,443,551,635,0x3269c8,2)
        if not @error Then
            mouseclick("left",$c[0]+4,$c[1]+3,4,2)
            $inn=10
        EndIf
    WEnd
 

This gives error:

Subscript used on non-accessible variable
mousemove($c[0],$c[1],2)
mousemove($c^ ERROR


    while $inn=10
        send("{TAB}")
        $c=PixelSearch(945,750,995,999,0x84c569,2)
        sleep(200)
        if not @error Then
            mousemove($c[0],$c[1],2)
            $inn=11
        EndIf
    wend

Anyone got an idea?
Yes $c is called at the start of the script.

Share this post


Link to post
Share on other sites

What application are you trying to automate ?  It seems very much like a game related script.  Have you read the forum rules ?

Share this post


Link to post
Share on other sites
57 minutes ago, Nine said:

What application are you trying to automate ?  It seems very much like a game related script.  Have you read the forum rules ?

It is not for a game, im a "Schleich" seller but i have over 5000 figures, and need an automated seller script for uploading them for auctions...

Share this post


Link to post
Share on other sites
32 minutes ago, Danp2 said:

You need to move the Sleep command. Otherwise, you lose the @error result from the prior command.

Thanx a bunch.. didnt know that :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...