Jump to content
Sign in to follow this  
autoxtacy

Gui Image/Picture Help Needed?

Recommended Posts

autoxtacy

I made a very simple GUI and then added a .jpg picture for the background of the gui yet when i try to press my buttons on the gui i cant. If i remove the picture I can press the buttons with no problem. If I remove the picture in the area of the buttons the buttons press fine. What is this picture doing to my ui and how do i make the buttons usable with the picture behind them?

My code:

#include <GuiConstants.au3>

#include<StaticConstants.au3>

#include <ButtonConstants.au3>

; Hides tray icon

#NoTrayIcon

; Change to OnEvent mode

Opt('GUIOnEventMode', 1)

; GUI Creation

GuiCreate("AleStorm - A NeverWinters Night PvP Server", 400, 300)

GuiSetIcon("icon.ico")

; Runs the GUIExit() function if the GUI is closed

GUISetOnEvent($GUI_EVENT_CLOSE, 'GUIExit')

; Logo / Pic

;GuiCtrlCreatePic("lotr_01_1024x768.jpg",120,5,156,160)

GuiCtrlCreatePic("lotr_01_1024x768.jpg",0,0,400,300)

; Instructions

GUICtrlCreateLabel("Please Choose an Option Below:", 100, 180, 200, 15, $SS_CENTER)

GUICtrlSetColor(-1,0xFF0000) ; Makes instructions Red

; Button1

GUICtrlCreateButton("Visit Our Forums", 100, 210, 200, 30)

GUICtrlSetOnEvent(-1, 'website') ; Runs website() when pressed

; Button2

GUICtrlCreateButton("Send an Email", 100, 250, 200, 30)

Share this post


Link to post
Share on other sites
Yashied
autoxtacy

Add

GUICtrlSetState($Pic, $GUI_DISABLE)

Thankyou! Worked like a charm and after reviewing that function in the help menu I understand why. Thanks again...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×