Jump to content
Sign in to follow this  
skiffle

How to User _ADAddUserToGroup with RunAs

Recommended Posts

skiffle

I try to use the _ADAddUserToGroup syntax with a RunAs like:

#include <adfunctions.au3>

RunAs("admin", "yyyy_hq", "xxxx", 0, "_ADAddUserToGroup("CN=Infomail,OU=yyyy AdminTool,OU=yyyy Services,OU=yyyy Group,DC=yyyy-online,DC=de", _ADSamAccountNameToFQDN("username"))")

without RunAs it works:

#include <adfunctions.au3>

"_ADAddUserToGroup("CN=Infomail,OU=yyyy AdminTool,OU=yyyy Services,OU=yyyy Group,DC=yyyy-online,DC=de", _ADSamAccountNameToFQDN("username"))

What is wrong?

Thank you for your help. regards Skiffle

Share this post


Link to post
Share on other sites
water

You can't combine RunAs and the adfunctions this way. If you want to run an _AD* function as a different user please use:

_ADAlternativeLogon($user, $password)
_ADAddUserToGroup("CN=Infomail,OU=yyyy AdminTool,OU=yyyy Services,OU=yyyy Group,DC=yyyy-online,DC=de",_ADSamAccountNameToFQDN("username"))

My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2017-04-18 - Version 1.4.8.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2017-02-27 - Version 1.3.1.0) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2015-04-01 - Version 0.4.0.0) - Download - General Help & Support - Example Scripts
Excel - Example Scripts - Wiki
Word - Wiki
PowerPoint (2015-06-06 - Version 0.0.5.0) - Download - General Help & Support

Tutorials:
ADO - Wiki

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.