Sign in to follow this  
Followers 0
aisc

Error on script line -1

6 posts in this topic

I have a long running script, which occasionally errors. The compiled mode shows the error as line -1. When I run in debug, I never seem to find the error; even when running it for a long time. Is there any of the compile options that allow the runtime to report the line that the error occured on? I tried the include scriptsource option, but reading the forum, it doesn't appear that is what the option is for.

L'il help?

Thanks,

aisc

Share this post


Link to post
Share on other sites



How can you expect help without showing us the script? There are infinite possibilities of what could be wrong, we can't just guess...

Share this post


Link to post
Share on other sites

Try creating a log file by adding some FileWrite statements in your code, to finding out where it may be failing when compiled. As per darkjohn20 you will need to provide more info.

Share this post


Link to post
Share on other sites

The code is a thousand lines, so I'm not sure where it's dying exactly. My question was just whether there was a way to get the run time to spit out a line number, rather than line -1. I do like the FileWrite idea. I have a lot of consolewrites... I could replace those.

Thanks!

aisc

Share this post


Link to post
Share on other sites

Yup, run it in scite and try to repeat what you do to reproduce the error...

Scite is really helpful in debugging script like that


AUTOIT[sup] I'm lovin' it![/sup]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0