Sign in to follow this  
Followers 0
supersonic

Problems when adding 300+ items/50+ subitems to a LV with GUICtrlCreateListViewItem()!?

3 posts in this topic

#1 ·  Posted (edited)

Hi!

I'm trying to add 300+ items/50+ subitems to a ListView with the help of GUICtrlCreateListViewItem().

Somewhere the script stops with an error: !>17:17:07 AutoIT3.exe ended.rc:-1073741819. It's seems like a "buffer overflow"...

When adding 300/10-15 to a ListView it works without error.

Mainly I use GUICtrlCreateListViewItem() to ink rows with $GUI_BKCOLOR_LV_ALTERNATE.

Any ideas about it?

Greets,

-supersonic.

Edited by supersonic

Share this post


Link to post
Share on other sites



Hi supersonic,

maybe you hit a limit of AutoIt? Please see this thread.

The GUI_MAXCONTROLS limit has been raised to 65532 in the meantime (please see the help file, Appendix -> AutoIt3 limits/defaults) but you seem to hit another limit.

Water


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2017-04-18 - Version 1.4.8.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2017-02-27 - Version 1.3.1.0) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2015-04-01 - Version 0.4.0.0) - Download - General Help & Support - Example Scripts
Excel - Example Scripts - Wiki
Word - Wiki
PowerPoint (2015-06-06 - Version 0.0.5.0) - Download - General Help & Support

Tutorials:
ADO - Wiki

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0