Sign in to follow this  
Followers 0

New SciTE4AutoIt3 available with SciTE v1.79

300 posts in this topic

Posted (edited)

February 5, 2010: Uploaded a new SciTe4AutoIt3.exe installer.

IMPORTANT: This version doesn't have support for the ANSI version of AutoIt3 anymore since that is removed from AutoIt3.

There are a couple of major changes:

  • The installer will not change the security setting for the SciTE directory anymore! To properly test this you need to either uninstall and remove the whole SciTE directory of manaully remove the extra security setting and revert to inherited security.
  • AutoIt3Wrapper_GUI is removed an now incorporated into AutoIt3Wrapper.
  • AutoIt3Wrapper has many updates including the Resource Update Functions which were mostly done by wraithdu! It now supports also none standard resources additions avoiding the need for Reshacker totally. Look in the Helpfile for some examples.

February 28, 2010: Fixes in the current installer:

--------------------------------------------------------------------------------------------------
2/28/2010
*** Updated AutoIt3Wrapper_Gui/AutoIt3Wrapper v2.0.1.24 (Jos)
- Made changes to support installation that didn't use installer
- Fixed autocomplete for #autoit3wrapper directives by adding au3.autoit3wrapper.api file and updating au3.properties
--------------------------------------------------------------------------------------------------
2/4/2010
*** Updated AutoIt3Wrapper_Gui/AutoIt3Wrapper v2.0.1.23 (Jos)
- Fixed /beta/beta warning for Obfuscator when from Ctrl+F7 Beta was selected
- Re-Actived support for the following directives to be able to override the defaukts for a particular script:
   #AutoIt3Wrapper_Autoit3Dir=    ;Optionally override the base AutoIt3 install directory.
   #AutoIt3Wrapper_Aut2exe=       ;Optionally override the Aut2exe.exe to use for this script
   #AutoIt3Wrapper_AutoIt3=       ;Optionally override the Autoit3.exe to use for this script
--------------------------------------------------------------------------------------------------
2/6/2010
*** SciTE General installation. (Jos)
    - Added missing autoit3wrapper.keywords.properties to installer.
--------------------------------------------------------------------------------------------------

Enjoy,

Jos

==> ScitillaHistory page containing all SciTE/Scintilla updates.

==> Visit the SciTE4AutoIt3 Download page for the latest versions

==> Check the online documentation for an overview of all extra's you get with this installer.

Enjoy,

Jos

2/4/2010
*** SciTE General installation. (Jos)
    - Updated AutoItTools.lua to use internal call for Abbreviation expansion.
    - Updated AutoItTools.lua to avoid the need for updating au3.properties.
    - Removed seracl.exe from installer and am Not changing the Security of the SciTE directory for the Users group anymore.
      The Installer previous would run SetAcl to change the ACL/security for the SciTE install directory and files to "Full" for
      the groups "Users" and "Power Users" avoiding security issues when updates need to be made to au3.properties etc.
      This Security setting will have to be manually remove when you wish to do so and revert back to the defaults!!
    - Removed au3record from the installer as this is now supplied by the Autoit3 installer.
*** Updated AutoIt3Wrapper_Gui/AutoIt3Wrapper v2.0.1.21 (Jos)
    - Added support for running the correct version of AU3Info now supplied by the Autoit3 Installer.
    - Added support for running the correct version of AU3Record now supplied by the Autoit3 Installer.
    - Updated internal resource update functions which now also support nonstandard Sections and languagecodes. (wraithdu/Jos)
    - Removed AutoIt3Wrapper_Gui and integrated the code into AutoIt3Wrapper.exe.
    - Added support for the following directives:
       #AutoIt3Wrapper_Run_SciTE_Minimized=            ;(Y/N) Minimize SciTE while script is running. (Default=n)
       #AutoIt3Wrapper_Run_SciTE_OutputPane_Minimized= ;(Y/N) Toggle SciTE output pane at run time so its not shown by default.(Default=n)
*** Updated Tidy.exe v2.1.0.0 (Jos)
    - Speed improvements up to 50%.
*** Updated Obfuscator.exe v1.0.28.7 (Jos)
    - Speed improvements up to 30%.
    - Fixed a reported stack corruption.
*** Updated SciTEConfig v1.6.7.5 (Jos)
    - Updated typo in text of a messagebox.
*** Some Helpfile updates. (Jos)
    - Added documentation for SciTEConfig.
*** Updated Koda v 1.7.2.0 (lazycat)
   - Release 1.7.2.0 build 180 (2009-06-27)
*** Updated FuncPopup v 1.3.2.0 (jos)
   - Change the use of the helpfile to autoit3.chm to avoid page-not-found error.
Edited by Jos

Share this post


Link to post
Share on other sites



Posted

Looks good Jos. Installed but not the wrapper. I'll have to mess around and see what I can do to keep using Resource Hacker for Resources since RH is scriptable instead of adding all those damn directives. Now if the wrapper had something like the ability to read a flat file (something I can generate from a file list) to get the resources then all might be good again.

Share this post


Link to post
Share on other sites

Posted

Looks good Jos. Installed but not the wrapper. I'll have to mess around and see what I can do to keep using Resource Hacker for Resources since RH is scriptable instead of adding all those damn directives. Now if the wrapper had something like the ability to read a flat file (something I can generate from a file list) to get the resources then all might be good again.

Flat file with Directive would work. :D

Share this post


Link to post
Share on other sites

Posted

Just reinstalled from the new installer and all looks good. The only question I have is that your 'SciTE\Defs\Production\au3abbrev.properties' is a beta abbreviation file from 2007 and your 'SciTE\Properties\au3abbrev.properties' is a production file from 2008. Shouldn't those be the same or updated to current?

Share this post


Link to post
Share on other sites

Posted

Flat file with Directive would work. :D

A single directive to handle all the resources listed in a flat file? Now that I could work with.

As it stands right now I'm thinking of generating a "Make" compiled file and handling everything in there. Been playing with it but, like you, not much time for it right now.

Share this post


Link to post
Share on other sites

Posted

Just reinstalled from the new installer and all looks good. The only question I have is that your 'SciTE\Defs\Production\au3abbrev.properties' is a beta abbreviation file from 2007 and your 'SciTE\Properties\au3abbrev.properties' is a production file from 2008. Shouldn't those be the same or updated to current?

Yea, like the last time I received an update from MHz, i only updated the active file in the installer but forgot the 2 copies in the DEFS subdir.

This has been like this for a while alreeady :D

Will be fix in the next version.

Thanks,

Jos

Share this post


Link to post
Share on other sites

Posted

FYI I get this error now:

C:\Program Files\AutoIt3\SciTE\Lua\Tools.lua:73: Tool "Tools.toggleOverrideFont" not found.

>Lua: error occurred while processing command

Share this post


Link to post
Share on other sites

Posted (edited)

FYI I get this error now:

C:\Program Files\AutoIt3\SciTE\Lua\Tools.lua:73: Tool "Tools.toggleOverrideFont" not found.

>Lua: error occurred while processing command

Guess this is only with Ctrl+F11?

This must have been "broken" for a while (early 2008) because it looks like the LUA func was missing ever since Valik rewrote the LUA funcs and I included those into the SciTE4AutoIt3 setup.

Edited by Jos

Share this post


Link to post
Share on other sites

Posted

Uploaded a update Tools.lua to the Beta dir. Download that to your LUA subdir and restart SciTE.

See if that fixes it for you.

Jos

Share this post


Link to post
Share on other sites

Posted

Hi,

I updated to the latest SciTE for AutoIt version and now the user calltips no longer work.

It's C:\Programme\AutoIt3\SciTE\api\au3.user.calltips.api which is opened when I use The "User Calltip Entries" from the "Tools" tab.

The content of this file (which is genereated by "Scite settings.exe") is like:

_AD_Open([$sAD_UserIdParam = "", $sAD_PasswordParam = ""[, $sAD_DNSDomainParam = "", $sAD_HostServerParam = "", $sAD_ConfigurationParam = ""]]) Opens a connection to the Active Directory. (Requires: #Include <AD.au3>)
_AD_Close() Closes the connection to the Active Directory opened by _AD_Open. (Requires: #Include <AD.au3>)

Anything I have to change?

Thanks for your help.

Share this post


Link to post
Share on other sites

Posted

The updated tools.lua fix the toggle override font, thanks.

Share this post


Link to post
Share on other sites

Posted

I don't think that the content is generated by the SciTE4AutoIt3 installer.

When I copy&Paste the info you posted into my "empty" au3.user.calltips.api file and save it, this calltip pops up fine when typing:

_AD_Open(

Jos

Share this post


Link to post
Share on other sites

Posted

Sorry, my bad.

It's not been the user calltips it's been the syntax highlighting that didn't work. I generated the file C:\Programme\AutoIt3\SciTE\Properties\au3.userudfs.properties and now everything works fine. But with the "old" version I only generated the file C:\Programme\AutoIt3\SciTE\api\au3.user.calltips.api and user calltips and syntax highlighting worked.

Anyway: problem solved - case closed :D

Thanks for your support!

Share this post


Link to post
Share on other sites

Posted

Sorry, my bad.

It's not been the user calltips it's been the syntax highlighting that didn't work. I generated the file C:\Programme\AutoIt3\SciTE\Properties\au3.userudfs.properties and now everything works fine. But with the "old" version I only generated the file C:\Programme\AutoIt3\SciTE\api\au3.user.calltips.api and user calltips and syntax highlighting worked.

Anyway: problem solved - case closed :D

Thanks for your support!

Nah ... that would take a miracle. :huggles:

You need the Funcnames defined in au3.userudfs.properties or au3.keywords.properties before syntax colors would work.

Jos

Share this post


Link to post
Share on other sites

Posted

I solved the problem :D

The tool I use to generate the SciTE settings for the user calltips and syntax highlighting writes to properties\au3.keywords.properties. That's why everything worked. After installing the new version the au3.user.calltips.api file was still available but au3.keywords.properties was replaced by a new one (without my UDF).

Share this post


Link to post
Share on other sites

Posted

Upload an updated installer with several fixes.

See first post.

Jos

Share this post


Link to post
Share on other sites

Posted

Few things.

In autoit3wrapper.keywords.properties, remove the '=' from #autoit3wrapper_aut2exe and #autoit3wrapper_autoit3.

Here's my suggested capitalization for the API file:

#AutoIt3Wrapper_Add_Constants?1
#AutoIt3Wrapper_Au3Check_Parameters?1
#AutoIt3Wrapper_Au3Check_Stop_OnWarning?1
#AutoIt3Wrapper_AutoIt3Dir?1
#AutoIt3Wrapper_Aut2Exe?1
#AutoIt3Wrapper_AutoIt3?1
#AutoIt3Wrapper_Change2CUI?1
#AutoIt3Wrapper_Compression?1
#AutoIt3Wrapper_cvsWrapper_Parameters?1
#AutoIt3Wrapper_Icon?1
#AutoIt3Wrapper_OutFile?1
#AutoIt3Wrapper_OutFile_Type?1
#AutoIt3Wrapper_PlugIn_Funcs?1
#AutoIt3Wrapper_Res_Comment?1
#AutoIt3Wrapper_Res_Description?1
#AutoIt3Wrapper_Res_Field?1
#AutoIt3Wrapper_Res_File_Add?1
#AutoIt3Wrapper_Res_FileVersion?1
#AutoIt3Wrapper_Res_FileVersion_AutoIncrement?1
#AutoIt3Wrapper_Res_Icon_Add?1
#AutoIt3Wrapper_Res_Language?1
#AutoIt3Wrapper_Res_LegalCopyright?1
#AutoIt3Wrapper_Res_ProductVersion?1
#AutoIt3Wrapper_Res_requestedExecutionLevel?1
#AutoIt3Wrapper_Res_SaveSource?1
#AutoIt3Wrapper_Run_After?1
#AutoIt3Wrapper_Run_Au3Check?1
#AutoIt3Wrapper_Run_Before?1
#AutoIt3Wrapper_Run_cvsWrapper?1
#AutoIt3Wrapper_Run_Debug_Mode?1
#AutoIt3Wrapper_Run_Obfuscator?1
#AutoIt3Wrapper_Run_SciTE_Minimized?1
#AutoIt3Wrapper_Run_SciTE_OutputPane_Minimized?1
#AutoIt3Wrapper_Run_Tidy?1
#AutoIt3Wrapper_ShowGUI?1
#AutoIt3Wrapper_Tidy_Stop_onerror?1
#AutoIt3Wrapper_UPX_Parameters?1
#AutoIt3Wrapper_UseAnsi?1
#AutoIt3Wrapper_UseUPX?1
#AutoIt3Wrapper_UseX64?1
#AutoIt3Wrapper_Version?1
#Region?1
#EndRegion?1
#Obfuscator_Ignore_Funcs?1
#Obfuscator_Ignore_Variables?1
#Obfuscator_Off?1
#Obfuscator_On?1
#Obfuscator_Parameters?1
#Tidy_Parameters?1

You may or may not want to remove the #Region/#EndRegion from this file since they are still in AutoIt's main .api file.

Share this post


Link to post
Share on other sites

Posted

Few things.

In autoit3wrapper.keywords.properties, remove the '=' from #autoit3wrapper_aut2exe and #autoit3wrapper_autoit3.

Here's my suggested capitalization for the API file:

You may or may not want to remove the #Region/#EndRegion from this file since they are still in AutoIt's main .api file.

Thanks.. Updated the current Beta versions of the file. :mellow:

Share this post


Link to post
Share on other sites

Posted (edited)

I just noticed, you can also remove #region/#endregion from autoit3wrapper.keywords.properties as well, as they are still in the main au3.keywords.properties file.

Or... move the region/endregion stuff out of the main AutoIt3 api/keywords files and solely into the scite specific files, in which case the API capitalization would be #Region / #EndRegion.

Also, would it be possible to have Tidy clean up pre-processor directive proper casing according to the api files in addition to function / keyword proper casing?

Edited by wraithdu

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.
Sign in to follow this  
Followers 0