Jump to content
Sign in to follow this  

Button Borders in Win XP

Recommended Posts


Hi all

I am just wondering if anyone can help as to why there are white borders around the buttons in Windows XP but not in Windows 7?

I am using BITMAP buttons as can be seen in the code below:

$CONTINUE = GUICreate("", 500, 250, -1, -1, $WS_POPUP)
GUISetBkColor(0x313131, $CONTINUE)
GUICtrlCreatePic("./bannercs.jpg", 0, 0, 500, 193)
GUICtrlCreateLabel("To continue seting up this machine click continue", 10, 175, 480, 20, $SS_CENTER)
GUICtrlSetColor(-1, 0xFFFFFF)
GUICtrlSetBkColor(-1, 0x313131)
$ContinueButtonContinue = GUICtrlCreateButton("", 410, 210, 80, 30, BitOR($BS_BITMAP, $BS_FLAT))
GUICtrlSetImage($ContinueButtonContinue, "continue.bmp")
$ContinueButtonClose = GUICtrlCreateButton("", 10, 210, 80, 30, BitOR($BS_BITMAP, $BS_FLAT))
GUICtrlSetImage($ContinueButtonClose, "exit.bmp")

I added the BS_FLAT style in the hope of removing the button but it just made the border thinner so it looks like in the image below:


Any help to fix this would be greatly appreciated


Adam Mallinson


Share this post

Link to post
Share on other sites

Will i still be able to use it as a button if i do that? (Multiple buttons per GUI)

If so how would i go about that?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.