Sign in to follow this  
Followers 0
macvoo

Checking Performance Intranet-Sites to low successrate

4 posts in this topic

#1 ·  Posted (edited)

Dear AutoIT-Community,

I am writting a Script which shall messaure the Performance of some Intranetsites, every Minute several Sites. (I am limited to IE9 + W7) and writing the time to log files

using IE.au3 Lib and _IECreate

$oie = _IECreate("http://myIntranet.com/",0,1,1,0)

i get the following error

 C:\Program Files (x86)\AutoIt3\Include\IE.au3 (560) : ==> The requested 
action with this object has failed.:
WEnd
WEnd^ ERROR

but in fact i think its this line which produces the error, because there is no object to fetch =(

IE.au3 (233) 

Local $o_object = ObjCreate("InternetExplorer.Application")

also with ObjGet("","InternetExplorer.Application") there was no chance to get the object of the intranet site

BTW: We are using single-sign-on in our company, and there is no way to turn it of.

 

So I tried to use Mouseclicks to click through the side, but every 10-100 runs, an error occurs, because the script is not clicking accurate.

 

stuff like:

Sleep(3050)
Send("{TAB}3{ENTER}")   
Sleep(1250)
MouseClick("left",406,355,2)
$begin = TimerInit()
Sleep(100)
$alternative = 0   
Do      
Sleep(150)
$dif = TimerDiff($begin)           
MouseClick("left",517,230,1)      
Send("{CTRLDOWN}a{CTRLUP}{CTRLDOWN}c{CTRLUP}")      
$alternative = $alternative + 1   Until StringLeft(ClipGet(), 10 ) = "Oil&Gas" or $alternative > 30

My last chance was to compare ImagesSearch.au3 (http://www.autoit.de/index.php?page=Thread&threadID=20415) but i couldnt make it to compare a single image.

using this TUT:

Edited by macvoo

Share this post


Link to post
Share on other sites



If you search the forum for this error message and the IE UDF you will find a lot of threads.


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2017-04-18 - Version 1.4.8.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2017-02-27 - Version 1.3.1.0) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2015-04-01 - Version 0.4.0.0) - Download - General Help & Support - Example Scripts
Excel - Example Scripts - Wiki
Word - Wiki
PowerPoint (2015-06-06 - Version 0.0.5.0) - Download - General Help & Support

Tutorials:
ADO - Wiki

 

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

If you search the forum for this error message and the IE UDF you will find a lot of threads.

you are absolutely right! Sorry on that. Using the latest AutoIT Beta + latest IE.au3 solved the problem, so i now can use IE.au3 library for the Intranet.

'?do=embed' frameborder='0' data-embedContent>>

 

can I close this thread on my own?!

Edited by macvoo

Share this post


Link to post
Share on other sites

Glad you got your problem solved :)

I think you need at least a post count of 10 before you can close a thread by editing the first post.


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2017-04-18 - Version 1.4.8.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2017-02-27 - Version 1.3.1.0) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2015-04-01 - Version 0.4.0.0) - Download - General Help & Support - Example Scripts
Excel - Example Scripts - Wiki
Word - Wiki
PowerPoint (2015-06-06 - Version 0.0.5.0) - Download - General Help & Support

Tutorials:
ADO - Wiki

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0