Jump to content
gingerpantman

random deployment issue

Recommended Posts

gingerpantman

Hi, So i have the script below and if i run it on a local machine with elevated rights it works fine, i deploy these scripts via LANDesk which installs the software as the local system account, The below script however seems to run, but doesnt execute anything, i can tell it executes as the EXE for the script is sitting in task manager not doing anything.

I thought maybe UNC was causing an issue however i have the same problem on an XP machine. Anyone got any ideas?

Run ("Install3MDrivers.exe")
Send ("{enter}")
winwaitactive ("3M USB Reader Driver Installation")
Send ("{enter}")
winwaitactive ("Device Driver Installation Wizard")
Send ("!n")
Winwaitactive ("Device Driver Installation Wizard", "Completing the Device Driver Installation Wizard")
Send ("{enter}")

Share this post


Link to post
Share on other sites
water

Doesn't the installer provide command line switches for a silent install?

Edited by water

My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (2018-06-01 - Version 1.4.9.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2018-09-01 - Version 1.3.4.0) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2017-07-21 - Version 0.4.0.1) - Download - General Help & Support - Example Scripts
PowerPoint (2017-06-06 - Version 0.0.5.0) - Download - General Help & Support
Excel - Example Scripts - Wiki
Word - Wiki
 
Tutorials:

ADO - Wiki

 

Share this post


Link to post
Share on other sites
gingerpantman

Hi nope, run a /? after it and it gave a few options /Q for example but none which work unfortunatly so it has to automated like this.

Share this post


Link to post
Share on other sites
Bert

different solution - use a virtual PC to get a "before snapshot" of the system state and a snapshot of the system state after you do the install. Find every difference and make a package with all the differences. You could make your own package then to run as you like and no clicking on buttons to install.

Share this post


Link to post
Share on other sites
JLogan3o13

For Bert's approach, I would suggest the following:

http://nsis.sourceforge.net/Main_Page

In years past I would have also suggested Wix, but it looks as though this product is finally dying.


√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×