Jump to content
Arka

Is there any way to verify a checkbox is already checked or not using any method.

Recommended Posts

Arka

I have a tool & in that i have a checkbox. I am clicking on that checkbox by using "ControlClick" method.

ControlClick("Internet Properties", "Start with ta&bs from the last session", "[CLASS:Button;INSTANCE:4]", "");

However i want to verify before clicking on that checkbox is already checked or not? Is there any way. 

Any example or help will be great.

Share this post


Link to post
Share on other sites
Danyfirex

Hello check controlcommand in helpfile.

 

Saludos

Share this post


Link to post
Share on other sites
Arka

@Danyfirex Thanks for the help.

Need one more help. How to change the values in slider. Attached screenshot: Slider.png

Say i have "High,Medium-High,Medium,Medium-low,low" values & based on input these slider values needs to change. 

Please help me for the above.

Slider.PNG

Edited by Arka

Share this post


Link to post
Share on other sites
Arka

@Bert I am creating a Autoit script which will read the inputs & based on that it will update the slider values.

EX: Say If the input is "High" it will set the slider to "High".

Code written for the same, however this is not a fullproof code, As if its already set to high, This code will not work. 

Needs some guidelines here:

If $sResult = "High" Then
    $CMD = "inetcpl.cpl"
    RunWait(@ComSpec & " /c " & $CMD); 
    WinWaitActive("[CLASS:#32770]");  
    ControlClick("Internet Properties", "Use de&fault", "[CLASS:Button;INSTANCE:2]", ""); 
    Send("+{TAB}");
    Send("+{TAB}");
    Send("+ {RIGHT}");
    Sleep(1000)
    Send("{TAB}");
    Send("{TAB}");
    Send("+{UP}");

 

Edited by Arka

Share this post


Link to post
Share on other sites
SadBunny

What do you mean by "will not work"? Expected versus experienced behaviour?


Roses are FF0000, violets are 0000FF... All my base are belong to you.

Share this post


Link to post
Share on other sites
Arka

Expected: Lets say value is set to "low", expected is using the above script it should set it to high.

Experienced: When the value is set to "low", script is setting the value is medium.

I got a new solution for the above. Thanks for the help. :)

Share this post


Link to post
Share on other sites
SadBunny

Well, that's easy... You only press "{up}" one time and you should press it twice as you want it to go up twice. Or just press "{HOME}" to up it to the maximum setting immediately.


Roses are FF0000, violets are 0000FF... All my base are belong to you.

Share this post


Link to post
Share on other sites
Arka

Thanks. However I did it by using your 1st approach. :)

Share this post


Link to post
Share on other sites
SadBunny

Note: GUI automation is typically the last resort. The security settings can be set in other ways, perhaps you should try and directly set the required zone levels in the registry, HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Zones.

RegRead, RegWrite...

Also, depending on what your network/deployment situation is, group policies may be the best way to go.


Roses are FF0000, violets are 0000FF... All my base are belong to you.

Share this post


Link to post
Share on other sites
Arka

Unable to get the values using Autoit inspector inside>> IE>Internet settings.

Screenshot attached: Autoit issue.png.

Please help me out how to get the values using autoit inspector.

Autoit issue.PNG

Share this post


Link to post
Share on other sites
BrewManNH

Refer to post #4, automating the GUI is the last thing you should be doing.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites
Arka

Using "Send" keys i am able to do. But that is not Foolproof.

As checkbox is already "Checked" how we will verify using "Send" key.

Send("{TAB}");
Send("+{DOWN}");
Send("+{SPACE}");

This code will do when checkbox is already checked then it will uncheck & if it is uncheck then it will check.

However i want to do first checkbox is already checked or not?

Share this post


Link to post
Share on other sites
AutoBert

You need #RequireAdmin and ControlListView, but i also suggest regread/regwrite is the better way.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • DynamicRookie
      By DynamicRookie
      Hey there!
       
      Is there a way to detect movement only for 1 specific window?

      HWnd is not really working, it still detects movement in all the windows within the region

      This is my script:
       
      ;Checksum actual HotKeySet("{f2}", 'exit_') MsgBox(0, '', '0') Beep(500, 2000) $Hwnd = WinActive('') while 1 $Checksum = PixelChecksum(211, 650, 1094, 914, 1, $Hwnd) If PixelChecksum(211, 650, 1094, 914, 1, $Hwnd) <> $Checksum Then For $i = 1 To 100 Beep(1000, 50) Next MsgBox(0, '', 'New message!', 1) EndIf WEnd Func exit_() Beep(500, 1000) Exit 0 EndFunc I just want to check whenever a message comes because the app i use doesn't give notifications properly.

      Any help is really appreciated!
    • PramodR
      By PramodR
      Can you please see whats wrong im doing in the below code? i can read few registry entry but not all for eg, i am able to get value of "Shell" Key from the registry path  but not AutoAdminLogon which has the value of "1", is there any change i have to do to read numeric values?
       Global  $shello = RegRead ("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","Shell" )
       ConsoleWrite("This is Hello"& $shello)
      above command returns proper value , but same command with AutoAdminLogon returns null as shown in below ? infact registry has the value of 1.
       Global  $shello = RegRead ("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon","AutoAdminLogon" )
       ConsoleWrite("This is Hello"& $shello)
    • Eminence
      By Eminence
      Hello,
      I've been searching on how to select the first row in my database which includes a time column based on the latest start_time date for today's date.
      This is my current code:
      Local $iCurrentDate = _Now() Local $sqlHandle = _dbOpen($sDbPath) Local $aResult, $iRows, $iCols _SQLite_GetTable2d($sqlHandle, "SELECT start_time FROM " & $srawDb & " ORDER BY datetime(start_time) DESC LIMIT 1", $aResult, $iRows, $iCols) _ArrayDisplay($aResult) _dbClose($sDbpath) What it does is it gets the first row entry in the database however it does not select the latest start_time entry in the database, it always select the first row. I've tried changing DESC to ASC to see if that will do it but the issue still remains. Any thoughts on this? Thanks in advance.
       
      *EDIT
      The date format in the database is by MM/DD/YYYY HH:MM:SS.
    • Trisha
      By Trisha
      Hello,
      I Have clicked on save as option to save a file, while doing that I need to rename a file appending with sysdate. I have searched in google find the below one line of code:
      FileMove("C:\somefile.txt", "C:\somefile1.txt"), When I am trying to append with sysdate. It is not happening. Please help me out  with the small issue.
    • TrashBoat
      By TrashBoat
      hey i would like to know if its possible to take a string like this
      $string = "onethousandninehundredeightyfive" and convert it into:
      $string = "one thousand nine hundred eighty five" i have something going on here but its no use
      $string = "onethousandninehundredeightyfive" Global $array[9] = ['one', 'two', 'three', 'four', 'five', 'six', 'seven', 'eight', 'nine'] Global $array1[19] = ['onethousand', 'twothousand', 'threethousand', 'fourthousand', 'fivethousand', 'sixthousand', 'seventhousand', 'eightthousand', 'ninethousand','tenthousand','hundred', 'twohundred', 'threehundred', 'fourhundred', 'fivehundred', 'sixhundred', 'sevenhundred', 'eighthundred', 'ninehundred'] MsgBox(0, 0, AddSpaces($string)) Func AddSpaces($string) Local $finalStr $length = StringLen($string) For $x = 0 To $length Local $trim = StringTrimRight($string, $x) For $h = 0 To 18 If $trim = $array1[$h] Then $finalStr = $finalStr & " " & $trim $string = StringTrimLeft($string, $h) $length = StringLen($string) EndIf Next For $z = 0 To 8 If $trim = $array[$z] Then $finalStr = $finalStr & " " & $trim $string = StringTrimLeft($string, $z) $length = StringLen($string) EndIf Next Next Return $finalStr EndFunc ;==>AddSpaces  
×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.