Jump to content
tbodine88

Au3Record feature request

Recommended Posts

tbodine88

Hello

 

I use Au3Record a lot to start building new applications.

I like to use tidy from inside Scite to make the code tidy.

It always complains about the utf16 nature of the code generated by AU3record

I have found that when running cygwin this works well:

iconv -f UTF-16LE -t UTF-8 afile_utf16.au3 > afile_utf8.au3

It would be preferable to be able to select the encoding from the Au3record GUI

 

Thanks


tbodine

Share this post


Link to post
Share on other sites
water

Au3Record is no longer part of AutoIt. So I'm sure there will be no code enhancement in the near future ;)

 


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (2018-06-01 - Version 1.4.9.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2018-09-01 - Version 1.3.4.0) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2017-07-21 - Version 0.4.0.1) - Download - General Help & Support - Example Scripts
PowerPoint (2017-06-06 - Version 0.0.5.0) - Download - General Help & Support
Excel - Example Scripts - Wiki
Word - Wiki
 
Tutorials:

ADO - Wiki

 

Share this post


Link to post
Share on other sites
TheDcoder

@tbodine88 Since you are already using SciTE to tidy the code, you can also change the encoding to UTF-8 or local code page before saving :)


AutoIt.4.Life Clubrooms - Life is like a Donut (secret key)

Spoiler

My contributions to the AutoIt Community

If I have hurt or offended you in anyway, Please accept my apologies, I never (regardless of the situation) mean to do that to anybody!!!

3fHNZJ.gif

PLEASE JOIN ##AutoIt AND HELP THE IRC AUTOIT COMMUNITY!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×