Jump to content

Recommended Posts

Posted (edited)

Hi,

I am using 3.3.8.1 and Scite lite. I would like to change the ProductVersion of an exe file created with AutoIt.

I know it can be done with full version of Scite and AutoIt 3.3.14 (with AutoitWrapper of Scite). But since of many script breaking changes I don't want to upgrade to AutoIt 3.3.14; even 3.3.10 make problems with my code.

What options do I have to change ProductVersion? 

Regards
Dolphins

Edited by dolphins

Share this post


Link to post
Share on other sites
Posted (edited)
6 minutes ago, dolphins said:

I know it can be done with full version of Scite and AutoIt 3.3.14 (with AutoitWrapper of Scite).

You can simply only update to the full SciTE4AutoIt3 and stick with your old AutoIt3 version. .....should work fine.

Jos

Edited by Jos

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

@Jos

That is what I tried first. I had AutoIt 3.3.8.1 installed with Scite lite. When I try to install Scite full version (4.2.0) I get errors already when installing. There are include files missing. I tried to create empty include files, but when there are other errors. The 3.3.8.1 version of AutoIt has problems with parts of the code from Scite.

I tried an older version of Scite (3.6), but with the same errors as 4.2.
If you can help on this, I would be happy.

@Shark007
Thanks a lot. That is of course possible. There are several tools available for doing the job of changing the productversion. I could also write a program in another language and so on. But I really would like to do it with AutoIt.

Regards
Dolphins

Share this post


Link to post
Share on other sites
Posted (edited)
4 minutes ago, dolphins said:

That is what I tried first. I had AutoIt 3.3.8.1 installed with Scite lite. When I try to install Scite full version (4.2.0) I get errors already when installing. There are include files missing. I tried to create empty include files, but when there are other errors. The 3.3.8.1 version of AutoIt has problems with parts of the code from Scite.

I tried an older version of Scite (3.6), but with the same errors as 4.2.
If you can help on this, I would be happy.

Are you getting Autoit3Wrapper errors or something?

You could always copy your 3.3.8.1 setup to a separate directory and install the latest and greatest AutoIt3 & FUll SciTE4AutoIt3 and then add the following directive to your script which still requires the old AutoIt3 version:

#AutoIt3Wrapper_AutoIt3Dir=c:\path\to\autoit3\3.3.8.1

Jos  

Edited by Jos

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

@Jos
Ok, good idea. I will try this later and let you know if it works.

Regards
Dolphins

Share this post


Link to post
Share on other sites
Posted (edited)

@Jos

It worked great. Thank you very much!

 

@Zedna

Thanks, this is a pretty cool solution.

 

Regards
Dolphins

Edited by dolphins

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...