Jump to content
GeorgeP

Windows 10 issue with data acquisition stopping

Recommended Posts

Hi,

I have a Windows 10 system (professional) that is running SCADA software talking with a series on instruments. One of them is on a USB connection but it suddenly loses communication with it hence I lose data. This system ran perfectly for several years on a Windows 7 box with the same hardware and I did temporarily go back to the Win 7 box to see if the same issue arose but it didn't - hence it is a Windows 10 issue. I overcome the problem by writing an Autoit script that started a piece of software that would re-scan the ports to my instruments which re-sets the communications and all works fine again.  or so I thought. The system still randomly loses comms.

Finally I had my SCADA software create a file when the comms errored (I get a message to advise me that comms has stopped) and then I created an Autoit script that runs the comms program to re-scan the ports, delete the file created by my SCADA software and write information to a log file. Testing this interactively or by watching the SCADA software until the error occurs worked fine - I thought the problem although not solved was worked around, I set my Autoit script to run every 5 minutes. However, the system often loses comms in the middle of the night between 10 pm and 4 am when no-one is around. My log file tells me that the script has run and the temporary file no longer is present which shows my script has deleted it but it hasn't corrected the comms by re-scanning the ports. Of course, the next time the SCADA system tries to communicate with the USB port it fails and creates the temporary file again. So during the night the files is being created then deleted by my script but comms is not re-scanned. I am working remotely to this SCADA system using Remote Desktop and I discovered that if I log into it via RDC and wait for my Autoit script to run at the next 5 minute interval it runs correctly and resets the comms ports and all works fine in my SCADA.

I have searched and set every setting relating to the screen, hard drive and USB ports to be not controlled by the computer and that they are never to sleep but this still happens. I am convinced this is a Windows 10 issue with some hardware going to sleep and not responding. Has anyone else seen this behaviour?

BTW, I am on to my second Windows 10 box and both exhibit the same behaviour while the Windows 7 box didn't but we need to move to Windows 10 for security reasons.

Thanks

George

Share this post


Link to post
Share on other sites

@GeorgeP

Which SCADA software are you running?

And what is the device connected via USB to the SCADA?

For the running problem of your script, if the script is run as an application and not a service, and no users are logged to the PC, then it's normal that the script does not run, but it can be easily fixed :)


Click here to see my signature:

Spoiler

ALWAYS GOOD TO READ:

 

Share this post


Link to post
Share on other sites

Talking to the SCADA ppl could be a good idea, they may are working on a fix...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...