Jump to content
Sign in to follow this  
Gillboss

Why not Work

Recommended Posts

Gillboss

its not Work sucefully

somtime work somtime dont work

i mean somtime click somtime dont click

MouseClick("Left" ,796,386)
                     Sleep(500)
                     MouseClick("Left" ,707,576)
                     Sleep(1000)
                     
                     MouseClick("Left" ,827,386)
                     Sleep(500)
                     MouseClick("Left" ,707,576)
                     Sleep(1000)
                     
                     MouseClick("Left" ,860,386)
                     Sleep(500)
                     MouseClick("Left" ,707,576)
                     Sleep(1000)
                     
                     MouseClick("Left" ,893,386)
                     Sleep(500)
                     MouseClick("Left" ,707,576)
                     Sleep(1000)
                     
                     MouseClick("Left" ,926,386)
                     Sleep(500)
                     MouseClick("Left" ,707,576)
                     Sleep(1000)
                     
                     MouseClick("Left" ,958,386)
                     Sleep(500)
                     MouseClick("Left" ,707,576)
                     Sleep(1000)

Share this post


Link to post
Share on other sites
spudw2k

Use SendControl or send keys instead of mouse click if possible, it's more accurate for automation. What are you trying to automate?

Share this post


Link to post
Share on other sites
Gillboss

the problem is that the bot not send the "clicks"

sometime yes and sometime no..

Share this post


Link to post
Share on other sites
spudw2k
Gillboss

no..

the mouse all the time move, but not all the time click..

Share this post


Link to post
Share on other sites
duckling78

Maybe try changing the "MouseClickDelay" and "MouseClickDownDelay" values? They default to 10 ms.

By the way, what application are you automating?

Opt("MouseClickDelay", "50")
Opt("MouseClickDownDelay", "50")

ClickIt(796)
ClickIt(827)
ClickIt(860)
ClickIt(893)
ClickIt(926)
ClickIt(958)

Func ClickIt($x, $y = 386)
    MouseClick("primary", $x, $y, 1, 1)
    Sleep(500)
    MouseClick("primary", 707, 576, 1, 1)
    Sleep(1000)
EndFunc
Edited by duckling78

Share this post


Link to post
Share on other sites
Gillboss

so if its my project:

MouseClick("Left" ,796,386)
                     Sleep(500)
                     MouseClick("Left" ,707,576)
                     Sleep(1000)
                     
                     MouseClick("Left" ,827,386)
                     Sleep(500)
                     MouseClick("Left" ,707,576)
                     Sleep(1000)
                     
                     MouseClick("Left" ,860,386)
                     Sleep(500)
                     MouseClick("Left" ,707,576)
                     Sleep(1000)
                     
                     MouseClick("Left" ,893,386)
                     Sleep(500)
                     MouseClick("Left" ,707,576)
                     Sleep(1000)
                     
                     MouseClick("Left" ,926,386)
                     Sleep(500)
                     MouseClick("Left" ,707,576)
                     Sleep(1000)
                     
                     MouseClick("Left" ,958,386)
                     Sleep(500)
                     MouseClick("Left" ,707,576)
                     Sleep(1000)

how should it seem?

ty :D

Share this post


Link to post
Share on other sites
duckling78

Add the following to the top of your script:

Opt("MouseClickDelay", "50")
Opt("MouseClickDownDelay", "50")

Change the "50" to different values until the program you're trying to click in accepts your clicks more regularly.

Share this post


Link to post
Share on other sites
Gillboss

well it slove :D but i have more problem:

Send("1")
                         Opt("MouseCoordMode", 1)
                         MouseClick("Right",1000,71)
                         Opt("MouseClickDownDelay", $Speed)                  

                         Send("2")
                         Opt("MouseCoordMode", 1)
                         MouseClick("Right",1000,71)
                         Opt("MouseClickDownDelay", $Speed)                  

                         Send("3")
                         Opt("MouseCoordMode", 1)
                         MouseClick("Right",1000,71)
                         Opt("MouseClickDownDelay", $Speed)

the mouse move and click but the bot not send the numbers good..

Share this post


Link to post
Share on other sites
duckling78

Try adding the following to the top of your script:

Opt("SendKeyDownDelay", 50)

Share this post


Link to post
Share on other sites
Gillboss

Thanks work!!!! You are Wise :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.