Jump to content
Sign in to follow this  
xcraft

GUI focus problem

Recommended Posts

xcraft

Hello guys,

I am working on one script with GUI that it will activate the language input method for the current window. Right now, I have created some buttons to do it. But when I click the button, it will focus to autoit gui itself and not to the current window. Meanwhile, I need the script to do the same job like the language bar for some reasons I have to do. For example, when I open the IE, notepad ,word or other editors.. and I want to switch the language input method to those applications.

does anyone know there have some parameters to disable the focus on the autoit gui itself?

Thanks,

Craft

Edited by xcraft

Share this post


Link to post
Share on other sites
xcraft

I found the solution to resolve it.

You can use the code like to below to stop the activate for the gui interface

$DONTACTIVE = 0x8000000

GUICreate("Testing", 112, 268, 192, 124, -1, $DONTACTIVE )

Share this post


Link to post
Share on other sites
Yashied

I found the solution to resolve it.

You can use the code like to below to stop the activate for the gui interface

$DONTACTIVE = 0x8000000

GUICreate("Testing", 112, 268, 192, 124, -1, $DONTACTIVE )

$WS_DISABLED (0x08000000)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.