Jump to content
Sign in to follow this  
Emiel Wieldraaijer

Quality added Icon to Executable

Recommended Posts

Emiel Wieldraaijer

Hi All,

I created an icon with several formats in it

256x256 - PNG Compressed

48x48 RGB/a + 256 + 16

32x32 RGB/a + 256 + 16

16x16 RGB/a + 256 + 16

When i add this icon to the AutoIt executable the 256x256 PNG Compressed icons isn't used in Windows Vista and in Windows 7 which result in low quality icons when using ALT-Tab.. and low resolution icons used in the taskbar.

Is it not possible to use/add 256x256 PNG Compressed icons as default icon ? or am i doing something wrong.

Thanks

Best regards,

Emiel


Best regards,Emiel Wieldraaijer

Share this post


Link to post
Share on other sites
Zedna

I'm not sure but maybe you should use Icon Group resource section.

Look at your final EXE and other EXE files containing multiresolution icons by reshacker and compare it.

I saw some such EXE files and its icons were inside ICON GROUP resource section.

Share this post


Link to post
Share on other sites
Emiel Wieldraaijer

Hi Zedna (The Great "Resource adding master" :) )

yes i already did ..

The problem is the following

I believe the specified icon is displayed as the following

0 x 0 (16.8mil colors) - Ordinal name: 7

When opening the group it will display "Out of systen resources"

Not every program supports PNG Compressed icons for more information see

http://www.axialis.com/

Microsoft Visual Studio® 2008 supports PNG Compressed icons but Visual C++ 6.0 and Visual .NET 2003/2005 reject the icons.

Thanks for the reply

Emiel


Best regards,Emiel Wieldraaijer

Share this post


Link to post
Share on other sites
Zedna

Hi Zedna (The Great "Resource adding master" :) )

Thanks for compliment :-)

When opening the group it will display "Out of systen resources"

Not every program supports PNG Compressed icons for more information see

http://www.axialis.com/

Microsoft Visual Studio® 2008 supports PNG Compressed icons but Visual C++ 6.0 and Visual .NET 2003/2005 reject the icons.

"Out of systen resources" is error from reshacker?

I think you should check if rehacker.exe supports it firstly.

At first it's related more on reshacker than on Autoit.

In your script you don't load/use this icon?

Share this post


Link to post
Share on other sites
wraithdu

What if you just create your multires icon using IcoFx and add it in the normal way through AutoIt3Wrapper/Scite? Does it work then?

Edited by wraithdu

Share this post


Link to post
Share on other sites
Emiel Wieldraaijer

@Zedna

Rehacker.exe ? Did i miss something !

Yes i use the icon as a GUIIcon and TrayIcon those two icons are displayed nicely.

@Wraithdu

I will try

Both Thanks

Emiel


Best regards,Emiel Wieldraaijer

Share this post


Link to post
Share on other sites
Zedna

When opening the group it will display "Out of systen resources"

Where it comes from?

Try to look at your final compiled EXE by reshacker.exe

Yes i use the icon as a GUIIcon and TrayIcon those two icons are displayed nicely.

So where exactly problem is?

Sorry for not understanding ;-)

Edited by Zedna

Share this post


Link to post
Share on other sites
Emiel Wieldraaijer

@Wraithdu

Same problem

@Zedna,

The icon used in the GUI and Tray are displayed correctly because the 48x48 (or 32x32) icon is used for both of them and there are very small so they are perfect.

Let me try to explain, when the program is started and you press the ALT+Tab keys the program icons are displayed and my icon isn't very nice.

I investigated a bit more

When i add my icon with only 256x256 PNG Compressed format the icon is displayed perfect in Vista and Windows 7, but when i add all of the sizes to my icon file it isn't displayed good.. i want to add multiple sizes to the icon file to support Windows XP and Windows 2000.

It looks like 48x48 or 32x32 is the default icon

Emiel


Best regards,Emiel Wieldraaijer

Share this post


Link to post
Share on other sites
Emiel Wieldraaijer

@All,

The problem is the 256x256 PNG Compressed Image..

It isn't used as the master GUI icon


Best regards,Emiel Wieldraaijer

Share this post


Link to post
Share on other sites
Yashied

@All,

The problem is the 256x256 PNG Compressed Image..

It isn't used as the master GUI icon

Convert (by Axialis IconWorkshop) your PNG compressed icon to normal 256x256 RGB/a icon and everything will work fine. Icons with PNG compressed are not supported at the system level (WinAPI).

Share this post


Link to post
Share on other sites
Dolemite50

OFF-TOPIC:

Axialis kicks a whole lotta ass. Highly recommended for icon development.

Share this post


Link to post
Share on other sites
Emiel Wieldraaijer

@Yashied,

I know but this will increase the Icon file with approx.. 300kb

But

@All

The Problem i have is caused by the following

GUISetIcon(@Scriptname) sets the default icon of the EXE to 48x48 instead of dynamicly assing the right file to the EXE

I don't know if it's a bug or just me being stupid again

Best regards,

Emiel


Best regards,Emiel Wieldraaijer

Share this post


Link to post
Share on other sites
Zedna

@All

The Problem i have is caused by the following

GUISetIcon(@Scriptname) sets the default icon of the EXE to 48x48 instead of dynamicly assing the right file to the EXE

I don't know if it's a bug or just me being stupid again

If you are sure then make simple reproducing script and add your icons to it

and create new bug ticket here or on the BugTrac.

Share this post


Link to post
Share on other sites
Emiel Wieldraaijer

@Zedna,

Will place it here so others can first check before i report it

#Region 
#AutoIt3Wrapper_icon=globe.ico
#AutoIt3Wrapper_outfile=IconBug.exe
#AutoIt3Wrapper_UseUpx=n
#EndRegion 
#include <GUIConstantsEx.au3>

GUICreate("Icon Bug", 315, 260)
; GuiSetIcon (@Scriptname) produces the Icon Bug with ALT-TAB / System Tray
; Wrong icon is displayed on Vista/Windows 7 i Believe 48x48 instead of a better one
; Remove the GuiSetIcon and the icon is displayed correct
GuiSetIcon(@ScriptName)
GuiCtrlCreateLabel("Hello World", 10, 10, 200, 20)
GUISetState()

While 1
    $msg = GUIGetMsg()
    If $msg = $GUI_EVENT_CLOSE Then exit
Wend

Look at the icons used for displaying the program when pressing ALT-TAB.

The globe is much better when no GuiSetIcon(@ScriptName) is used.

I know it isn't necessary to use it.. but i still believe it's a bug

Can someone acknowledge this ? Before i report it as a bug..

Best regards and Thanks,

Emiel

globe.ico

Edited by Emiel Wieldraaijer

Best regards,Emiel Wieldraaijer

Share this post


Link to post
Share on other sites
Jon

On my windows 7 and vista systems it's 32x32 icons that are used in ALT-TAB. The only place I can see that uses 256x256 and 48x48 is in the large thumbnail view in explorer. The problem is that our gui icon code only works with the small "16x16" icons so the alt-tab image is getting an expanded version of that which looks crappy. We need to adds lots of stuff to load multiple icons for different places. At the very least we need 16x16 and 32x32

I've changed the bug to a feature request because it needs a complete overhaul of the set icon code to work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.