Sign in to follow this  
Followers 0
wimhek

If program does not start

4 posts in this topic

Hi I am having troubles with my script. I start up a program, but sometimes is fails. Result is that Autit loops. How can I avoid this.

Code is simple (generated)

If Not WinActive("ServiceCenter", "") Then WinActivate("ServiceCenter", "")

WinWaitActive("ServiceCenter", "")

I tried several options, any help would be appreciated.

Share this post


Link to post
Share on other sites

#2 ·  Posted (edited)

Set a timeout for Winwait like

$Result = WinWait("ServiceCenter", "", 10)
If $Result = 0 Then
 msgbox(0,"","ServiceCenter didn't start!")
 exit 
Endif
If Not WinActive("ServiceCenter", "") Then WinActivate("ServiceCenter", "")
WinWaitActive("ServiceCenter", "")

This solution has the advantage that your script goes on as soon as ServiceCenter starts up correctly but waits a maximum of 10 seconds if it doesn't.

Edited by water

My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2017-04-18 - Version 1.4.8.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2017-02-27 - Version 1.3.1.0) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2015-04-01 - Version 0.4.0.0) - Download - General Help & Support - Example Scripts
Excel - Example Scripts - Wiki
Word - Wiki
PowerPoint (2015-06-06 - Version 0.0.5.0) - Download - General Help & Support

Tutorials:
ADO - Wiki

 

Share this post


Link to post
Share on other sites

- Bruce /*somdcomputerguy */  If you change the way you look at things, the things you look at change.

Share this post


Link to post
Share on other sites

Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0