Sign in to follow this  
Followers 0

AutoIt doesn't work properly on windows7 or IE8

9 posts in this topic

Posted

I've run my AutoIt script on 4 different machines,on those that have windows7 installed on ,script doesn't show some text (ControlGetText()) return empty string, on XP machines the same command return text properly, or may be it depends on IE version? Did anybody have solved problem like this?

Share this post


Link to post
Share on other sites



Posted

Have you considered it might not be Windows 7? What code are you using first of all and what do you want to do? IE Versions vary from version to version, what is installed on XP? IE 6?

Share this post


Link to post
Share on other sites

Posted

I run the following script:

Local $text= ControlGetText("Speech Analytics","","[CLASS:RichEdit20A; INSTANCE:1]")

MsgBox(1,"xxx",$text)

On XP computer text is returned, on Windows 7 the text is empty, on XP IE7 is installed,

I guess those configurations may be the reason, may be not, if you have got another suggession, please share!

Share this post


Link to post
Share on other sites

Posted

I run the following script:

Local $text= ControlGetText("Speech Analytics","","[CLASS:RichEdit20A; INSTANCE:1]")

MsgBox(1,"xxx",$text)

On XP computer text is returned, on Windows 7 the text is empty, on XP IE7 is installed,

I guess those configurations may be the reason, may be not, if you have got another suggession, please share!

Do you use AutoIt Window Info with the 2 Os ?

Did you get same Infos for ControlGetText ?

Share this post


Link to post
Share on other sites

Posted (edited)

I use Autoit Info on both OSs,the difference is that on window7 I haven't got any result under "Active window", on XP there is text there,I'm looking for.

This text is extracted from player object, but only on XP...

Edited by LesnoyElf1

Share this post


Link to post
Share on other sites

Posted

LesnoyElf1,

Have you checked that the CLASS and INSTANCE values are the same on all OSs? :)

M23

Share this post


Link to post
Share on other sites

Posted

LesnoyElf1,

Have you checked that the CLASS and INSTANCE values are the same on all OSs? :)

M23

They are the same!

Share this post


Link to post
Share on other sites

Posted

This is the difference

post-63699-0-01005300-1300275806_thumb.p

Share this post


Link to post
Share on other sites

Posted

and this is the problematic variant

post-63699-0-94111700-1300275889_thumb.p

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.