Sign in to follow this  
Followers 0
netman74501

_INetGetSource function not working properly

7 posts in this topic

I am unable to get the _INetGetSource function to work at work. (No pun intended.) The function works just fine at home. I have tried disabling the AntiVirus and Windows Firewall. Therefore, I was wondering would my work's hardware firewall be blocking this in some way?

I need for this function (or an alternative function that will perform the same) to work in all circumstances as my program will soon be in the hands of about 9000 users.

The problem is that the source is never returned. In fact, nothing is ever returned. Not even an error (though I'm not sure how to check if this function errors out or not). How can I go about troubleshooting this? The problem exists even when using the example code found in the help file. Like I said, it works at home. Thanks in advance!

P.S.

If you need to see the code, I can provide the relevant part but, as previously stated, the code from the help file doesn't even work. Also, an interesting note is that internal addresses work (hence my suspicion of the hardware firewall).

Share this post


Link to post
Share on other sites



Hi there,

Do you have a proxy server at work?

Cheers.


Old Scriptology

Visual Ping 1.8 - Mass Ping Program with export to txt delimited.

Desktop 2 RGB and YMCK - Pick a color in the desktop and get the RGB and YMCK code.

Desktop 2 RGB - Pick a color in the desktop and get the RGB code.

ShootIT 1.0 - Screen Capture full and partial screen

[font="'Arial Black';"]Remember Remember The Fifth of November.[/font]

Share this post


Link to post
Share on other sites

Hi there,

Do you have a proxy server at work?

Cheers.

No we do not. That made me think of something that I totally forgot though; at home I run a proxy server and a firewall, (to be exact, SmoothWall with the advanced proxy plugin), that blocks everything ingoing and outgoing except a few ports and port 80. So now I'm at a loss as to what it could be that is different at work.

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Any ideas?

I guess I could always have a disclaimer that the update feature might not work behind firewalls or proxies. I'm not sure if my boss would just accept and leave it at that or not...

Edited by netman74501

Share this post


Link to post
Share on other sites

Did you try using another website for testing?


_AdapterConnections()_AlwaysRun()_AppMon()_AppMonEx()_BinaryBin()_CheckMsgBox()_CmdLineRaw()_ContextMenu()_ConvertLHWebColor()/_ConvertSHWebColor()_DesktopDimensions()_DisplayPassword()_DotNet_Load()/_DotNet_Unload()_Fibonacci()_FileCompare()_FileCompareContents()_FileNameByHandle()_FilePrefix/SRE()_FindInFile()_GetBackgroundColor()/_SetBackgroundColor()_GetConrolID()_GetCtrlClass()_GetDirectoryFormat()_GetDriveMediaType()_GetFilename()/_GetFilenameExt()_GetHardwareID()_GetIP()_GetIP_Country()_GetOSLanguage()_GetSavedSource()_GetStringSize()_GetSystemPaths()_GetURLImage()_GIFImage()_GoogleWeather()_GUICtrlCreateGroup()_GUICtrlListBox_CreateArray()_GUICtrlListView_CreateArray()_GUICtrlListView_SaveCSV()_GUICtrlListView_SaveHTML()_GUICtrlListView_SaveTxt()_GUICtrlListView_SaveXML()_GUICtrlMenu_Recent()_GUICtrlMenu_SetItemImage()_GUICtrlTreeView_CreateArray()_GUIDisable()_GUIImageList_SetIconFromHandle()_GUIRegisterMsg()_GUISetIcon()_Icon_Clear()/_Icon_Set()_IdleTime()_InetGet()_InetGetGUI()_InetGetProgress()_IPDetails()_IsFileOlder()_IsGUID()_IsHex()_IsPalindrome()_IsRegKey()_IsStringRegExp()_IsSystemDrive()_IsUPX()_IsValidType()_IsWebColor()_Language()_Log()_MicrosoftInternetConnectivity()_MSDNDataType()_PathFull/GetRelative/Split()_PathSplitEx()_PrintFromArray()_ProgressSetMarquee()_ReDim()_RockPaperScissors()/_RockPaperScissorsLizardSpock()_ScrollingCredits_SelfDelete()_SelfRename()_SelfUpdate()_SendTo()_ShellAll()_ShellFile()_ShellFolder()_SingletonHWID()_SingletonPID()_Startup()_StringCompact()_StringIsValid()_StringRegExpMetaCharacters()_StringReplaceWholeWord()_StringStripChars()_Temperature()_TrialPeriod()_UKToUSDate()/_USToUKDate()_WinAPI_Create_CTL_CODE()_WinAPI_CreateGUID()_WMIDateStringToDate()/_DateToWMIDateString()Au3 script parsingAutoIt SearchAutoIt3 PortableAutoIt3WrapperToPragmaAutoItWinGetTitle()/AutoItWinSetTitle()CodingDirToHTML5FileInstallrFileReadLastChars()GeoIP databaseGUI - Only Close ButtonGUI ExamplesGUICtrlDeleteImage()GUICtrlGetBkColor()GUICtrlGetStyle()GUIEventsGUIGetBkColor()Int_Parse() & Int_TryParse()IsISBN()LockFile()Mapping CtrlIDsOOP in AutoItParseHeadersToSciTE()PasswordValidPasteBinPosts Per DayPreExpandProtect GlobalsQueue()Resource UpdateResourcesExSciTE JumpSettings INISHELLHOOKShunting-YardSignature CreatorStack()Stopwatch()StringAddLF()/StringStripLF()StringEOLToCRLF()VSCROLLWM_COPYDATAMore Examples...

Updated: 04/09/2015

Share this post


Link to post
Share on other sites

Did you try using another website for testing?

Yes. Google, Yahoo, Autoit and mine. None work. I thought maybe it could be the OS I was on so I switched from a Windows 7 machine to a Windows XP machine. Same results. Nothing returned. The only thing I want to do is ping a php script on the server and return the version number that script outputs. Is there another way to do this outside of _INetGetSource?

Share this post


Link to post
Share on other sites

#7 ·  Posted (edited)

Nevermind. I have found an alternative to accessing the source of a webpage and saving it to a variable that will work at my work (and hopefully everywhere else). Not familiar at all with COM, but it works. In case anyone is curious, this is what I ended up doing (taken from the COM Reference I stumbled upon in the help files):

$oHTTP = ObjCreate("winhttp.winhttprequest.5.1")
$oHTTP.Open("GET","http://google.com")
$oHTTP.Send()
$HTTPSource = $oHTTP.Responsetext
ConsoleWrite($HTTPSource)

Thank you to you both for responding.

Edited by netman74501

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0