Jump to content

Recommended Posts

Diana (Cda)

I have a script from before I did an OS wipe/reinstall a couple of weeks ago. I've been living with a new error ever since.

I didn't change anything, just perhaps didn't install all the apps I normally do. Each new install I try to install less and use standalones/portables more. So don't know what lack could be causing this problem and need to fix this without installing more things. I dl, scanned and then tried to register the dll in question but Windows doesn't seem to want to register this, no matter that I've tried several di.

Thought I'd ask here to see if anyone had encountered this problem as well, but had found resolution for.

When the SoundPlay and MP3 line comes up, I get the box: "AutoIt3.exe has encountered a problem and needs to close. We are sorry for the inconvenience" and then asks if I want to tell M$ about the problem (not hardly!).

Clicking the data this error report contains brings up my AI version and this:

ModName: mpegin.dll

ModVer: 1.103.4.1

Offset: 0001c45b

SoundPlay works fine on WAVs but not on MP3s anymore as I get this error on MP3s. But I used it before and really cannot start converting all the MP3s I use with SoundPlay to WAV just so that they can play nice with AI <vbg>. WAVs are too big if they're not just small, simple alarm sounds. Besides, this script has worked before and for a long time.

Any ideas on how to fix? I'm fresh out.

Thanks!! :graduated:

Share this post


Link to post
Share on other sites
Diana (Cda)

Title should read "mpegin.dll". New AI forum interface doesn't allow to make edits like before. Sorry for typo.

Share this post


Link to post
Share on other sites
AdmiralAlkex

Title should read "mpegin.dll". New AI forum interface doesn't allow to make edits like before. Sorry for typo.

I can edit my titles just like before from the full editor (Use Full Editor)....

Edit: your tags are funny :graduated:

Edited by AdmiralAlkex

Share this post


Link to post
Share on other sites
Diana (Cda)

Well, sure glad for you. New interface isn't working for me. Thanks anyway.

With regards to the dll, anyone have any ideas as to what is going on? SoundPlay won't work on MP3s when it always did before.

Thanks.

Edited by Diana (Cda)

Share this post


Link to post
Share on other sites
guinness

Maybe this could shed some light on your problem >>


UDF List:

 
_AdapterConnections()_AlwaysRun()_AppMon()_AppMonEx()_ArrayFilter/_ArrayReduce_BinaryBin()_CheckMsgBox()_CmdLineRaw()_ContextMenu()_ConvertLHWebColor()/_ConvertSHWebColor()_DesktopDimensions()_DisplayPassword()_DotNet_Load()/_DotNet_Unload()_Fibonacci()_FileCompare()_FileCompareContents()_FileNameByHandle()_FilePrefix/SRE()_FindInFile()_GetBackgroundColor()/_SetBackgroundColor()_GetConrolID()_GetCtrlClass()_GetDirectoryFormat()_GetDriveMediaType()_GetFilename()/_GetFilenameExt()_GetHardwareID()_GetIP()_GetIP_Country()_GetOSLanguage()_GetSavedSource()_GetStringSize()_GetSystemPaths()_GetURLImage()_GIFImage()_GoogleWeather()_GUICtrlCreateGroup()_GUICtrlListBox_CreateArray()_GUICtrlListView_CreateArray()_GUICtrlListView_SaveCSV()_GUICtrlListView_SaveHTML()_GUICtrlListView_SaveTxt()_GUICtrlListView_SaveXML()_GUICtrlMenu_Recent()_GUICtrlMenu_SetItemImage()_GUICtrlTreeView_CreateArray()_GUIDisable()_GUIImageList_SetIconFromHandle()_GUIRegisterMsg()_GUISetIcon()_Icon_Clear()/_Icon_Set()_IdleTime()_InetGet()_InetGetGUI()_InetGetProgress()_IPDetails()_IsFileOlder()_IsGUID()_IsHex()_IsPalindrome()_IsRegKey()_IsStringRegExp()_IsSystemDrive()_IsUPX()_IsValidType()_IsWebColor()_Language()_Log()_MicrosoftInternetConnectivity()_MSDNDataType()_PathFull/GetRelative/Split()_PathSplitEx()_PrintFromArray()_ProgressSetMarquee()_ReDim()_RockPaperScissors()/_RockPaperScissorsLizardSpock()_ScrollingCredits_SelfDelete()_SelfRename()_SelfUpdate()_SendTo()_ShellAll()_ShellFile()_ShellFolder()_SingletonHWID()_SingletonPID()_Startup()_StringCompact()_StringIsValid()_StringRegExpMetaCharacters()_StringReplaceWholeWord()_StringStripChars()_Temperature()_TrialPeriod()_UKToUSDate()/_USToUKDate()_WinAPI_Create_CTL_CODE()_WinAPI_CreateGUID()_WMIDateStringToDate()/_DateToWMIDateString()Au3 script parsingAutoIt SearchAutoIt3 PortableAutoIt3WrapperToPragmaAutoItWinGetTitle()/AutoItWinSetTitle()CodingDirToHTML5FileInstallrFileReadLastChars()GeoIP databaseGUI - Only Close ButtonGUI ExamplesGUICtrlDeleteImage()GUICtrlGetBkColor()GUICtrlGetStyle()GUIEventsGUIGetBkColor()Int_Parse() & Int_TryParse()IsISBN()LockFile()Mapping CtrlIDsOOP in AutoItParseHeadersToSciTE()PasswordValidPasteBinPosts Per DayPreExpandProtect GlobalsQueue()Resource UpdateResourcesExSciTE JumpSettings INISHELLHOOKShunting-YardSignature CreatorStack()Stopwatch()StringAddLF()/StringStripLF()StringEOLToCRLF()VSCROLLWM_COPYDATAMore Examples...

Updated: 22/04/2018

Share this post


Link to post
Share on other sites
Diana (Cda)

<sigh> Thanks. I'm already on that thread later on.

btw, the wait parameter is not an issue. I already have that in there as is needed. As I mentioned, this script worked fine before, in fact for maybe a year or more. There's something else going on that I don't know how to pinpoint. I no longer install a couple of applications that I used to and that _may_ be part of the problem but I'm ultimately not sure about that being the cause and don't know what part might have affected AI even if I did install them again.

Will keep looking. Thanks. I really need to fix this. It's an alarm sound that comes on as part of a scheduled script in early morning. The song portion is main part of alarm and it used to play for several minutes which is why I really need it to work and _without_ converting it to an absolutely ridiculously large wav. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×