Jump to content
Sign in to follow this  
Lorenzen

Problems running simple MsgBox Function on MS 2008 R2 server (64-bit)

Recommended Posts

Lorenzen

Hi

Im getting an "Unable to open the script file" msg when I try to run my script on MS 2008 R2 server (64-bit). Because of this I have made a simple test script that just launches a MsgBox displaing a static text string. The script is 1 line:

MsgBox(0, "ww", "123")

I've tried to compile to both 32 and 64 bit, but with no luck. Strange thing is that I have actually gotten the script to run a few times (1/30), but it generally fails.

There is no AV installed on the server. I cant see anything from the system logs. I have just installed the latest version of AutoIT. Googling the problem a bit, I can see that others have had the same problem, but usually due to some complicated coding. A simple MsgBox is ofc as simple as it gets.

Do you guys have any clue as to what is going on? Thanks

Christian

Share this post


Link to post
Share on other sites
careca

That is a weird one, as i don't know how to solve it, i would try installing SciTe and compile with and without UPX


Spoiler

Paster - Main function is to paste text, but has more functions. (No longer mantained, switched to String Trigger)

Renamer - Rename files and folders, remove portions of text from the filename etc.

GPO Tool - Export/Import Group policy settings.

BeatsPlayer - Music player.

Params Tool - Right click an exe to see it's parameters or execute them.

String Trigger - Triggers pasting text or applications or internet links on specific strings.

Inconspicuous - Hide files in plain sight, not fully encrypted.

Regedit Control - Registry browsing history, quickly jump into any saved key.

Time4Shutdown - Write the time for shutdown in minutes.

Power Profiles Tool - Set a profile as active, delete, duplicate, export and import.

Firefox Profile Backup - Backup/restore previously saved profile.

Finished Task Shutdown - Shuts down pc when specified window/Wndl/process closes.

NetworkSpeedShutdown - Shuts down pc if download speed goes under "X" Kb/s.

IUIAutomation - Topic with framework and examples

Au3Record.exe

Share this post


Link to post
Share on other sites
Lorenzen

I will give it a go. I was actually looking at this UPX option, but as I dont know what it is, I chose not to mess about with it. Thanks for the input - if anyone has anything to add it would be much appreciated! :)

Share this post


Link to post
Share on other sites
Lorenzen

Careca, you are the man! Disabling UPX did the trick. Still not sure what UPX is - gonna have to do some reading up on this at some point.

Thanks a bunch mate :D

Share this post


Link to post
Share on other sites
Melba23

Lorenzen,

upx is a file compressor whch makes the on-disk size of the exe as small as possible - and it is often flagged by AV packages as malware, so not using it is a good idea. Back in the old days when disk space was tight every byte counted, but now hard drives are sooo big it is not really worth the risk. ;)

M23


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites
Lorenzen

Ah, ok. Nice to know - thx for the info! Really appreciate your info/help guys :)

Share this post


Link to post
Share on other sites
Lorenzen

Hmmm, I am still having problems :/

After removing UPX yesterday, my compiled script ran just fine, but now I am having problems again. The .exe I compiled yesterday is still able to run on the server with no problems, but if I compile the exact same script (the simple msgBox script) again, in the exact same way as yesterday, the resulting .exe file will not run!

I've been working locally on my PC so I have only just realized that there are still problems running scripts on the server. I am now suspecting that the problem could be related to system privileges. Still it does not make sence why the .exe compiled yesterday can run with no problems :/

Any ideas?

Share this post


Link to post
Share on other sites
Lorenzen

Closing this one again - I can run scripts compiled to x86 on the server. In the midst of confusion, I forgot to check if that could be the problem.

Share this post


Link to post
Share on other sites
Lorenzen

For anyone experiencing the same problems as I did, let me just add that there was apparently something wrong with my compiler. I had problems again after the last post, and after some troubleshooting, I found that UPX was not being disabled on compilation, eventhough the box was unchecked. I noticed that the filesize of the compiled .exe was the same as the UPX-complied .exe - thats the only reason I was able to resolve the problem. After checking/unchecking the checkbox a few times, with compiles in between, the .exe file was finally compiled to a file-size that was about 10% larger than the UPX compiled .exe. The compiled .exe was able to run without any problems.

So in short, AutoIt can apparently have problems registering whether or not UPX is enabled (is my guess at least).

Share this post


Link to post
Share on other sites
Lorenzen

Thats a great suggestion - I will do the same. Thanks for sharing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×