Jump to content
Sign in to follow this  
Jon

Using AutoItX from C# / .Net

Recommended Posts

The following files are provided to allow .NET use:

  • AutoItX3.Assembly.dll - The .NET Assembly for using AutoItX.
  • AutoItX3.Assembly.xml - The Visual Studio Intellisense help file for the .NET Assembly.
  • AutoItX3.dll - The main AutoItX DLL (x86)
  • AutoItX3_x64.dll - The main AutoItX DLL (x64)

Using the Assembly from VB/C# within in Visual Studio is very easy:

  • Add a reference to AutoItX3.Assembly.dll to your project
  • Add a using AutoIt; statement in the files you want to use AutoIt functions
  • Write code like this C# example:
using AutoIt;

...

// Wow, this is C#!
AutoItX.Run("notepad.exe");
AutoItX.WinWaitActive("Untitled");
AutoItX.Send("I'm in notepad");
IntPtr winHandle = AutoItX.WinGetHandle("Untitled");
AutoItX.WinKill(winHandle);
  • Distribute your final executable with the files AutoItX3.Assembly.dll, AutoItX3.dll, AutoItX3_x64.dll.

Share this post


Link to post
Share on other sites

nice and easy but got error when run, Autoitx3.Dll can not access.

 reg dll like this "regsvr32 c:\AutoitX\AutoitX3.dll" for use, got an error 

what can i do now for using autoitx in C#

i'm using VS community 2015.

autoit error run.jpg

autoit error reg.jpg

Edited by xhuyvn

Share this post


Link to post
Share on other sites

nice and easy but got error when run, Autoitx3.Dll can not access.

 reg dll like this "regsvr32 c:\AutoitX\AutoitX3.dll" for use, got an error 

what can i do now for using autoitx in C#

i'm using VS community 2015.

autoit error run.jpg

autoit error reg.jpg

i was solved this problem. just copy AutoitX3.dll to bin directory and it work like a charm.

Share this post


Link to post
Share on other sites

can you please help me, i have the same trouble. added references to dll files, put using statement. but error comes up, it can't find autoit3x dll, whats going on?

Share this post


Link to post
Share on other sites

The DllNotFoundException is caused by screwed up assembly dependencies when the dll package was built.  Nuget installer for AutoitX is not working for the same reason (more details here).  Bottom line - Visual Studio doesn't know it needs to copy AutoItX3.dll to the output directory.  It only copies AutoItX3.Assembly.dll, and forgets about the other one.

The easiest solution is ensuring AutoItX3.dll is in your output bin/Debug or bin/Release directory, when you run your program (basically the same directory as your exe).  You can do that by simply placing AutoItX3.dll in the root of your project in visual studio, and then setting its properties to:

Copy to Output Directory: 'Copy if newer'

Share this post


Link to post
Share on other sites

Hi can someone enlighten me, I have a current application in autoit that calculate IP address. would I be able to port that to c# using autoitx3.dll then that application can be run off the browser. This is fascinating if true

thanks ahead for any answers

Edited by antonioj84

Share this post


Link to post
Share on other sites

I'm not sure what your post is getting at, with "run off the browser".

AutoIt3X allows you to reference the dll in C# and use its functions, which are a subset of AutoIt's native functions.

You wont find UDF functions such as _IE* etc...


AutoIt Absolute Beginners    Require a serial    Pause Script    Video Tutorials by Morthawt   ipify 

Monkey's are, like, natures humans.

Share this post


Link to post
Share on other sites

Hi Johnone,

I understand that part, however I mean in that case can the application run from a IIS server, then user can access thru their browser. I want to be able to use the native udf that come with autoit.

Edited by antonioj84

Share this post


Link to post
Share on other sites
On 01/02/2016 at 4:18 AM, Eternal21 said:

The DllNotFoundException is caused by screwed up assembly dependencies when the dll package was built.  Nuget installer for AutoitX is not working for the same reason (more details here).  Bottom line - Visual Studio doesn't know it needs to copy AutoItX3.dll to the output directory.  It only copies AutoItX3.Assembly.dll, and forgets about the other one.

The easiest solution is ensuring AutoItX3.dll is in your output bin/Debug or bin/Release directory, when you run your program (basically the same directory as your exe).  You can do that by simply placing AutoItX3.dll in the root of your project in visual studio, and then setting its properties to:

Copy to Output Directory: 'Copy if newer'

This resolved the issue when executing from visual studio, however when the build is put into an MTM build directory the error returns. Have confirmed that the dll is in the build directory.

 

Any thoughts?

Share this post


Link to post
Share on other sites
On 18.09.2015 at 6:21 AM, xhuyvn said:

nice and easy but got error when run, Autoitx3.Dll can not access.

 reg dll like this "regsvr32 c:\AutoitX\AutoitX3.dll" for use, got an error 

what can i do now for using autoitx in C#

i'm using VS community 2015.

autoit error run.jpg

autoit error reg.jpg

How can I list all windows with `AutoITX` static field? Seems most of methods are preserved, but `WinList` is missing. 

Share this post


Link to post
Share on other sites

Hi,

I tried to select an email in Outlook 2013 but without success. I succeeded with the below code to open the Outlook window and send a TAB

public void Outlook()
        {

            autoit.Run("C:\\Program Files (x86)\\Microsoft Office\\Office15\\outlook.exe");
            autoit.WinActivate(MessageText);
            
            string windowName = "Inbox - ";
            int found = autoit.WinWait(windowName, "", 10);
            if (found != 0)
            {
                autoit.WinActivate(windowName);
                
                autoit.Send("{ENTER}");
                autoit.Send("{TAB}");

            }
        }

Any idea or sugestion how to do this?

Share this post


Link to post
Share on other sites

Using C# from AutoIt and .Net

Now that we can run C# and VB code in AutoIt it could be interesting to see, if we can run the C# code from first post in AutoIt:

using AutoIt;
using System;
using System.Threading;

public class Au3Class
{
  public void MyMethod()
  {
    // Wow, this is C#!
    AutoItX.Run("notepad.exe", "", AutoItX.SW_SHOW);
    AutoItX.WinWaitActive("Untitled");
    AutoItX.Send("I'm in notepad{Enter}{Enter}");
    AutoItX.Send("From AutoItX in C{#}{Enter}{Enter}");
    AutoItX.Send("From C{#} in AutoIt through .NET Framework{Enter}");
    Thread.Sleep(5000);
    IntPtr winHandle = AutoItX.WinGetHandle("Untitled");
    AutoItX.WinKill(winHandle);
  }
}
#include "DotNetAll.au3"

Example()

Func Example()
  ; Wow, this is AutoIt!
  Local $oComErrFunc = ObjEvent( "AutoIt.Error", "ComErrFunc" )
  #forceref $oComErrFunc

  Local $oNetCode = DotNet_LoadCScode( FileRead( "AutoItXTest.cs" ), "System.dll | AutoItX3.Assembly.dll" )
  Local $oAu3Class = DotNet_CreateObject( $oNetCode, "Au3Class" )
  $oAu3Class.MyMethod()
EndFunc

You must copy AutoItX3.Assembly.dll, AutoItX3.dll and AutoItX3_x64.dll to @ScriptDir. And you must copy AutoItX3.Assembly.dll to AutoIt installation folder where AutoIt3.exe and AutoIt3_x64.exe are installed.

The code: AutoItXTest.7z

Edited by LarsJ

Share this post


Link to post
Share on other sites

Zag8888,

Look in your AutoIt installation folder, you will find the files in AutoItX subfolder.

M23


Public_Domain.png.2d871819fcb9957cf44f4514551a2935.png Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind

Open spoiler to see my UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites
2 hours ago, Melba23 said:

Zag8888,

Look in your AutoIt installation folder, you will find the files in AutoItX subfolder.

M23

I'm having 1 issue,

using Autoit;

IntPtr winhandle = AutoItX.WinGetPos("Google Chrome"); 
            if (AutoItX.PixelGetColor(745 + winhandle[0], winhandle[1] + 55) != 0xFF4DEB)
            {
                MessageBox.Show("text", "text");
            }
            
            

I get always error, what I wrong?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By learner123
      Hi All,
       
      I am new to this AUTO IT and I have created a script that will open an app,enter pin and copy the code generated to clipboard. My java code call this autoIT script and use the copied generated code from clipboard.
      This works fine when server  window is on focus. My server is an windows server. 
      But when I minimize or disconnect the server, the script opens the app.exe but doesn't copy any value to clipboard.  
      Can anyone help me on this 😐
       
      Run("C:\Program Files (x86)\RSA SecurID Software Token\SecurID.exe")
      Local $hWnd=WinWait("abc - RSA SecurID Token") ; waits until the window is the active window
      $hWin = WinGetHandle("abc - RSA SecurID Token");
      ControlSend($hWnd,"","","1111") ; simulates pressing the Home key
      ControlSend($hWnd,"","","{ENTER}");
      ControlSend($hWnd,"","","^c");
      Sleep(1000) ;
      ControlSend($hWnd,"","","^c");
       
    • By poddex
      Hello everyone.
      I always try to work with old Windows 10 versions as much as possible because I know mane compatibility issues with Windows 10 upgrading. 
      But I couldn't do anything else (I got drivers problem), and nothing couldn't help me besides upgrading, so I upgraded from 1807 to 1903.
      And...get another problem 😃
      I use AutoitX library in external project like this.
      ObjectAutoIt=New COMObject("AutoItX3.Control");
      ObjectAutoIt.AutoItSetOption("WinTextMatchMode",2);
              While ObjectAutoit.WinExists("",WindowHeader) Cycle 
                  ObjectAutoIt.WinClose("",WindowHeader);
              EndCycle;
      After upgrade I get that this line code 
      While ObjectAutoit.WinExists("",WindowHeader)
      become extremely low - ~ 20 seconds even if 10 windows open. But before upgrade it takes 0.5 s for a max.
      And every time that this code line passes through  - it takes ~20s, (20.115, for example), not less, not more. Something pauses it to work.
      How can I diagnose, what is that?
      I tried reinstall whole AutoIt, but no results.
      Thanks to all.
    • By Mudoch
      I need to replace a desktop applications functionality. I'll call it App "A".
      The application has defined 2 hot keys one that toggles between it and another window, App "B", and one that triggers keystrokes to App "B" to get data where App "A" can access it. Then tells app "A" to fire off processing of data.. Unfortunately when App "B" is a 64bit application this functionality no longer works. 
       
      For now I've hobbled together a work a round solution by using 2 apps with what appears to be similar abilities. AutoIt and a desktop application that allows me to define the 2 hot keys. The SutoItX Dll is great for my processes within App "A" as it uses VBA for event driven tasks.
      The second app allows me to define the Hot keys and which windows they belong to.
      My fail is on how to use AutoIT to define the hot Keys and link to specific windows.
      So as I see this working:
                App "A" launches and fires off internal VBA code that in turn sets up HotKeys. If App "B" is not found code shuts down without enabling the hotkeys.  
                A hot key of CTRL-F1 toggles, activates window, back and forth between App "A and "B"  So the hotkey is captured only when either App "A" or "B" is currently the active focus. and swaps the active focus application window.
                A hot key of CTRL-F2 from App "B", Send Key strokes to App "B" to place App "B" windows' content into windows clip board then switch to App "A" and send a keystroke, CTRL-F3, to trigger processing the clip board through App "A"'s normal event handlers.  App "A" already knows that CTRL-F3 means to run custom VBA code to process the clipboard.
      Any help would be appreciated here, thanks.  
    • By buymeapc
      Hello,
      I was looking for a way to use the CLR functions to check a SQL 2016 database state, but I've been unable to find an example that I can get to work. Any help would be appreciated. Here's what I have, which always errors when I try to set the connection string and I'm not sure why. Thanks!
      #include ".\Includes\CLR.au3" #include ".\Includes\CLR Constants.au3" JustATest() Func JustATest() Local $oAssembly = _CLR_LoadLibrary("System.Data") ConsoleWrite("$oAssembly: " & IsObj($oAssembly) & @CRLF) Local $oSQLConn = _CLR_CreateObject($oAssembly, "System.Data.SqlClient.SqlConnection") ConsoleWrite("$oSQLConn: " & IsObj($oSQLConn) & @CRLF) $oSQLConn.ConnectionString = "Server=serverip;Database=dbname;UID=user;PWD=aaaa;" $oSQLConn.Open EndFunc Edit: I am using ptrex's CLR UDF from here:
    • By ScrapeYourself
      I didn't like the search time of Simple Native Image Search, and being on windows 10 64bit, I couldn't get ImageSearchDll.dll to work properly.
      So I started researching image search routines and found this excellent post and set of replies find-a-bitmap-within-another-bitmap.

      I really liked the pattern that the Simple Native Image Search used, the clipboard usage and the method of searching. Although I think it could be improved by using some short circuit techniques to return sooner, like consecutive matched > 65% return | matched total > 85% return) , and I wanted the function to manage the click on the found image as well.
      So I just did a bit more research and a few trips to MSDN and stackoverflow, these two snippets allow me to replicate KyleJustKnows code, and click.  Another feature is that it also saves the image it captures to disk, so that if the image is not found you can check what was captured, and alternatively cut out a new search image to use.
      private void PrintScreen() { keybd_event(VK_SNAPSHOT, 0, KEYEVENTF_EXTENDEDKEY, 0); keybd_event(VK_SNAPSHOT, 0, KEYEVENTF_KEYUP, 0); } public Bitmap CaptureScreenPrtSc() { PrintScreen(); if (Clipboard.ContainsImage()) { using (Image img = Clipboard.GetImage()) { img.Save("ClipBoard.PNG", ImageFormat.Png); return new Bitmap(img); } } return default; } [DllImport("user32.dll")] [return: MarshalAs(UnmanagedType.Bool)] private static extern bool GetCursorPos(out MousePoint lpMousePoint); [DllImport("user32.dll")] private static extern void mouse_event(int dwFlags, int dx, int dy, int dwData, int dwExtraInfo); private MousePoint GetCursorPosition() { var gotPoint = GetCursorPos(out MousePoint currentMousePoint); if (!gotPoint) { currentMousePoint = new MousePoint(0, 0); } return currentMousePoint; } private void MouseEvent(MouseEvents value) { MousePoint position = GetCursorPosition(); mouse_event ((int)value, position.X, position.Y, 0, 0) ; }
      So after managing to compile the dll with COM support, with much reading of this forum and many posts from paulpmeier, ptrex, LarsJ, and others about loading .net, I managed to get this all working.

      Here is the BotIt Core:
      ; BotIt Core Global $sPath = "BotIt.dll" Global $RegAsmPath = "C:\Windows\Microsoft.NET\Framework\v4.0.30319\RegAsm.exe" Func BotIt_StartUp() RegisterBotIt() OnAutoItExitRegister("UnregisterBotIt") EndFunc ;==>BotIt_StartUp Func RegisterBotIt() RunWait($RegAsmPath & " /register /codebase /tlb " & $sPath, @ScriptDir, @SW_HIDE) EndFunc ;==>RegisterBotIt Func UnregisterBotIt() FileDelete("Step.txt") RunWait($RegAsmPath & " /unregister " & $sPath, @ScriptDir, @SW_HIDE) EndFunc ;==>UnregisterBotIt Func ActivateAndSearch($sTitle, $sImgPath, $bClick = True) WinActivate($sTitle) Sleep(1000) $oBotIt = ObjCreate("BotIt.DetectImageAndClick") ConsoleWrite($sImgPath & @CRLF & $bClick & @CRLF) $bRet = $oBotIt.FindAndClick($sImgPath, $bClick) Return $bRet EndFunc ;==>ActivateAndSearch  
      Usage:
      Do Sleep(500) Until ActivateAndSearch("Window Title", "PathToFile")

      I hope you enjoy!
      Regards,
      ScrapeYourself
       
       
      BotIt.cs
×
×
  • Create New...