phuocvovan

Problem with Pixelsearch

4 posts in this topic

#1 ·  Posted (edited)

Hi guys. I got some problems with Pixelsearch. 


 

$coord = PixelSearch(0, 0, @DesktopWidth,@DesktopHeight , 0xFFF200)
If Not @error Then
$handle = WinGetHandle("D-com 3G","")
MouseClick("primary", $coord[0], $coord[1], 1, 0)
EndIf

It was working well on my pc. But when i bring it to another computer. It wasn't working correctly. I think the problem related to the resolution of the screen.

 

I used windows with 100% size of text,apps, and other item. It worked correctly. But when i change to 125 %. It didn't work

 

 

Capture.PNG

 

Thanks in advance

Edited by phuocvovan

Share this post


Link to post
Share on other sites



What happens if you add some shade variation? also, how did you get the color? in case you dont know, the autoit info tool retrieves the color in the "mouse" tab.

But i suppose that if it worked in another pc...


Spoiler

Paster - Main function is to paste text, but has more functions.

OpenW - Open With... alternative, Open any file with any application, set it's icon, set application as default.

Renamer - Rename files and folders, remove portions of text from the filename etc.

BeatsPlayer - Music player.

Params Tool - Right click an exe to see it's parameters or execute them.

Regedit Control - Registry browsing history, quickly jump into any saved key.

Time4Shutdown - Write the time for shutdown in minutes.

Power Profiles Tool - Set a profile as active, delete, duplicate, export and import.

Firefox Profile Backup - Backup/restore previously saved profile.

Finished Task Shutdown - Shuts down pc when specified window/Wndl/process closes.

NetworkSpeedShutdown - Shuts down pc if download speed goes under "X" Kb/s.

 

Share this post


Link to post
Share on other sites
26 minutes ago, careca said:

What happens if you add some shade variation? also, how did you get the color? in case you dont know, the autoit info tool retrieves the color in the "mouse" tab.

But i suppose that if it worked in another pc...

I used Autoit info. That application is too funny. when i am 100% screen. autoit info can get hex color . But when it is 125 %. It's can't get

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now