zone97

2 Issues Lately?

17 posts in this topic

#1 ·  Posted (edited)

Issue #1, I have a program I wrote for work, lately one user who uses it, it has quit working.. Specifically. The run function. My script creates a batch file as temp.cmd, then runs it. but for this one user, the cmd window opens blank? The temp.cmd file exists and has content and you can double click it and it works fine. just my script won't run it? No one else who uses this has this issue, and she didn't have it before the past few days.. My question? where might I look for a cause of this? Like security changes? antivirus issues? I have run out of ideas...

Issue #2, lately as well for myself, when I compile and executable in autoit, it will freeze at the same point and I have to go to tools, stop executing to have it finish.

-Updated the Source Version to:1.2.0.200
+>10:40:13 AutoIt3Wrapper Finished.

>Process failed to respond; forcing abrupt termination...
>Exit code: 1    Time: 13.37

Notice the space between AutoItWrapper Finished. and Process failed? That's where it would be hung till i stopped it.. Now, it creates the updated EXE, but I don't understand why its hanging.. Never has before.

I know neither of these are "script" or "code" issues, but just looking for suggestions on why this happens if someone else has experienced this before.

Edited by zone97

 

Spoiler

WinSizer 2.1 (01/04/2017) - Download - [ Windows Layout Manager ]
Folder+Program (12/23/2016) - Download - [ USB Shortcut Creator ]

 

Share this post


Link to post
Share on other sites



Wrapper version 16.612.1119.0 But to my knowledge I haven't updated autoit it a month.. So nothing from the compilers side should be different than say last week when all was working flawlessly.


 

Spoiler

WinSizer 2.1 (01/04/2017) - Download - [ Windows Layout Manager ]
Folder+Program (12/23/2016) - Download - [ USB Shortcut Creator ]

 

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)


 

Spoiler

WinSizer 2.1 (01/04/2017) - Download - [ Windows Layout Manager ]
Folder+Program (12/23/2016) - Download - [ USB Shortcut Creator ]

 

Share this post


Link to post
Share on other sites

lol.. googled it..


 

Spoiler

WinSizer 2.1 (01/04/2017) - Download - [ Windows Layout Manager ]
Folder+Program (12/23/2016) - Download - [ USB Shortcut Creator ]

 

Share this post


Link to post
Share on other sites

#8 ·  Posted (edited)

Oh and just so we are on the same page.. Its not the script.. EVERY script i compile does this..

msgbox(0,"test","hello world")
exit

Just created this.. Selected go, and it hangs after clicking ok to msgbox.

Edited by zone97

 

Spoiler

WinSizer 2.1 (01/04/2017) - Download - [ Windows Layout Manager ]
Folder+Program (12/23/2016) - Download - [ USB Shortcut Creator ]

 

Share this post


Link to post
Share on other sites

#9 ·  Posted (edited)

5 minutes ago, zone97 said:

EVERY script i compile does this..

 

5 minutes ago, zone97 said:

Just created this.. Selected go, and it hangs after clicking ok to msgbox

These statements are not the same. The first indicates the Compile action and the second indicates the Run/Go action.
So are you saying they both show this issue with AutoIt3Wrapper?

Jos

Edited by Jos

Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#10 ·  Posted

Well originally I thought it was just the compiler, but now it does it when I run a script. When the script ends, even if properly. I have to tell autoit to "stop" before I can start the process again.. I think its the computer or something else running is holding these processes hostage..


 

Spoiler

WinSizer 2.1 (01/04/2017) - Download - [ Windows Layout Manager ]
Folder+Program (12/23/2016) - Download - [ USB Shortcut Creator ]

 

Share this post


Link to post
Share on other sites

#12 ·  Posted

Corporate McAfee... So no.. Lol, it was updated the other day (forcefully I might add) but it has never been an issue before, unless whatever is new is being overly protective.. I may have to get the IT department to set an exclusion for my machine and specifically autoit..


 

Spoiler

WinSizer 2.1 (01/04/2017) - Download - [ Windows Layout Manager ]
Folder+Program (12/23/2016) - Download - [ USB Shortcut Creator ]

 

Share this post


Link to post
Share on other sites

#14 ·  Posted (edited)

Issue #1 Doesn't do it on my computer or others, just this one user started having this issue.. But all are governed by corporate AV.  I dunno, I hate corp. BS.. But I'm limited in what I can change. lol

Edited by zone97

 

Spoiler

WinSizer 2.1 (01/04/2017) - Download - [ Windows Layout Manager ]
Folder+Program (12/23/2016) - Download - [ USB Shortcut Creator ]

 

Share this post


Link to post
Share on other sites

#15 ·  Posted

Update!

Issue#1 is now effecting my system, so it's company wide? has anyone had this issue? Where autoit won't run a batch/cmd file? IT seems hit or miss, as in i can make it do it once, but the next 5, 6 times it just hangs? I don't need a solution, maybe just a cause. I will more than likely have to send a write up explaining what the issue is and have corporate undo it for the machines effected. But I have to first find the culprit.  I'm still leaning towards some sort of corporate protection application.


 

Spoiler

WinSizer 2.1 (01/04/2017) - Download - [ Windows Layout Manager ]
Folder+Program (12/23/2016) - Download - [ USB Shortcut Creator ]

 

Share this post


Link to post
Share on other sites

#16 ·  Posted

Maybe a sleep helps between the creation of the cmd file and running it to allow any AV to scan it?
Can you post the code that has issues?

Jos


Visit the SciTE4AutoIt3 Download page for the latest versions  - Beta files                                How to post scriptsource        Forum Rules
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

#17 ·  Posted (edited)

Maybe some Group Policies changed?

To fight ransomware the IT guys set up application directory whitelisting or something similar lately?

Edited by water

My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2017-04-18 - Version 1.4.8.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2017-02-27 - Version 1.3.1.0) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2015-04-01 - Version 0.4.0.0) - Download - General Help & Support - Example Scripts
Excel - Example Scripts - Wiki
Word - Wiki
PowerPoint (2015-06-06 - Version 0.0.5.0) - Download - General Help & Support

Tutorials:
ADO - Wiki

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now