Sign in to follow this  
Followers 0
taurus

media remote and unknown keys

12 posts in this topic

hi forum people , 

i have had this media remote lying around and just using for volume up and down because thats about all that works with it, i thought i could maybe write up a script to make it do MORE ? :o

 

UFWV5GF.jpg

 

all the circled up buttons dont work, ive tryed  reading them by making simple script.

[autoit]

#include <Misc.au3>

While 1

    Sleep(100)
    For $x = 1 to 254
        If _IsPressed(Hex($x)) Then
            MsgBox(64, "WARNING", "PRESSED :"&$x)
        EndIf
    Next
WEnd[/autoit]

but nothing works except arrows,ok,play/pause,fast forward,skip to next, volume and ofcourse the numerics and CLEAR[ESC] and ENTER ... 

 

anybody could help somehow? is there anything doable with this? there are no drivers for this thing ...

Share this post


Link to post
Share on other sites



#3 ·  Posted (edited)

5 minutes ago, JohnOne said:

weird question maybe, but did you try 255 +?

tried. with no luck at all.. those buttons will not report :(

i tried up to a 1000

Edited by taurus

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

Those buttons could possibly be a combination of two or more keys.

Download or write a keylogger, (downloading better as they cannot be discussed on here if you have problems).

EDIT: infact au3recorder has a built in keylogger, see if that detects the presses.

Edited by JohnOne

AutoIt Absolute Beginners    Require a serial    Pause Script    Video Tutorials by Morthawt   ipify 

Monkey's are, like, natures humans.

Share this post


Link to post
Share on other sites

#6 ·  Posted (edited)

8 minutes ago, spudw2k said:
14 minutes ago, JohnOne said:

Those buttons could possibly be a combination of two or more keys.

Download or write a keylogger, (downloading better as they cannot be discussed on here if you have problems).

EDIT: infact au3recorder has a built in keylogger, see if that detects the presses.

 

8 minutes ago, spudw2k said:

what is the IR receiver you are using with the remote?

what is the IR receiver you are using with the remote?

 

i tried au3recorder but it did not catch any of those keys either. maybe another keylogger would be worth the time ? 

 

https://www.impactcomputers.com/imp-616971.html

this is the IR receiver i have gotten WITH that media remote since the day ive had the remote.

Edited by taurus

Share this post


Link to post
Share on other sites

Hi all,

No more discussion of keyloggers please.

M23


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

Found this article.  Not sure how applicable it may be, but seeing a lot of combination codes for various buttons.  I think @JohnOne may be on to something.

Share this post


Link to post
Share on other sites

..... worth check whether those buttons actually send a signal (probably those individual keys could be not working).
To test if a remote control is working, (even for individual keys) you can use the phone's camera in this way: set the camera in shooting mode and then pointing the remote control at the camera lens and press the various buttons on the remote, if the key you are pressing actually transmits a signal, you can see the lED that flashes on the camera display. If you do not see the LED blink then the remote control button does not work.

 


small minds discuss people average minds discuss events great minds discuss ideas.... and use AutoIt....

Share this post


Link to post
Share on other sites

#10 ·  Posted

12 hours ago, spudw2k said:

Found this article.  Not sure how applicable it may be, but seeing a lot of combination codes for various buttons.  I think @JohnOne may be on to something.

the article ive seen . and it still just shows keys that DO work in windows , they are mostly replicas of xbox controller keys. and @JohnOne idea did not turn out too good either... tryed advanced programs , no luck whatsoever 

7 hours ago, Chimp said:

..... worth check whether those buttons actually send a signal (probably those individual keys could be not working).
To test if a remote control is working, (even for individual keys) you can use the phone's camera in this way: set the camera in shooting mode and then pointing the remote control at the camera lens and press the various buttons on the remote, if the key you are pressing actually transmits a signal, you can see the lED that flashes on the camera display. If you do not see the LED blink then the remote control button does not work.

 

they do check out, every key is working with flashing light. but no  software can read the buttons , as a matter of fact , i dont really remember any of those keys working even on windows vista/7 days when i got the remote with a prebuilt packard bell computer before...so im not sure whats the story with them, but would be handy if i could get them to do my own things

Share this post


Link to post
Share on other sites

#11 ·  Posted

I didn't even know Packard Bell was still in business; last time I saw/worked on one was pre Windows XP days (Windows 98 SE/ME).  I guess they just don't sell in the U.S. anymore (beaten by gateway, compaq and dell I presume).

Share this post


Link to post
Share on other sites

#12 ·  Posted

On 2/21/2017 at 3:16 PM, spudw2k said:

I didn't even know Packard Bell was still in business; last time I saw/worked on one was pre Windows XP days (Windows 98 SE/ME).  I guess they just don't sell in the U.S. anymore (beaten by gateway, compaq and dell I presume).

theyve been out of business since 2010 or something. because last time i got a prebuilt pc was indeed packard bell and it sucked balls . apart from this media remote hahah

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0