Jump to content

When dropping file on compiled exe, Windows shows "Open in Aut2Exe" - show actual program name?


Recommended Posts

I have some compiled scripts that perform operations on files dropped on them. When I drag a file over the executable, Windows prompts with a box that says "Open in Aut2Exe." Is there any way to make Windows show the actual name of the executable? I've tried using the name of the executable in every available field in the Resource Update tab of the editor, with no success. I can't find the string "Aut2Exe" in the compiled scripts, so I'm completely baffled.

Any help will be gratefully received.

Link to post
Share on other sites

Thiis is is an example of how I process the command line:

$cmln = $CmdLine[0]
If $cmln >= 1 Then
    $editdoc = $CmdLine[1]
Else
    MsgBox(0, $msgtitle, "Filename required.")
    Exit
EndIf

And here's an executable that shows the issue (though I think all AutoIt-compiled programs show the same behavior):

https://www.dropbox.com/s/9gy5qpwpd86xibh/WPWDocX.exe?dl=1

Edited by emendelson
Make link work.
Link to post
Share on other sites
6 hours ago, Danp2 said:

Download link worked for me, but I don't get the message described in the OP. For me it says "Open with WPWDocX.exe". What OS are you using for testing? I'm running W11 v22H2.

 

Thank you for this. When I restarted my machine, I got exactly the same result. It seems that the problem was that Windows cached the internal name of the executable when I ran it after compiling it with the Description and Comment fields blank in the Resource Update tab. Even after I compiled the exe with the correct name in the Description and Comment fields, Windows still showed Aut2Exe.exe in the popup - but eventually showed the correct name after I restarted.

Lesson learned. Thank you. (And though it doesn't matter, I've made the download link active, as I should have done earlier, and of course the code I posted was in answer to the question, how do I process the command-line input; it wasn't meant to compile.)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...