Sign in to follow this  
Followers 0
shay

32bit vs 64bit code compatibility

8 posts in this topic

#1 ·  Posted (edited)

Hi

i write a script that on 32bit PC

when i test in all run OK

but when i run the code on 64bit PC

it didn't work so good,

it get stuck on the "WinWaitActive" so i try to baypass this with a loop with no lock

;close installation GUI 
Do
 WinActivate ("LU-1000") 
 $handle = WinGetHandle("LU-1000","") 
 sleep(1500) $wait = WinWait("LU-1000", "exit") 
Until $wait = $handle

any idea?

Edited by shay

"If the facts don't fit the theory, change the facts." Albert Einstein

Share this post


Link to post
Share on other sites

Have you tried using the AutoIt info tool (comes with autoit install) to see if the title of the window is still the same?

the title is the same.


"If the facts don't fit the theory, change the facts." Albert Einstein

Share this post


Link to post
Share on other sites

#4 ·  Posted (edited)

whatever Edited by MvGulik

"Straight_and_Crooked_Thinking" : A "classic guide to ferreting out untruths, half-truths, and other distortions of facts in political and social discussions."
"The Secrets of Quantum Physics" : New and excellent 2 part documentary on Quantum Physics by Jim Al-Khalili. (Dec 2014)

"Believing what you know ain't so" ...

Knock Knock ...
 

Share this post


Link to post
Share on other sites

Forum post typo? (probably)

sleep(1500) $wait = WinWait("LU-1000", "exit")

Assuming

sleep(1500)
$wait = WinWait("LU-1000", "exit")

If the WinWait() [text] parameter fails for some reason it would also never exit.

yes its a typo,

in my code it`s doesn't look like that.

i know the loop want exit, also i try WinWaitActive with no luke.

it doesn't work on the 64Bit PC.:mellow:


"If the facts don't fit the theory, change the facts." Albert Einstein

Share this post


Link to post
Share on other sites

Hmm, just to give it a shot - maybe the "exit" text isn't being read? Try to see if it shows up with the AutoIT window info tool ('Visible Text' tab).

Also, would you mind telling people what the program is? Searches for LU-1000 didn't bring up anything useful for me.

Share this post


Link to post
Share on other sites

[quote name='Ascend4nt' date='14 June 2010 - 11:08 AM....

...Also, would you mind telling people what the program is? Searches for LU-1000 didn't bring up anything useful for me.


"If the facts don't fit the theory, change the facts." Albert Einstein

Share this post


Link to post
Share on other sites

Hmm, just to give it a shot - maybe the "exit" text isn't being read?

Seems like the best guess so far to me. Compile your code to x64 and test that. If it works, you need a 32/64 bit wrapper for your code. Take a look at ICU how I've done it, the wrapper is part of the source download.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0