Sign in to follow this  
Followers 0
bhavesh803

Auto it support on win7

7 posts in this topic

Hi,

I need to know about stability of Autoit on Win7 as compared to WinXP.

I an new to autoit and I written an code to extract text from the listview .

Code is :

Local $hWnd = ControlGetHandle("IRM Client Preferences","","SysListView321")

$iCount = ControlListView("IRM Client Preferences","User Profiles","SysListView321","GetItemCount")

For $i = 0 To $iCount

Local $val = _GUICtrlListView_GetItemText($hWnd,$i)

;MsgBox(0, "", $val)

If $val = "IRM-Auto-Cmb51.dctmlabs.com" Then

FileWrite("result.log.html", "TestCase : 0001 : Failed : Profile Still Exists")

FileWrite("result.log.html",""& @CRLF)

$var1 = "fail"

ExitLoop

EndIf

Next

In this code im getting text from the syslistview321.

This code works fine perfectly on winXP.

But as soon as I try to excute this code on Win7, it fails. Even though application under test is same, env is same only difference is the OS.

So it is not able to get text from the desired syslistview321 in win 7 [32 bit or 64bit].

So is it possible that Autoit is not stable or not working fine on windows 7?

Or do I have to write some other code to achieve this in win7?

Any help and comments are valuable.

Thanks

Bhavesh

Share this post


Link to post
Share on other sites



#2 ·  Posted (edited)

Are you compiling your script in 32 bits? I have similar problems when I don't force-compile in 32.

also maybe you could try using

Local $val = ControlListView("IRM Client Preferences","","SysListView321", "GetText", $i, 0)
Edited by jmon

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

As you're writing out to a log file, have you tried adding #RequireAdmin at the top of your script?

Edited by JLogan3o13

√-1 2^3 ∑ π, and it was delicious!

Share this post


Link to post
Share on other sites

AutoIt runs stable on Windows 7!

When I moved to Windows 7 there were "problems" with the move from 32 to 64 bit and the UAC.

What your script needs is error checking. Check the return value and @error after every function call so you know that the function finished successfully.

BTW: Which version of AutoIt do you run?


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2017-04-18 - Version 1.4.8.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2017-02-27 - Version 1.3.1.0) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2015-04-01 - Version 0.4.0.0) - Download - General Help & Support - Example Scripts
Excel - Example Scripts - Wiki
Word - Wiki
PowerPoint (2015-06-06 - Version 0.0.5.0) - Download - General Help & Support

Tutorials:
ADO - Wiki

 

Share this post


Link to post
Share on other sites

@water : im using autoit version 3.3.8.1

@jmon : After i modified the line as you suggested it is still not working.

So im getting the item count on that syslistview, which is 1 items.

So my iCount value is 1.

Now im looping through, and getting text from first item in the list view.

If i use this mehtod in Winxp :

Local $val = _GUICtrlListView_GetItemText($hWnd,$i)

It collects the text without error.

But when same code is executed on Win7, it does not collects anything.

Here is the screnshot :

IRM Server Username

IRM-Auto-Cmb51.dctmlabs.com irm

Thanks

Bhavesh

Share this post


Link to post
Share on other sites

ListViews are zero based, so you'd need to use For $i = 0 to $iCount - 1, because if there's only one item in the LV then when $iCount is 1 it won't get anything from the LV.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites

@jmon, thanks very much.

I compiled my code with x64 compiler, and it is working fine now.

thanks for your suggestion.

Thanks

Bhavesh

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0