Jump to content
Sign in to follow this  
sooskri

_IELoadWait issue

Recommended Posts

sooskri

Hi,

I am having problems with the _IELoadWait. It is giving an error at line 585 "WEnd" when waiting for drop-down or the frame on the page to load. It was suggested on another post that it is "synchronization issue" and wll be fixed.

Is there a fixed version of AutoIT? If not, can somebody give me a little bit more help on how to handle the issue? If instantiate a COM error handler is the only way, can you please send me some lines of code, how would that look like?

Thanks

Share this post


Link to post
Share on other sites
water

Welcome to AutoIt and the forum,

Please search the forum for this problem. It has been asked a few times before and I'm sure you'll find a solution :)


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2018-12-03 - Version 1.4.11.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (2018-10-31 - Version 1.3.4.1) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2017-07-21 - Version 0.4.0.1) - Download - General Help & Support - Example Scripts
PowerPoint (2017-06-06 - Version 0.0.5.0) - Download - General Help & Support
Excel - Example Scripts - Wiki
Word - Wiki
 
Tutorials:

ADO - Wiki

 

Share this post


Link to post
Share on other sites
sooskri

Thank for the welcome. I did use the forum many times before for other issues. Thanks for all the great posts.

I did find a few similar questions before I opened my post, but unfortunately did not find the solution. I would really appreciate if you could direct me to the right place.

Thanks

Share this post


Link to post
Share on other sites
water

Can you please post the code you use?


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2018-12-03 - Version 1.4.11.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (2018-10-31 - Version 1.3.4.1) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2017-07-21 - Version 0.4.0.1) - Download - General Help & Support - Example Scripts
PowerPoint (2017-06-06 - Version 0.0.5.0) - Download - General Help & Support
Excel - Example Scripts - Wiki
Word - Wiki
 
Tutorials:

ADO - Wiki

 

Share this post


Link to post
Share on other sites
sooskri

I need to select a value from a drop-down list and then after the page is loaded do something else. Here is the call for the drop down selection.

func fSelectDropDown($formID, $selection)

$form = _IEGetObjById(_IEFrameGetObjByName(_IEAttach("xxxx"), "yyyy"), $formID)

_IEAction($form, "focus")

Sleep(500)

If fGetFormValue($formID) <> $selection Then

_IEFormElementOptionselect($form, $selection, 1, "byText")

_IELoadWait(_IEGetObjById(_IEFrameGetObjByName(_IEAttach("xxxx"), "yyyy"), $formID), 1500)

Sleep(500)

EndIf

EndFunc

I get error intermittently for the _IELoadWait call.

Share this post


Link to post
Share on other sites
DaleHohm

First, I don't think that is your code, because IE.au3 functions pass their values ByRef and will throw errors if you try to nest them that way.

Regarding the WEND error, see the discussion and my recommendation here:

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites
sooskri

Thank Dale for the link.

You are right. Those function use ByRef, but the function above actually works. I did not pay attention to ByRef and I use nesting in many places in my code and there was no error whatsoever because of that.

I found beta version v3.3.9.4 and I have alpha version v3.3.8.1. I hope that is what you meant in the other post.

Thanks for all your aswer in the forum Dale, I found a lot of answers in them.

Share this post


Link to post
Share on other sites
DaleHohm

No, that is not the Alpha I was referring to. It may be that you don't have access to the Alpha I am referring to. I need to figure out the best way to distribute it since it is not clear when the next refresh release will be made. In the mean time, I will PM you a copy of IE.au3.

Dale

Update: oops, you have not been around long enough to use the PM system. Watch the forum for more info on this.

Edited by DaleHohm

Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites
sooskri

Thanks Dale.

Share this post


Link to post
Share on other sites
DaleHohm

See here:

Dale


Free Internet Tools: DebugBar, AutoIt IE Builder, HTTP UDF, MODIV2, IE Developer Toolbar, IEDocMon, Fiddler, HTML Validator, WGet, curl

MSDN docs: InternetExplorer Object, Document Object, Overviews and Tutorials, DHTML Objects, DHTML Events, WinHttpRequest, XmlHttpRequest, Cross-Frame Scripting, Office object model

Automate input type=file (Related)

Alternative to _IECreateEmbedded? better: _IECreatePseudoEmbedded  Better Better?

IE.au3 issues with Vista - Workarounds

SciTe Debug mode - it's magic: #AutoIt3Wrapper_run_debug_mode=Y Doesn't work needs to be ripped out of the troubleshooting lexicon. It means that what you tried did not produce the results you expected. It begs the questions 1) what did you try?, 2) what did you expect? and 3) what happened instead?

Reproducer: a small (the smallest?) piece of stand-alone code that demonstrates your trouble

Share this post


Link to post
Share on other sites
JohnOne

IE.au3 functions pass their values ByRef and will throw errors if you try to nest them that way.

Hi DaleHohm.

I think that fashion of nesting might actually be valid, here's a quote from the help file 3.3.8.1

"unnamed temporary variables, such as function return values, may be passed as ByRef parameters as well"

Please excuse me if I'm wrong.


AutoIt Absolute Beginners    Require a serial    Pause Script    Video Tutorials by Morthawt   ipify 

Monkey's are, like, natures humans.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×