Sign in to follow this  
Followers 0
lawrenceqa

Send doesn’t work with UAC off in Windows 8 PRO

10 posts in this topic

Send command doesn’t work for me in my Windows 8 PRO when I turn UAC off.

If I turn UAC on, then run the script, and then press yes on the UAC prompt, the send command works fine.

Any ideas? I’m on Windows 8 Pro. I tried the same on Windows 8 Home and it works fine there. The same also works fine on Windows 7 Pro with UAC turned off.

My script just opens the windows run command:

Send(“#r”)

Share this post


Link to post
Share on other sites



not that it should matter but are you running it with with an administrator account?

i just tried that on my windows 8 enterprise both with and without UAC turned on.

Share this post


Link to post
Share on other sites

I tried with Windows 8 Pro without UAC (really disabled, with registry keys), and Send() command works.

1 person likes this

Share this post


Link to post
Share on other sites

Does AutoIt also works on Windows 8 ? oO

Share this post


Link to post
Share on other sites

What I have read on the forum it works fine with Windows 8 though it is not officially supported.


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2017-04-18 - Version 1.4.8.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2017-02-27 - Version 1.3.1.0) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2015-04-01 - Version 0.4.0.0) - Download - General Help & Support - Example Scripts
Excel - Example Scripts - Wiki
Word - Wiki
PowerPoint (2015-06-06 - Version 0.0.5.0) - Download - General Help & Support

Tutorials:
ADO - Wiki

 

Share this post


Link to post
Share on other sites

I tried with Windows 8 Pro without UAC (really disabled, with registry keys), and Send() command works.

This worked!!!!! Thanks so much, the send command (at least the one I was using, which was Send("#r")) now works when I disable the UAC through the registry.

I dont' get why using the send command doesn't work when I disable UAC through the slider. I am an admin on my machine, so not sure what’s going on.

I used the registry edit that was described here:

http://www.computerperformance.co.uk/win8/windows8-uac-disable.htm#Disable_the_Windows_8_UAC_with_Registry_a_Registry_Tweak

Share this post


Link to post
Share on other sites

Add #RequireAdmin to start of script

This will then cause the script to request elevated UAC privileges.

Send then will work fine..

1 person likes this

Share this post


Link to post
Share on other sites

#9 ·  Posted (edited)

Add #RequireAdmin to start of script

This will then cause the script to request elevated UAC privileges.

Send then will work fine..

That tends to sort out UAC/Permission issues with stuff like this.

I am running Windows 8. The biggest glitch I've seen, is actually with Scite. My AutoIt scripts were so sporadic, until I changed Scite to permanently run with Administrative privileges.

Edited by BinaryBrother

Share this post


Link to post
Share on other sites

Add #RequireAdmin to start of script

This will then cause the script to request elevated UAC privileges.

Send then will work fine..

I don't want a UAC pop-up. Send works fine when I turn UAC on and then press the ok or yes on that UAC popup (without even using #RequireAdmin).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0