Jump to content
vkrisz81

FF au3 does not work

Recommended Posts

vkrisz81

hello!

can anybody tell me is there any working udf for firefox? because the .15 version cant communicate with firefox. the first statement does not work . i know it worked because i tested it few months ago, but now its dead. after refresh firefox 2 weeks ago.

is there any tip?

Share this post


Link to post
Share on other sites
water

Which version of FF are you talking about?


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2018-12-03 - Version 1.4.11.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (2018-10-31 - Version 1.3.4.1) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2017-07-21 - Version 0.4.0.1) - Download - General Help & Support - Example Scripts
PowerPoint (2017-06-06 - Version 0.0.5.0) - Download - General Help & Support
Excel - Example Scripts - Wiki
Word - Wiki
 
Tutorials:

ADO - Wiki

 

Share this post


Link to post
Share on other sites
vkrisz81

we know ie too old for modern webpages. if ff udf does not work.. what other udf is presented to communicate with any browser?

Share this post


Link to post
Share on other sites
vkrisz81

"0.6.0.1b-15"

Share this post


Link to post
Share on other sites
vkrisz81

the ffstart returns regedit problem, i corrected it to the correct way, but still does not change the url

Share this post


Link to post
Share on other sites
BrewManNH

If you're using the latest version of firefox the FF.au3 UDF won't work with it because MozRepl won't work with this version of FF.


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites
vkrisz81

and is there any solving?

Share this post


Link to post
Share on other sites
vkrisz81

or mozrepl never will work with ff more?

Share this post


Link to post
Share on other sites
water

Maybe you get some answers on the MozRepl homepage: https://github.com/bard/mozrepl/wiki


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2018-12-03 - Version 1.4.11.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (2018-10-31 - Version 1.3.4.1) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2017-07-21 - Version 0.4.0.1) - Download - General Help & Support - Example Scripts
PowerPoint (2017-06-06 - Version 0.0.5.0) - Download - General Help & Support
Excel - Example Scripts - Wiki
Word - Wiki
 
Tutorials:

ADO - Wiki

 

Share this post


Link to post
Share on other sites
vkrisz81

now i downgraded the mozilla

it can communicate

it can load a site, but the return does not work, i mean ffopenurl says cant find, while really it loaded.. HOW???

it can navigate but cant see its done??

Share this post


Link to post
Share on other sites
vkrisz81

is there any other way to automate web pages? to acces a browser and get dta from sites? because ie old, ff dont work!

Share this post


Link to post
Share on other sites
spike2489

Hi, i'm new to AutoIt. And I have the same problem too. I'm using FF 56 with MozRepl. However, I can sent command to MozRepl and it seems work fine. But I find that I can't get any return from it. For example, I can open a new tab/change url. But I can't get the page HTML code or get the current URL etc. I had try several ways to get the HTML, all return empty. Here is my code.

#RequireAdmin
#include <FF.au3>
#include <FFEx.au3>

If _FFStart("https://www.google.com", Default, 0) Then

    Sleep(15000)

    $sHTML = _FFReadHTML()
    ConsoleWrite($sHTML)
    $sHTML = _FFReadHTML("html",7)
    ConsoleWrite($sHTML)
    
    ;;https://stackoverflow.com/questions/45149596/autoit-ff-au3-cant-check-if-element-is-focused
    _FFCmd("FFau3.GetInnerHTML=function GetInnerHTML(a) {return '123456'};", 15000)
    Sleep(20000)
    $sHTML = _FFCmd("FFau3.GetInnerHTML(1)") ;; Return empty too.
    ConsoleWrite($sHTML)
    $sHTML = _FFCmd("gBrowser.contentDocument", 25000) ; _FFReadHTML("html",8)
    Sleep(400)
    ConsoleWrite($sHTML)
    $sHTML = _FFCmd("content.document", 25000) ; _FFReadHTML("html",8)
    Sleep(400)
    ConsoleWrite($sHTML)
    $sHTML = _FFCmd("window.opener.content.document", 25000) ; _FFReadHTML("html",8)
    Sleep(400)
    ConsoleWrite($sHTML)
    $sHTML = _FFCmd("window.content.document.documentElement", 25000) ; _FFReadHTML("html",8)
    Sleep(400)
    ConsoleWrite($sHTML)
EndIf

One more thing, I can not use the _FFIsConnected(). It seem "_FFCmd("FFau3 != null?1:0") = 1" return empty, so it throw to error.

 

P.S.: I turn off my firewall too.

Share this post


Link to post
Share on other sites
spike2489

And thanks you for junkew, I find the new version of FF.au3 and FFEx.au3:lmao:.

 

 

But it's not work too.:(

Share this post


Link to post
Share on other sites
Danp2
On 11/17/2017 at 9:57 PM, spike2489 said:

Hi, i'm new to AutoIt. And I have the same problem too. I'm using FF 56 with MozRepl. However, I can sent command to MozRepl and it seems work fine. But I find that I can't get any return from it. For example, I can open a new tab/change url. But I can't get the page HTML code or get the current URL etc. I had try several ways to get the HTML, all return empty. Here is my code.

As @BrewManNH stated earlier in this thread, MozRepl no longer works with the latest versions of FF. I believe it stopped working correctly after FF 54.

Edited by Danp2
typo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×