ayatest

strange behavior

17 posts in this topic

I'm using only variables to store window/control sizes and positions on the screen, hotkeys and mouseclicks (combined with these variables).

I noticed, that sometimes after modification - script isn't working correctly (each time) - mouse is shifted from proper positions. But after I push the script through debugger - it works fine there, and after that - it works correctly when running normally.

What an be reason for that?


functional testing. multimedia recording. flowstone. mouseclick, hotkeys and modularity in general.

Share this post


Link to post
Share on other sites



We would only be shooting in the dark trying to give suggestions. Can you post your script, please?


Snips & Scripts


My Snips: graphCPUTemp ~ getENVvars
My Scripts: Short-Order Encrypter - message and file encryption V1.6.1 ~ AuPad - Notepad written entirely in AutoIt V1.9.4

Feel free to use any of my code for your own use.                                                                                                                                                           Forum FAQ

 

Share this post


Link to post
Share on other sites

It happens with all scripts, and probably not always. Only one script is running at the time, win81. Scripts are edited in non-autoit editor. So the question is regarding autoit and possibility for such problems to happen.


functional testing. multimedia recording. flowstone. mouseclick, hotkeys and modularity in general.

Share this post


Link to post
Share on other sites

Please, post your script so that we can see what you are seeing. If this problem was happening to everyone, then I would understand not posting it, but that is not the case.

What are you also trying to automate?


Snips & Scripts


My Snips: graphCPUTemp ~ getENVvars
My Scripts: Short-Order Encrypter - message and file encryption V1.6.1 ~ AuPad - Notepad written entirely in AutoIt V1.9.4

Feel free to use any of my code for your own use.                                                                                                                                                           Forum FAQ

 

Share this post


Link to post
Share on other sites

Could be line 56.

I don't think that's the problem I think the negative X value on line 428 is more likely the cause of the problem.

"Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the universe trying to build bigger and better idiots. So far, the universe is winning."- Rick Cook

Share this post


Link to post
Share on other sites

Sorry to disagree with you guys. But as Douglas Adams stated: The Answer is 42.


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2017-04-18 - Version 1.4.8.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2017-02-27 - Version 1.3.1.0) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2015-04-01 - Version 0.4.0.0) - Download - General Help & Support - Example Scripts
Excel - Example Scripts - Wiki
Word - Wiki
PowerPoint (2015-06-06 - Version 0.0.5.0) - Download - General Help & Support

Tutorials:
ADO - Wiki

 

Share this post


Link to post
Share on other sites

Sorry to disagree with you guys. But as Douglas Adams stated: The Answer is 42.

 

The answer is clear. The question is what the question is.


Roses are FF0000, violets are 0000FF... All my base are belong to you.

Share this post


Link to post
Share on other sites

#9 ·  Posted (edited)

Post your script, it's easier for us to check what the problem might be. Try using AutoIT original editor and see if it works fine.

Edited by AlisPT

Share this post


Link to post
Share on other sites

Part of my job is to isolate problems in (related to) software.

This issue does not have to do with any particular script, it happens with various scripts. I noticed it today, so I'm not sure yet whether terminatng scripts may start cause it (that's why I pointed what kind of groups/types of operators I use) or something else. It looks as if each script was somehow "cached" by autoit when starting them, and if script is modified - some new values/variables were mixed with that cache. Debugger seems to clear the problem (at stage of use).

The question was whether someone experienced similar issues or whether this can happen in autoit under some "wrong" circumstances.

I will post something when I'm able to isolate some replicable basic routine to play with.


functional testing. multimedia recording. flowstone. mouseclick, hotkeys and modularity in general.

Share this post


Link to post
Share on other sites

#12 ·  Posted (edited)

It looks as if each script was somehow "cached" by autoit when starting them, and if script is modified - some new values/variables were mixed with that cache. Debugger seems to clear the problem (at stage of use).

Nope...there is no way to inject logic|coding into a running script...unless you are reading a file, or some outside source dictates what the script will do and THAT is modified.

Or, if your script is executing another script multiple times, and someone modifies the target script prior to the driver calling it.

Edited by jdelaney

IEbyXPATH-Grab IE DOM objects by XPATH IEscriptRecord-Makings of an IE script recorder ExcelFromXML-Create Excel docs without excel installed GetAllWindowControls-Output all control data on a given window.

Share this post


Link to post
Share on other sites

Consider this. Among constants. there are groups of problems that may happen to host app like autoit, groups of problems that may be present in scripts, and groups of problems that are some in between and ambiguous, and groups of problems that may be related to environment. This is what I'm being taught, and this is the perspective I look through. I don't want to repair any script or "bad routine" here, at least not at the moment; I clearly defined the scope of the question. Maybe I don't know autoit like you, but this is no reason to insult/abuse me in this indirect way you do, don't you think?


functional testing. multimedia recording. flowstone. mouseclick, hotkeys and modularity in general.

Share this post


Link to post
Share on other sites

Nope...there is no way to inject logic|coding into a running script...unless you are reading a file, or some outside source dictates what the script will do and THAT is modified.

Or, if your script is executing another script multiple times, and someone modifies the target script prior to the driver calling it.

 

Thanks for clarification on this part.


functional testing. multimedia recording. flowstone. mouseclick, hotkeys and modularity in general.

Share this post


Link to post
Share on other sites

You list a lot of things that can "happen" there.

Here's another thing that can happen, that is not in your list...

The author of the scripts is useless at it, and that is why all the scripts have seemingly random errors.

If you can not accept that, or at least consider it, then, what is your job title again?


AutoIt Absolute Beginners    Require a serial    Pause Script    Video Tutorials by Morthawt   ipify 

Monkey's are, like, natures humans.

Share this post


Link to post
Share on other sites

It's not random.

Now you are offensive.


functional testing. multimedia recording. flowstone. mouseclick, hotkeys and modularity in general.

Share this post


Link to post
Share on other sites

#17 ·  Posted (edited)

ayatest,

Many people around the world use AutoIt daily and do not seem to suffer the same "random errors" as you appear to see. This suggests to me that the fault is more likely to be in the specific code you use rather then in AutoIt itself. But you are not providing any code samples nor specific instances of the errors you claim to see, so it is completely impossible to offer you any sensible advice on what might be the cause. :(>

While not being as blunt as JohnOne, I share his opinion on the most likely cause being the manner in which the scripts you use have been written. So I suggest you provide some code which we can run to test, because otherwise we are all just wasting bandwidth. To prevent this thread deteriorating further I am locking it - if and when you PM me some code to test I will reopen it. :)

M23

Edited by Melba23
English grammar

Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.