Jump to content
Sign in to follow this  
siva1612

Mouse functions cause Windows 10 to lock

Recommended Posts

I have been using AutoIt scripts in all of the PCs in my office. Some of the PCs are running on Windows 7 and some are in Windows 10. I have this new bug that whenever mouse functions like MouseClick, MouseClickDrag, MouseMove are called, the PC executes the action and then it causes the PC to be locked and the screen blacks out.

This is noticed only in some of the Windows 10 PCs and is NOT noticed in the PCs running Windows 7.  Any idea why?

MouseClick("primary")

MouseMove(10, 100)

MouseClickDrag("primary", 0, 200, 600, 700)

The screen locks even if i execute just one of any of the above three statements

AutoIt version : v3.3.14.2 (tried in v3.3.14.5 as well)

 

Capture.PNG

Edited by siva1612

Share this post


Link to post
Share on other sites

How we are suppose to know what's going wrong ? Look my avatar.

Edited by caramen

My video tutorials : HERE ( In construction )  || My Discord : https://discord.gg/S9AnwHw

How to Ask Help ||  UIAutomation From Junkew || WebDriver From Danp2 || And Water's UDFs in the Quote

Spoiler

 Water's UDFs:
Active Directory (NEW 2018-10-19 - Version 1.4.10.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (2018-10-31 - Version 1.3.4.1) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2017-07-21 - Version 0.4.0.1) - Download - General Help & Support - Example Scripts
PowerPoint (2017-06-06 - Version 0.0.5.0) - Download - General Help & Support
Excel - Example Scripts - Wiki
Word - Wiki
 
Tutorials:

ADO - Wiki

 

Share this post


Link to post
Share on other sites
On 1/21/2019 at 5:05 PM, caramen said:

How we are suppose to know what's going wrong ? Look my avatar.

I had NOT added any code because the problems arise even with just one line of code using any of the mouse function. Anyway added them now to the original post.

Share this post


Link to post
Share on other sites

Post code that can actually be tested. If this were real bug everybody would be complaining about it which it’s not


My resources are limited. You must ask the right questions

 

Share this post


Link to post
Share on other sites

Really weird thing, i've never seen that before.

Is it really only with mouse functions? not with any other?

Could you try running in admin mode? #requireadmin?


Spoiler

Renamer - Rename files and folders, remove portions of text from the filename etc.

GPO Tool - Export/Import Group policy settings.

MirrorDir - Synchronize/Backup/Mirror Folders

BeatsPlayer - Music player.

Params Tool - Right click an exe to see it's parameters or execute them.

String Trigger - Triggers pasting text or applications or internet links on specific strings.

Inconspicuous - Hide files in plain sight, not fully encrypted.

Regedit Control - Registry browsing history, quickly jump into any saved key.

Time4Shutdown - Write the time for shutdown in minutes.

Power Profiles Tool - Set a profile as active, delete, duplicate, export and import.

Finished Task Shutdown - Shuts down pc when specified window/Wndl/process closes.

NetworkSpeedShutdown - Shuts down pc if download speed goes under "X" Kb/s.

IUIAutomation - Topic with framework and examples

Au3Record.exe

Share this post


Link to post
Share on other sites

Admins. Any idea why this is happening?

AutoIt version : v3.3.14.2. It happens even if I run from Scite. The weird thing is I tested this mouse function on 3 PCs all of which have the same configuration in the first post. The locking effect is noticed in two PC and there is NO problem in the 3rd PC. I tried matching things like input keyboard language, region settings, but to no avail.

 

I tried with the latest version v3.3.14.5 as well. but still same error persists

Edited by siva1612

Share this post


Link to post
Share on other sites

Anti-virus kicking in and shutting it down?


If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites
19 minutes ago, BrewManNH said:

Anti-virus kicking in and shutting it down?

I don't think so. The thing is the script continues to run after I have logged into the PC once again, i.e, the process is NOT terminated. If it were the work of the anti-virus, I expect the process will have been terminated.

Is there anyway I can help you recreate the environment, so that anyone can help?

Share this post


Link to post
Share on other sites
3 minutes ago, siva1612 said:

The thing is the script continues to run after I have logged into the PC once again, i.e, the process is NOT terminated.

Login or do you mean the account stays logged-in but you locked the screen with WINDOWS+L?

Jos


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites
1 minute ago, Jos said:

Login or do you mean the account stays logged-in but you locked the screen with WINDOWS+L?

Jos

"Login" is not the correct word. The script continues to run after I've "unlocked" the computer, because the script causes the windows to lock as if I have pressed the Win+L command.

Share this post


Link to post
Share on other sites

Ok, clear, and you state that just one line of your initial post would cause this, so also just this line is a file:

MouseMove(10, 100)

..and then run with SciTE (F5) ?

Jos


SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

Yes, I create a file with just one line of code. And press F5 in Scite. The mouse moves and then the screen locks and also blacks out (i.e., it does NOT show the lock screen, but the display blacks out as it happens after a certain time when the screen is locked, in order to conserve power)

The same happens if I convert it to exe and run the exe.

Share this post


Link to post
Share on other sites

Ah, ok, so it doesn't have the same effect as WIN+L but it simply blacks out the screen and becomes totally unresponsive?
The WIN+L effect only kicks in after the timeout...right?

Edited by Jos

SciTE4AutoIt3 Full installer Download page   - Beta files       Read before posting     How to post scriptsource   Forum etiquette  Forum Rules 
 
Live for the present,
Dream of the future,
Learn from the past.
  :)

Share this post


Link to post
Share on other sites

this statement can't even be run in scite

MouseClickDrag("primary", 0, 200, 600, 700)
 

: error: Statement cannot be just an expression. (illegal character)
MouseClickDrag("primary", 0, 200, 600, 700)

i can't test with anything you've given. You probably have windows issues


My resources are limited. You must ask the right questions

 

Share this post


Link to post
Share on other sites
20 hours ago, Earthshine said:

(illegal character)

Maybe the copy-paste issue that has the Forum adding strange characters? :)


Click here to see my signature:

Spoiler

Thoughts:

  • I will always thank you for the time you spent for me.
    I'm here to ask, and from your response, I'd like to learn.
    By my knowledge, I can help someone else, and "that someone" could help in turn another, and so on.

/*--------------------------------------------------------------------------------------------------------------------------------------------------------------------------*/

ALWAYS GOOD TO READ:

 

Share this post


Link to post
Share on other sites
On 6/28/2019 at 6:12 PM, Jos said:

Ah, ok, so it doesn't have the same effect as WIN+L but it simply blacks out the screen and becomes totally unresponsive?
The WIN+L effect only kicks in after the timeout...right?

No. The screen blacks out. if i move the mouse or press any key then the unlock screen of Windows appears asking me to enter the password.

In other words the effect is the same as pressing Win+L and leaving the screen idle for sometime so that the display blacks out. However, here the screen blacks out without waiting for the idle time i.e. instantaneously.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...