Sign in to follow this  
Followers 0
LondonNDIB

How did I screw this up? Consolewrite no longer outputting in scite

9 posts in this topic

I always used consolewrite to output debugging messages to my UNCOMPILED scripts run with F5 in Scite.

Suddenly, they stopped outputting.  No error, just nothing in the console.

I searched here for help and see plenty of suggestions that a script must be compiled for consolewrite to do anything, but clearly that's not the case as I've been doing it this way for years (right or wrong).

I didn't knowingly change anything, but I figure I must have hit a hotkey somewhere that turned off console output.  I just don't know what that is.

Any ideas?

Share this post


Link to post
Share on other sites



What scite version are you using?


Common sense plays a role in the basics of understanding AutoIt... If you're lacking in that, do us all a favor, and step away from the computer.

Share this post


Link to post
Share on other sites

Nevermind... I just realized a few seconds after posting that it was working in another script.

The difference?   #RequireAdmin.  Console output doesn't show up with #RequireAdmin set

Share this post


Link to post
Share on other sites

Console output doesn't show up with #RequireAdmin set

 

Not really you're right.

Just run the program SciTE as admin, using the right mouse button.

And then run your script.


Signature beginning:   Wondering who uses AutoIT and what it can be used for ?
* GHAPI UDF - modest begining - comunication with GitHub REST API *
ADO.au3 UDF     POP3.au3 UDF     XML.au3 UDF    How to use IE.au3  UDF with  AutoIt v3.3.14.x  for other useful stuff click the following button

Spoiler

Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind. 

My contribution (my own projects): * Debenu Quick PDF Library - UDF * Debenu PDF Viewer SDK - UDF * Acrobat Reader - ActiveX Viewer * UDF for PDFCreator v1.x.x * XZip - UDF * AppCompatFlags UDF * CrowdinAPI UDF * _WinMergeCompare2Files() * _JavaExceptionAdd() * _IsBeta() * Writing DPI Awareness App - workaround * _AutoIt_RequiredVersion() * Chilkatsoft.au3 UDF * TeamViewer.au3 UDF * JavaManagement UDF * VIES over SOAP * WinSCP UDF * GHAPI UDF - modest begining - comunication with GitHub REST API *

My contribution to others projects or UDF based on  others projects: * _sql.au3 UDF  * POP3.au3 UDF *  RTF Printer - UDF * XML.au3 - BETA * ADO.au3 UDF SMTP Mailer UDF *

Useful links: * Forum Rules * Forum etiquette *  Forum Information and FAQs * How to post code on the forum * AutoIt Online Documentation * AutoIt Online Beta Documentation * SciTE4AutoIt3 getting started * Convert text blocks to AutoIt code * Games made in Autoit * Programming related sites * Polish AutoIt Tutorial * DllCall Code Generator * 

Wiki: Expand your knowledge - AutoIt Wiki * Collection of User Defined Functions * How to use HelpFile * Best coding practices * 

IE Related:  * How to use IE.au3  UDF with  AutoIt v3.3.14.x * Why isn't Autoit able to click a Javascript Dialog? * Clicking javascript button with no ID * IE document >> save as MHT file * IETab Switcher (by LarsJ ) * HTML Entities * _IEquerySelectorAll() (by uncommon) * 

I encourage you to read: * Global Vars * Best Coding Practices * Please explain code used in Help file for several File functions * OOP-like approach in AutoIt * UDF-Spec Questions *  EXAMPLE: How To Catch ConsoleWrite() output to a file or to CMD *

"Homo sum; humani nil a me alienum puto" - Publius Terentius Afer
"Program are meant to be read by humans and only incidentally for computers and execute" - Donald Knuth, "The Art of Computer Programming"
:naughty:  :ranting:, be  :) and       \\//_.

Anticipating Errors :  "Any program that accepts data from a user must include code to validate that data before sending it to the data store. You cannot rely on the data store, ...., or even your programming language to notify you of problems. You must check every byte entered by your users, making sure that data is the correct type for its field and that required fields are not empty."

Signature last update: 2017-06-04

Share this post


Link to post
Share on other sites

I was curious about that and realized the same earlier today.  

It is all good.  Once I recognized the issue, I have no problem.

Share this post


Link to post
Share on other sites

Hehe, first thing this morning as I came here to look around was that I learn something, this maybe an okey day after all :)

Share this post


Link to post
Share on other sites

Its rarely a bad thing :)

Share this post


Link to post
Share on other sites

I broke mine a long time back too, but never found the fix.

Works on my other computers but not my work computer where I do most of my scripting :/

Share this post


Link to post
Share on other sites

Maybe a 32-bit vs 64-bit issue?  Purely a guess.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0